Correct spelling of "Maori" is with a macronised "a"

ASSIGNED
Assigned to

Status

()

--
trivial
ASSIGNED
11 years ago
19 days ago

People

(Reporter: konrad, Assigned: smontagu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; mi; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; mi; rv:1.9) Gecko/2008051206 Firefox/3.0

languageNames.properties file has incorrect spelling, "Maori" should be "M\u0101ori". i.e. lowercase "a" with macron

Incorrect spelling manifests whenever human readable form of language code "mi" is used.

Evidence for change is available from the Māori language commission's website
http://www.tetaurawhiri.govt.nz/english/pub_e/conventions2.shtml

Root cause of problem is in the en-US build, but bug exists in other localized builds now.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Assignee: nobody → smontagu
Component: Infrastructure → Internationalization
Product: Mozilla Localizations → Core
QA Contact: infrastructure → i18n
(Assignee)

Comment 1

11 years ago
I tend to WONTFIX, at least for en-US, though other localizations may differ. Even if it's correct to write "Māori" with a macro in Maori, I don't think it's the convention in English. It's not used at either http://www.loc.gov/standards/iso639-2/php/code_list.php or http://www.ethnologue.com/show_language.asp?code=mri

Comment 2

11 years ago
I tend to agree. I've been surfing a bit on the talk pages on wikipedia, too, and there's nothing there that indicates that US English would have changed the spelling.
(Reporter)

Comment 3

11 years ago
Not sure if wikipedia, i.e. en.wikipedia.org qualifies as evidence?  Considering it covers all regions of English and it redirects Maori to Māori, then I could argue that it is an already accepted change that has _not_ been disqualified since.

If however the ISO639 code for Māori was updated, either accepted on parts 1 or 2 maintained by the LoC or part 3 by the SIL, would that be grounds enough to reconsider this bug?

Does approval from a recognized Government agency or Organization of the target locale qualify as enough evidence for change to that locale, in this particular case to en-US?

Comment 4

10 years ago
This would be fine for an en-NZ dictionary, but American English simply does not use foreign diacritics. And despite technological changes that have made them easier to use, their usage has been declining over time. 

http://en.wikipedia.org/wiki/Diaeresis
http://www.informatics.sussex.ac.uk/department/docs/punctuation/node43.html

For example, even the US Department of State calls Côte d'Ivoire "Cote d'Ivoire": https://www.cia.gov/library/publications/the-world-factbook/geos/IV.html

This is not a road I think we want to go down, because if we try to adopt correct orthography for all world languages, it will get arbitrarily complex and will baffle users. 

Workaround: anthropologists and scholars can add correct orthography to their personal dictionaries.

--> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 5

10 years ago
Sorry, thought this was a spelling dictionary bug. My mistake.

Unconfirming. Still opposed to diacritics in American English, though.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.