If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Line in floating block breaks before it reach the right edge of page

RESOLVED DUPLICATE of bug 349760

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 349760
10 years ago
10 years ago

People

(Reporter: arai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ja-JP-mac; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ja-JP-mac; rv:1.9) Gecko/2008051202 Firefox/3.0

Line in block besides floating block inside floating block
breaks before it reach the right edge of page on Firefox 3.0 RC1.
It does not happen on Firefox 2.0.0.14.


Reproducible: Always

Steps to Reproduce:
1. Create an HTML file containing the following HTML:

<html><body>
<div style="float: left; background-color: green; padding: 1em;">
This block is float.
<div style="float: left; width: 100px; height: 100px; background-color: cyan;">This block is float too.</div>
<div style="background-color: yellow;">This line breaks before it rearch the right edge of page.</div>
</div>
</body></html>

2. Open this file in Firefox 3.0 RC1

Actual Results:  
Line in yellow block breaks before it reach the right edge of page.
(it breaks after "the" on my environment)

Expected Results:  
Line in yellow block does not break unless it reach the right edge of page.


It might be caused by patch of bug 255990.
(Reporter)

Comment 1

10 years ago
Created attachment 321403 [details]
test case
This is the result of the heuristic for intrinsic width calculation used in bug 300030 (since we no longer do layout to calculate intrinsic widths for floats).  It was an expected side-effect of that bug.  Note that WebKit behaves the same.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349760
You need to log in before you can comment on or make changes to this bug.