Closed Bug 434192 Opened 13 years ago Closed 13 years ago

Fails to build after make clean on architectures using .s files

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glandium, Assigned: glandium)

References

Details

(Keywords: fixed1.9.0.18)

Attachments

(2 files)

Attached patch patchSplinter Review
The ALL_TRASH variable contains .s files corresponding to .o files ($(OBJS:.$(OBJ_SUFFIX)=.s)), but in some directories where there are .s source files, this means removing source files, which, in turn, leads to failure to build after make clean because of missing source files.

Attached patch fixes the issue.
Attachment #321409 - Flags: review?(benjamin)
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402824
Considering there is a patch here and not there, shouldn't the duplicate be reversed ?
Sorry, yeah, do whatever's easier for you.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 402824
Attachment #321409 - Flags: review?(benjamin) → review+
Duplicate of this bug: 422401
The patch is never landed, right?

Keywords: checkin-needed
Assignee: nobody → mh+mozilla
Status: REOPENED → NEW
Pushed to mozilla-central: https://hg.mozilla.org/mozilla-central/index.cgi/rev/5f9f6eb00601
Status: NEW → RESOLVED
Closed: 13 years ago13 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Flags: blocking1.9.0.16?
r.mozley: There's no way this will block 1.9.0.16. When you nominate, please nominate with rationale. We might consider a patch for this, assuming someone asks for approval and tests said patch on a 1.9.0 tree.
Flags: blocking1.9.0.16? → blocking1.9.0.16-
Sorry about that, I don't know the correct procedure to get this onto the 1.9.0 branch. The patch is already there and was written (I believe) for the 1.9.0 branch.
FYI, this patch has been in use in Debian since 1.9rc1.
Updated the patch for the 1.9.0 branch.
Attachment #414399 - Flags: approval1.9.0.17?
Comment on attachment 414399 [details] [diff] [review]
1.9.0 branch patch

Approved for 1.9.0.16, a=dveditz for release-drivers
Attachment #414399 - Flags: approval1.9.0.17? → approval1.9.0.17+
(dveditz meant 1.9.0.17 as indicated by the appropriate approval flag.)
Checking in config/rules.mk;
/cvsroot/mozilla/config/rules.mk,v  <--  rules.mk
new revision: 3.597; previous revision: 3.596
done
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.