checksetup.pl fails on precompiling templates

RESOLVED DUPLICATE of bug 390442

Status

()

Bugzilla
Installation & Upgrading
--
blocker
RESOLVED DUPLICATE of bug 390442
10 years ago
10 years ago

People

(Reporter: Siarhei, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
checksetup.pl fails on precompiling templates

Step to reproduce:
1) uncompress Bugzilla 2.22.4 installation.
2) run ./checksetup.pl

checksetup.pl fails with the following error:
----------------
Precompiling templates ...
Not a subroutine reference at Bugzilla/Template.pm line 59.
Compilation failed in require at ./checksetup.pl line 1270.
----------------

Perl version:

perl -v

This is perl, v5.10.0 built for i386-linux-thread-multi


The same error exists in 2.20.6. checksetup.pl report the error:
---------------
Precompiling templates ...
Not a subroutine reference at Bugzilla/Template.pm line 54.
Compilation failed in require at ./checksetup.pl line 1230.
---------------
(Reporter)

Comment 1

10 years ago
To continue installation I had to replace lines 59-69 in Bugzilla/Template.pm with the code imported from 3.0.*
------------------------
        if (ref Bugzilla::Constants->$constant) {
            $constants{$constant} = Bugzilla::Constants->$constant;
        }
        else {
            my @list = (Bugzilla::Constants->$constant);
            $constants{$constant} = (scalar(@list) == 1) ? $list[0] : \@list;
        }
------------------------

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390442

Comment 3

10 years ago
As reported in bug 390442 comment 0, we are not going to support Perl 5.10 in Bugzilla 2.20 or 2.22. So in order to use Perl 5.10, you have to install Bugzilla 3.0.2 or higher.
You need to log in before you can comment on or make changes to this bug.