Closed Bug 434210 Opened 16 years ago Closed 14 years ago

Option (alt) dragging text within text fields doesn't copy the selection

Categories

(Core :: Widget: Cocoa, defect, P2)

All
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.3a3

People

(Reporter: poweruser.ml, Assigned: mstange)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.18
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; it; rv:1.9) Gecko/2008051202 Firefox/3.0

On Mac OS X dragging and dropping the selected text in a textarea holding the option (alt) key inserts a copy of the selection in the drop point.
In Firefox 3 it doesn't appen. The text is moved not copied.

Reproducible: Always

Steps to Reproduce:
1. Get a page with a textarea
2. Fill it with some text
3. Select some words
4. Start dragging the selection
5. Hold Option key
6. Drop the selection in another point of the same textarea (keep holdin Option)
Actual Results:  
The selected text is moved

Expected Results:  
The selected text should be copied to the drop point

Using default theme.
In Firefox 2 it worked.
> 1. Get a page with a textarea

Please give a publicly accessible example.
The page is not important. The problem happens with every textarea.
However here's a page: http://www.htmlref.com/examples/chapter12/textarea.html
This doesn't work in Camino 1.6 either, so it seems like a long-standing Cocoa widgets bug (but a regression in Firefox from fx2, where it did work).

It's not just <textarea>s; <input type="text"> is also affected.
Assignee: nobody → joshmoz
Status: UNCONFIRMED → NEW
Component: OS Integration → Widget: Cocoa
Ever confirmed: true
Flags: wanted1.9.0.x?
Keywords: regression
Product: Firefox → Core
QA Contact: os.integration → cocoa
Summary: Option (alt) dragging text within a textarea doesn't copy the selection → Option (alt) dragging text within text fields doesn't copy the selection
Yes, Smokey, it looks like you're right.

And by the way, control-drag works properly (copies text instead of
moving it) on both Windows and Linux, in both Firefox 3 RC 1 and
Firefox 2.0.0.14.
Assignee: joshmoz → smichaud
Priority: -- → P2
No changes in RC2 :(
Confirming this bug in the Version 3 public release, and confirming how very, very annoying it is.  The workaround of course is copy and pasting, but dragging and dropping with the option key down to copy is far more natural and I need it all the time.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

(A different but possibly related feature request:  It would be great to be able to hold down a button to drag a tab's URL into a textarea rather than immediately switch to that tab.  I would use this all the time to get the URL of a site I was visiting in one tab into a post I'm writing in another tab.)
Only wanted1.9.0.x+ pending the size and risk of the fix. This should be wanted1.9.1 though.
Flags: wanted1.9.1?
Flags: wanted1.9.0.x?
Flags: wanted1.9.0.x+
Flags: wanted1.9.1? → wanted1.9.1+
Nothing changed in Firefox 3.0.4 :(
Still seems broken in 3.5.7; I’ve reverted to 2.0.0.20.
I'm afraid I'm not going to be able to get to this anytime soon.
Assignee: smichaud → nobody
Attached patch v1Splinter Review
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #430003 - Flags: review?(Olli.Pettay)
Attachment #430003 - Flags: review?(Olli.Pettay) → review+
Comment on attachment 430003 [details] [diff] [review]
v1

This looks ok to me, but please file followup bugs to fix OSX and Linux drag events to set modifiers.
Depends on: 549891
Hardware: PowerPC → All
Target Milestone: --- → mozilla1.9.3a3
Version: unspecified → Trunk
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Not fixed in 3.6.4, but it is fixed in Developer Preview 3.7a5/1.9.3.
So, this was wanted for 1.9.0 and 1.9.1, and its followup bug, bug 549891, already had its patch nominated for 1.9.2 (needs a rollup patch); any chance we can get this on 1.9.2, too?
You need to log in before you can comment on or make changes to this bug.