Firefox CRASHES trying to connect to Windows Computer running LogMeIn Free Version [@ nsGenericElement::GetParentNode]

RESOLVED WORKSFORME

Status

()

Core
DOM
--
critical
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Norm Gilbert, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

The latest version of Firefox has a problem with http://www.logmein.com such that a user attemtping to use Firefox and LogMeIn to remote control another PC over the Internet will suffer a complete lockup of Firefox and loss of control such that Firefox will need to be force quit. This bug was introduced in the Firefox 3 beta and was not present in earlier versions which worked fine. The bug is unique to Firefox, as SAFARI works flawlessly in this instance.

Reproducible: Always

Steps to Reproduce:
1) Launch Firefox and navigate to http://www.logmein.com
2) Log into my account and see list of computers I can remote control. These computers are running the logmein software. In my case, they are Windows PC's at my business all running WinXP Pro.
3) Select a PC to remote control.
4) LogMeIn displays a User Name and PW dialog normally.
5) Click the REMOTE CONTROL link.
6) I'm not a programmer but I believe logmein will run either a Java application or a Mozilla application to allow me on my Mac to log into and take control of the remote PC.
7) The last thing I usually see before gaining control is the logmein process window. It is this process window that is causing the lockup of Firefox. The symptoms are the spinning beachball of death and complete loss of control of Firefox, necessitating a FORCE QUIT. In this process window, instead of seeing the proper names for the two buttons (DETAILS and CLOSE) I see tmp_dete and tmp_exit or some such thing. The buttons are not functional and Firefox is completely locked up.

Actual Results:  
Firefox is 100% locked up, the spinning beachball of death is on screen. Other applications are not affected and Firfox can be force quit from the dock.

Expected Results:  
The logmein progress bar completes normally, and stays on screen. If progress is going slowly or not completing, I can click on the detail button and see a lower sidebar open with the full log on detils, dialog and log. When handshaking is complete, I can click on CLOSE and have full remote control of my distant PC.

Comment 1

10 years ago
Probably a duplicate of bug 426640.  According to bug 426780 comment 2
they have a new version of the plugin that should work in Firefox 3.
Please install it and try again.
Severity: critical → normal
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Probably a duplicate of bug 426640.  According to bug 426780 comment 2
> they have a new version of the plugin that should work in Firefox 3.
> Please install it and try again.
> 
SORRY Mats I believe you are mistaken. Bug #426640 and all other bugs reported that dela with logmein are for the PeeCee version of both Firefox and the LogMeIn plug in. This bug is for the Mac version of Firefox. It is NOT, confirmed NOT, the logmein plug-in. I disabled the plug in and tried connecting to my pc's via logmein again. It asked if I wanted to install the latest plug in, so I downloaded and installed the latest plug in from logmein.com.

Tried to go to my pc using logmein and Firefox crashed abruptly. Here's the detail from the crash report.

Add-ons: firefox@1passwd.com:2.6.2,{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}:0.9.6.1,{89506680-e3f4-484c-a2c0-ed711d481eda}:0.9.4.8,{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}:0.9.9,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.0,pinstripe_prototype@kmgerich.com:1.0
BuildID: 2008051202
Comments: See bug report for this crash
CrashTime: 1211067257
Email: normg1@adnc.com
InstallTime: 1211053204
ProductName: Firefox
SecondsSinceLastCrash: 14492
StartupTime: 1211053257
Theme: proto
URL: https://pos2-xxlibsshpf.app02.logmein.com/main.html
UserID: ace75805-37d0-4008-9d42-9f0db16791e6
Vendor: Mozilla
Version: 3.0

This report also contains technical information about the state of the application when it crashed.

This is STILL a Firefox bug. Remember, logmein.com works splendidly in Safari. So, if the plug in were the problem, it would also affect Safari too, correct?

Suggest the team get to work finding out the real bug and fixing it. I contacted logmein but they refuse to provide any support for a Beta (now Release Candidate) piece of software. Since logmein works fine in the current official V2 Firefox release, they are apparently waiting for you guys to either fix it or release it with the bug before they'll even look at the situation.
Severity: normal → critical
Keywords: crashreportid

Comment 3

10 years ago
Please enter about:crashes in the URL bar and paste a couple of
Report IDs here.  Thanks.
http://support.mozilla.com/en-US/kb/Firefox+crashes#Mozilla_Crash_Reporter
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Please enter about:crashes in the URL bar and paste a couple of
> Report IDs here.  Thanks.
> http://support.mozilla.com/en-US/kb/Firefox+crashes#Mozilla_Crash_Reporter
> 
e15643b8-2469-11dd-ab10-001321b13766
cec77638-1ee0-11dd-8d60-001cc45a2c28

Comment 5

10 years ago
Mozilla Crash Reports

    * Find a Report
    * Top Crashers

Firefox 3.0b5 Crash Report [@ nsGenericElement::GetParentNode(nsIDOMNode**) ]
ID: cec77638-1ee0-11dd-8d60-001cc45a2c28
Signature: nsGenericElement::GetParentNode(nsIDOMNode**)

    * Details
    * Frames
    * Modules
    * Raw Dump

Signature	nsGenericElement::GetParentNode(nsIDOMNode**)
UUID	cec77638-1ee0-11dd-8d60-001cc45a2c28
Time	2008-05-10 14:48:03-07:00
Uptime	3067
Product	Firefox
Version	3.0b5
Build ID	2008032619
OS	Mac OS X
OS Version	10.5.2 9C7010
CPU	x86
CPU Info	GenuineIntel family 6 model 7 stepping 6
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0xf7fd05
Comments	
Crashing Thread
Frame 	Module 	Signature 	Source
0 	XUL 	nsGenericElement::GetParentNode 	mozilla/content/base/src/nsGenericElement.cpp:203
1 	XUL 	nsHTMLEditor::HideResizers 	mozilla/editor/libeditor/html/nsHTMLObjectResizer.cpp:433
2 	XUL 	nsHTMLEditor::~nsHTMLEditor 	mozilla/editor/libeditor/html/nsHTMLEditor.cpp:187
3 	XUL 	nsEditor::Release 	mozilla/editor/libeditor/base/nsEditor.cpp:171
4 	XUL 	nsCOMPtr_base::~nsCOMPtr_base 	nsCOMPtr.cpp:81
5 	XUL 	nsEditingSession::TearDownEditorOnWindow 	mozilla/editor/composer/src/nsEditingSession.cpp:542
6 	XUL 	nsDocShellEditorData::TearDownEditor 	mozilla/docshell/base/nsDocShellEditorData.cpp:82
7 	XUL 	nsDocShell::FirePageHideNotification 	mozilla/docshell/base/nsDocShell.cpp:1019
8 	XUL 	nsDocShell::FirePageHideNotification 	mozilla/docshell/base/nsDocShell.cpp:1011
9 	XUL 	nsDocShell::CreateContentViewer 	mozilla/docshell/base/nsDocShell.cpp:5975
10 	XUL 	nsDSURIContentListener::DoContent 	mozilla/docshell/base/nsDSURIContentListener.cpp:138
11 	XUL 	nsDocumentOpenInfo::TryContentListener 	mozilla/uriloader/base/nsURILoader.cpp:735
12 	XUL 	nsDocumentOpenInfo::DispatchContent 	mozilla/uriloader/base/nsURILoader.cpp:434
13 	XUL 	nsDocumentOpenInfo::OnStartRequest 	mozilla/uriloader/base/nsURILoader.cpp:280
14 	XUL 	nsHttpChannel::CallOnStartRequest 	mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp:756
15 	XUL 	nsHttpChannel::ProcessNormal 	mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp:938
16 	XUL 	nsInputStreamPump::OnStateStart 	mozilla/netwerk/base/src/nsInputStreamPump.cpp:439
17 	XUL 	nsInputStreamPump::OnInputStreamReady 	mozilla/netwerk/base/src/nsInputStreamPump.cpp:395
18 	XUL 	nsInputStreamReadyEvent::Run 	mozilla/gfx/cairo/cairo/src/cairo-hull.c:107
19 	XUL 	nsThread::ProcessNextEvent 	mozilla/xpcom/threads/nsThread.cpp:510
20 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:180
Component: General → DOM
Keywords: crashreportid → crash
Product: Firefox → Core
QA Contact: general → general
Summary: Firefox CRASHES trying to connect to Windows Computer running LogMeIn Free Version → Firefox CRASHES trying to connect to Windows Computer running LogMeIn Free Version [@ nsGenericElement::GetParentNode]
Version: unspecified → Trunk
Something to do with bug 364719? (just a guess)
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/editor/libeditor/html/nsHTMLObjectResizer.cpp&rev=1.31&mark=433#433

Regression range and a *minimal* testcase would be great.
Nightly builds http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/ are useful
to find regression range.

(In reply to comment #2)
> So, if the plug in were the problem, it would also affect Safari too, correct?
That is not correct, although often likely.
(Reporter)

Comment 7

10 years ago
Is anyone working on fixing this bug? I'm not a programmer so can someone tell me what a regression range is and how to provide one. What would help you guys get this fixed?

Comment 8

10 years ago
Regression range = when it broke.  You can help us find it by testing
nightly builds from 
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/
(in the "2008" folder most likely)
A good start would be to test builds before and after bug 364719 landed,
that is 2008-01-21.  Ideal would be if you can narrow it down to two
consecutive builds, the first which is working, the second which crashes,
then we can look at which code changes were done between those builds.
(Reporter)

Comment 9

10 years ago
I do believe it broke in the very first beta of 3 . . . many many months ago. Let me see if I can find an old build and test it.
(Reporter)

Comment 10

10 years ago
I downloaded and ran Minefield from 1/16/2008 and the problem with logmein.com is present in that build. Hope that helps. Anyone know the very first date 3.0 beta was released. I'd like to test that release against the 2.x release that works fine.
FYI, 3.0b1 is dated 2007-11-09.

Comment 12

7 years ago
this crash might be nsGenericElement::GetParentNode(nsIDOMNode**) but they end at 3.0b4. bp-56748c4f-8e79-421d-b1d2-303d22110303 is an example

and I've recently used logmein without crashing, except for a java update that was needed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsGenericElement::GetParentNode]

Comment 13

6 years ago
(In reply to Mats Palmgren [:mats] from comment #8)
> Regression range = when it broke.  You can help us find it by testing
> nightly builds from 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/
> (in the "2008" folder most likely)
> A good start would be to test builds before and after bug 364719 landed,
> that is 2008-01-21.  Ideal would be if you can narrow it down to two
> consecutive builds, the first which is working, the second which crashes,
> then we can look at which code changes were done between those builds.

For me, this has broken after I uninstalled and installed again the 64-bit(includes 32-bit) version of latest FLASH PLAYER.

Comment 14

6 years ago
Filip,

Build 928 of the LogMein plugin had a bug in it, which could trigger a crash in certain Firefox configurations, this might be what you've experienced. We've identified and fixed the bug, a new fixed version will be available shortly.

Thanks.

Comment 15

6 years ago
(In reply to Tibor Biczo from comment #14)
> Filip,
> 
> Build 928 of the LogMein plugin had a bug in it, which could trigger a crash
> in certain Firefox configurations, this might be what you've experienced.
> We've identified and fixed the bug, a new fixed version will be available
> shortly.
> 
> Thanks.

Thank You. Re-installed the LogMeIn plugin.
WORKSFORME. (both in Nightly x64 and Firefox 12 win32)
Tibor, which version(s) of the plugin is broken?
You need to log in before you can comment on or make changes to this bug.