Closed Bug 43449 Opened 22 years ago Closed 22 years ago

aCC A.03.15 compiler issue

Categories

(SeaMonkey :: Build Config, defect, P3)

HP
HP-UX
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 65664

People

(Reporter: jdunn, Assigned: mozilla)

References

Details

the aCC compiler (A.03.15) that comes with the 4/00 ACE pack
for HPUX 11.00 has a known issue that causes builds to fail.

The problem is:  CR JAGad04044
Error 229 overloading error occurs due to unrelated lines

but should be fixed in A.03.26

it is encountered when building
layout/xul/base/src/nsTitledButtonFrame.cpp

and the work around is to remove the operator+ member
function from the class nsPromiseConcatenation<CharT>

Index: nsAReadableString.h
===================================================================
RCS file: /cvsroot/mozilla/xpcom/ds/nsAReadableString.h,v
retrieving revision 1.60
diff -r1.60 nsAReadableString.h
901c901
<       nsPromiseConcatenation<CharT> operator+( const basic_nsAReadableString
<CharT>& rhs ) const;
---
> //JDUNN      nsPromiseConcatenation<CharT> operator+( const
basic_nsAReadableString<CharT>& rhs ) const;
1001a1002
> /*
1009c1010
<
---
> */
This is really just a tracking bug till we get the patch
Blocks: 18687
Status: NEW → ASSIGNED
QA Contact: granrose → barrettl
Summary: aCC A.03.15 compiler issue → aCC A.03.15 compiler issue
Target Milestone: --- → M30
another workaround is to remove the +p from compile line

CXX = aCC -ext +DA1.1 +DS2.0
No longer blocks: 18687
updating dependency and reassigning to john since he
will be working with Frank to get the 3.25 compiler going.
Assignee: jdunn → jgaunt
Blocks: 18688
Status: ASSIGNED → NEW
Blocks: 18687
No longer blocks: 18688
we have the 3.25 compiler, this problem still exists. If you compile with the +p 
option you get the overload error and it will not build. The work around still 
works.

Jim has it that the 3.26 compiler fixes the problem, but I have yet to talk with 
frank about it.
Status: NEW → ASSIGNED
dbaron checked in a fix for this into the trunk last night.
Marking this as a dup of 65664.

So for trunk builds you can (and should) go back to having a +p in the CXX var

*** This bug has been marked as a duplicate of 65664 ***
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Hmmm.  Was my change really related to this?  Or is an additional fix based on
the autoconf test needed?  (What was the compiler error?)
DOH!  maybe this wasn't a dup of your stuff...  For some reason I thought
it was since both were related to +p... I could be wrong.  In any event
the bug is fixed.
verified dup......... or fixed...... or whatever jim says it is.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.