MLK: 36 bytes leaked CSS leak - startup/shutdown

VERIFIED FIXED in M16

Status

()

P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: bruce, Assigned: attinasi)

Tracking

({memory-leak, verifyme})

Trunk
memory-leak, verifyme
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 4/24: requested verification by reporter or assigned engineer. waiting for apprunner document leaks to be fixed)

(Reporter)

Description

20 years ago
Build, pull from March 28, 1999.  Happens in apprunner startup/shutdown process
with only default chrome loading.

MLK: 36 bytes leaked in 2 blocks
  * This memory was allocated from:
        malloc         [rtlib.o]
        __bUiLtIn_nEw  [libgcc.a]
        __builtin_new  [rtlib.o]
        __bUiLtIn_vEc_nEw [libgcc.a]
        __builtin_vec_new [rtlib.o]
        nsString::EnsureCapacityFor(int) [nsString.cpp:314]
        nsString::nsString(const nsString&) [nsString.cpp:210]
        nsFont::nsFont(const nsFont&) [nsFont.cpp:45]
        nsStyleFont::nsStyleFont(const nsFont&,const nsFont&)
[nsStyleContext.cpp:49]
        StyleFontImpl::StyleFontImpl(const nsFont&,const nsFont&)
[nsStyleContext.cpp:57]

StyleContextImpl::StyleContextImpl(nsIStyleContext*,nsIAtom*,nsISupportsArray*,n
sIPresContext*) [nsStyleContext.cpp:913]

NS_NewStyleContext(nsIStyleContext**,nsIStyleContext*,nsIAtom*,nsISupportsArray*
,nsIPresContext*) [nsStyleContext.cpp:1514]

StyleSetImpl::GetContext(nsIPresContext*,nsIStyleContext*,nsIAtom*,nsISupportsAr
ray*,int,int&) [nsStyleSet.cpp:453]

StyleSetImpl::ResolveStyleFor(nsIPresContext*,nsIContent*,nsIStyleContext*,int)
[nsStyleSet.cpp:546]

nsPresContext::ResolveStyleContextFor(nsIContent*,nsIStyleContext*,int,nsIStyleC
ontext**) [nsPresContext.cpp:384]

nsCSSFrameConstructor::ResolveStyleContext(nsIPresContext*,nsIFrame*,nsIContent*
,nsIAtom*,nsIStyleContext**) [nsCSSFrameConstructor.cpp:2838]

nsCSSFrameConstructor::ConstructFrame(nsIPresContext*,nsIContent*,nsIFrame*,nsAb
soluteItems&,nsFrameItems&,nsAbsoluteItems&,nsAbsoluteItems&)
[nsCSSFrameConstructor.cpp:2861]

nsCSSFrameConstructor::ProcessChildren(nsIPresContext*,nsIContent*,nsIFrame*,nsA
bsoluteItems&,nsFrameItems&,nsAbsoluteItems&,nsAbsoluteItems&)
[nsCSSFrameConstructor.cpp:275]

nsCSSFrameConstructor::ConstructDocElementFrame(nsIPresContext*,nsIContent*,nsIF
rame*,nsIStyleContext*,nsIFrame*&,nsAbsoluteItems&)
[nsCSSFrameConstructor.cpp:1456]

nsCSSFrameConstructor::ContentInserted(nsIPresContext*,nsIContent*,nsIContent*,i
nt) [nsCSSFrameConstructor.cpp:3318]

StyleSetImpl::ContentInserted(nsIPresContext*,nsIContent*,nsIContent*,int)
[nsStyleSet.cpp:747]
        PresShell::InitialReflow(int,int) [nsPresShell.cpp:850]
        XULDocumentImpl::StartLayout() [nsXULDocument.cpp:3088]
        XULDocumentImpl::EndLoad() [nsXULDocument.cpp:1413]
        XULContentSinkImpl::DidBuildModel(int) [nsXULContentSink.cpp:426]
        CWellFormedDTD::DidBuildModel(unsigned
int,int,nsIParser*,nsIContentSink*) [nsWellFormedDTD.cpp:288]
        nsParser::DidBuildModel(unsigned int) [nsParser.cpp:443]
        nsParser::ResumeParse(nsIDTD*) [nsParser.cpp:760]
        nsParser::OnStopBinding(nsIURL*,unsigned int,const unsigned short*)
[nsParser.cpp:984]
        nsDocumentBindInfo::OnStopBinding(nsIURL*,unsigned int,const unsigned
short*) [nsDocLoader.cpp:1806]
  * Block of 18 bytes (2 times); last block at 0x7641a0
(Reporter)

Comment 1

20 years ago
Probably caused by 4336.

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M5

Comment 2

20 years ago
Apprunner is currently leaking the entire document. Deferring until I can even
see these leaks again...

Updated

20 years ago
Whiteboard: suspect leaks have been fixed

Comment 3

20 years ago
It seems that RDF generated documents are *still* leaking entirely, not
suprising that all the style data leaks with them. Deferring again until major
leaks are corrected in apprunner.

Updated

20 years ago
Whiteboard: suspect leaks have been fixed → waiting for apprunner document leaks to be fixed

Updated

20 years ago
Target Milestone: M10 → M11

Comment 4

19 years ago
Pushing off non-beta 1 issues
(Reporter)

Updated

19 years ago
Depends on: 13283

Updated

19 years ago
Summary: MLK: CSS leak → MLK: 36 bytes leaked CSS leak - startup/shutdown

Updated

19 years ago
Blocks: 14516

Comment 5

19 years ago
Reassigning peterl's bugs to myself.

Comment 6

19 years ago
Accepting peterl's bugs that have a Target Milestone

Comment 7

19 years ago
Pushing my M15 bugs to M16

Updated

19 years ago
Keywords: mlk

Comment 8

19 years ago
Block-moved memory leaks to attinasi
Assignee: pierre → attinasi
Status: ASSIGNED → NEW
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

19 years ago
These leaks ae not showing up in latest leak logs or recent Purify run. Marking 
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Keywords: verifyme

Comment 10

19 years ago
Mark or Bruce:

I am unable to verify leaks. Could one of you please marked this as verified? 
Thanks
Whiteboard: waiting for apprunner document leaks to be fixed → 4/24: requested verification by reporter or assigned engineer. waiting for apprunner document leaks to be fixed

Comment 11

19 years ago
Verified per Marc's comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.