Closed Bug 434872 Opened 14 years ago Closed 14 years ago

[10.5] "Corporate Announcements" applet does not play

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED INCOMPLETE

People

(Reporter: marcia, Unassigned)

References

()

Details

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0.

STR:
1. Visit the site. 
2. Observe no content shows under "Corporate Announcements"

I have Java Embedding Plugin 0.9.6.4 installed on this machine. On my mac mini running Leopard I have JEP 0.9.6.3 and I see the content. The content shows fine using the latest nightly on Tiger.
I can't reproduce.

I tested with Firefox 3.0 RC 1 on both Tiger and Leopard.  Both bundle JEP 0.9.6.4, and both will (therefore) use that version, even if a different version is installed in /Library/Internet Plug-Ins/.

I'd bet reloading the page will clear up this problem.
OK, I will try with a new profile. I did reload the page dozens of times with no change. My machine recently melted down so this is relatively new installation of Leopard and I am just now building up my machine back to what it was.
I have Java Embedding Plugin 0.9.6.4 on 10.4, and don't see that content either; build ID: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008052004 Minefield/3.0pre
I wonder if the content is only intermittently available from the servers.

If possible, please also test on other platforms (or in Safari).
Works for me on IE 7 (Vista), and Safari 2.0.4 (older version on 10.4, which I need for webdev testing).
Marcia and Stephen:  Do you _never_ see the content (in Firefox 3 RC 1 on OS X), or sometimes see it?
Stephen:  If you test on Safari, please also test immediately afterwards, on the same machine, in Firefox 3 RC 1 (and vice versa).
Also, I assume you're both using the default Java version (J2SE 5.0).
And please report any errors you see in the Java Console.
Here is some updated information from the various machines where I loaded the site:

Machine 1: PPC Mac in the Lab running 10.5.1
Java Version: 1.5.0.13 from Apple Computer, Inc.
The content loads fine in Safari but has never show up in Firefox RC1 candidate despite numerous page refreshes.

Machine 2: Intel Mac mini running Leopard 10.5.2
Java Version: 1.5.0.13 from Apple Computer, Inc.
The site did not load initially but it when I switched back to the machine using the KVM switch the content displayed.

Machine 3: Macbook Pro running Leopard 10.5.2
Java Version: 1.5.0.13 from Apple Computer, Inc.
The content loads fine in Safari but has never shown up in Firefox RC1 candidate despite numerous page refreshes.

I don't see any errors in the console on any of the machines.

I can reproduce the bug running the latest nightly on
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008052004 Minefield/3.0pre
Java version using the Java Embedding plugin 0.9.6.4
Marcia:

Running "java -version" from Terminal doesn't tell you what version of
Java you're using to run applets.  Instead you need to run Java
Preferences (in /Applications/Utilites/Java/) and see what "Java
version" is specified there.  The default is "J2SE 5.0".

The Java Console isn't the same as the system Console.  To see the
Java Console, run Java Preferences, click on the Advanced tab, and
then choose "Show console" under "Java console".
One more thing:

Those of you who see this problem on a given machine, please check to see if you can load _any_ Java applets on that machine (in Firefox 3 RC 1 or a current Minefield nightly).

Here's a very simple applet to test with (Sun's Clock applet):

http://java.sun.com/applets/jdk/1.4/demo/applets/Clock/example1.html
Steven: thanks for the helpful tips in Comment 12. The version reported in Java Preferences is J2SE 5.0. When I run the Java console I see the following error reported on my machine: SecurityException occured:access denied (java.net.SocketPermission www.bseindia.com:80 connect,resolve)
News refresh over
Interesting.  Here's what I see in my Java Console (the 2nd and 3rd lines are broken, because they're otherwise too long):

[starting up Java Applet Security @ Wed May 21 21:02:28 CDT 2008]
Wed May 21 21:02:29 CDT 2008 JEP creating applet bse_ticker
  (http://bseindia.com/applet/ticker/)
Wed May 21 21:02:30 CDT 2008 JEP creating applet NewsScroller
  (http://bseindia.com/applet/announce/)
434
Done from WebBase init
News refresh over

I can't explain the difference.

Do you have any proxy settings?  (I don't.)

They'd be under Advanced : Network : Settings (for Firefox) and Network : Advanced : Proxies (for the OS).
No, I do not have any proxy settings set. I just checked the latest candidate Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0 and the problem persists. Same deal using the equivalent build on Tiger. 
I just tried this bug's URL again with FF 3 RC 3 (on OS X 10.5.3) --
no problems.

There currently isn't enough information here to do anything with, so
I'm going to mark this bug incomplete.  It can be reopened if/when we
get more information.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → INCOMPLETE
WFM with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090726 Minefield/3.6a1pre too.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.