If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

delete/rename imap folder doesn't show in the UI until collapse/expand

VERIFIED FIXED in mozilla1.9

Status

MailNews Core
Backend
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

({regression})

Trunk
mozilla1.9
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.02 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
I can't believe this isn't filed somewhere, but if I delete an imap folder, so that it goes under the trash, the change isn't reflected in the UI until I restart. I believe this is a regression from some of the frozen linkage work. Patch upcoming.
(Assignee)

Comment 1

10 years ago
Created attachment 321879 [details] [diff] [review]
proposed fix
Attachment #321879 - Flags: superreview?(neil)
Attachment #321879 - Flags: review?(neil)
> I can't believe this isn't filed somewhere

You are right. Bug 399769 is report of phenomenon when rename, and Bug 409839 is report of phenomenon when new folder creation. (Assigned To: of both bug is set to you).
Will your patch resolve new folder creation case(Bug 409839) too?

> the change isn't reflected in the UI until I restart

"fold IMAP account then expand IMAP account again" was sufficient when I execute duplication test of Bug 399769 and Bug 409839 with Gmail IMAP. Restart of Thunderbird is really required?

Comment 3

10 years ago
Comment on attachment 321879 [details] [diff] [review]
proposed fix

Ah yes, the delightful bug 379070... I remember double-checking some of the patches, but I gave up as there were too many :-(
Attachment #321879 - Flags: superreview?(neil)
Attachment #321879 - Flags: superreview+
Attachment #321879 - Flags: review?(neil)
Attachment #321879 - Flags: review+
(Assignee)

Comment 4

10 years ago
you're right, collapse/expand of imap account is sufficient, since that redoes folder discovery, but most users would not discover that.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Duplicate of this bug: 399769
(Assignee)

Updated

10 years ago
Duplicate of this bug: 409839
(Assignee)

Comment 7

10 years ago
thx for finding the other bugs, WADA - I've marked them as dups.

Updated

10 years ago
Blocks: 379070
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
Summary: delete/rename imap folder doesn't show in the UI until restart → delete/rename imap folder doesn't show in the UI until collapse/expand
Target Milestone: --- → mozilla1.9
Tested with Name=Thunderbird,Version=3.0a2pre,BuildID=2008052203 on MS Win-XP SP2, with Gmail IMAP. Original folder pane refresh problem when delete/create/rename of IMAP subfolder has been resolved.
==> VERIFIED.

However, some remaining issues are observed with Gmail IMAP.
 a. When move to Trash model(not to [Gmail]/Trash, to standard IMAP Trash folder
    which is displayed as label of [IMAP]/Trash at Gmail Web),
    deleted IMAP subfolder in Trash didn't disappear from Trash folder
    after "Empty Trash", as original problem of this bug.
    "Collapse then expand" of Gmail IMAP account was required to clear
    Trash folder content display at folder pane.
 b. When folder name has some non-ascii chars, error message of "unknown folder"
    appeared, although rename itself looks to be successful. (with Gmail IMAP)
I'll open separate bugs if these are Tb's problem instead of Gmail IMAP bug.

(Off-Topic)
This bug is a new evidence that my theory of "'David has come' means 'Mail bug will be solved very soon or at a glance'" is valid. :-)
Status: RESOLVED → VERIFIED

Comment 9

9 years ago
(In reply to comment #4)
> you're right, collapse/expand of imap account is sufficient, since that redoes
> folder discovery, but most users would not discover that.
Pun intentional? ;-)
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.