Implement interface for viewing RSS feeds as a content page

RESOLVED DUPLICATE of bug 415372

Status

enhancement
RESOLVED DUPLICATE of bug 415372
11 years ago
11 years ago

People

(Reporter: lee_fur_pool, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

While coming to this page:
http://groups.google.com/group/mozilla.dev.apps.seamonkey/feed/rss_v2_0_msgs.xml
Seamonkey was not able to open it up. It says that the XML file does not have any style information associated with it.

On the other hand, this XML file can be successfully opened using IE7 and Firefox 2.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://groups.google.com/group/mozilla.dev.apps.seamonkey/feed/rss_v2_0_msgs.xml using the address bar.
Actual Results:  
It displays a message that the invoked XML file does not have any style information associated with it. Therefore, the page cannot be displayed properly. Instead of showing the correct page, it displays the document's XML codes.

Expected Results:  
It should display the page properly, as it does in IE7 and Firefox 2
This page is an RSS feed. Firefox and IE have special code for handling these feeds, among which a feature which "prettifies" the XML code when accessed directly.

SeaMonkey has no RSS code so far (AFAICT), it falls back to treating this page as just any XML page. Now "how to display a random XML page" must be defined in an associated style sheet: unlike HTML, XML makes no assumption about what to display. Since there is no associated style sheet, SeaMonkey displays the raw XML code, with a warning.

I'm changing the Summary to what the Reporter seems to want in this particular case, since it would be INVALID to want every XML page to display as "other than raw source" even in the absence of a stylesheet.

Wendy: Don't set your hopes too high, I expect this bug to end up WONTFIX.
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All
Summary: Seamonkey fails to open XML page → Implement interface for viewing RSS feeds as a content page
Version: unspecified → Trunk

Comment 2

11 years ago
We're planning to implement a "feed preview" like Firefox has, probably for SeaMonkey 2 (not alpha, though). This would solve your case here, making this a duplicate of bug 415372.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415372
You need to log in before you can comment on or make changes to this bug.