Improper right click handling on Google Maps on Mac/Windows.

RESOLVED DUPLICATE of bug 426643

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 426643
10 years ago
9 years ago

People

(Reporter: Disorn Homchuenchom, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9pre) Gecko/2008052100 Camino/2.0a1pre (like Firefox/3.0pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9pre) Gecko/2008052100 Camino/2.0a1pre (like Firefox/3.0pre)

Right click handling on Google Maps is improperly. On Mac, I cannot use touchpad right click on Google Maps. When forced right click is used (use CTRL+click), a default right click context is shown above a Google Maps context menu. This situation also occurs on Windows right click.

Reproducible: Always

Steps to Reproduce:
1. Go to Google Maps. (http://maps.google.com)
2. Right click on map region.
Actual Results:  
For Mac with touchpad, nothing happens. If forced right click is used, a default context menu is shown over a Google Maps own context menu.
For Windows, it gets the same result like the forced right click on Mac.

Expected Results:  
Only Google Maps context menu should be shown.

Even I use Camino to file this bug, it occurs on both Camino and Firefox.
I don't know whether other platforms also suffers with this bug.

Safari 3 works fine.

Comment 1

10 years ago
There's Bug 426643 for this in Firefox.  That's a Mac only bug.  It's probably a core bug which would be why Camino is affected.

>This situation also occurs on Windows right click.

Do you have dom.event.contextmenu.enabled set to false on Windows?  I only see this behavior on Windows with that pref set to false.  Which that is not a bug.  
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> 
> Do you have dom.event.contextmenu.enabled set to false on Windows?  I only see
> this behavior on Windows with that pref set to false.  Which that is not a bug. 
> 

I've set it via a JavaScript exception dialog. If I reenable it again, it works fine (right click by mouse/forced right click). But a normal right click tap using Touchpad still doesn't work.

Comment 3

10 years ago
It's not just touchpads, either.  I have a 3-button mouse (Microsoft, if it matters) plugged into a G4 Mac mini, and right-clicking doesn't work.  Ctrl-LeftClick works, but if I have a proper multi-button mouse, shouldn't the other buttons work?  Right-click worked properly in Firefox 2, and it continues to work in Safari.

I've not tested on Windows or Linux to see if Firefox 3 on those platforms exhibits the same behavior, but I can confirm that something's broken in Firefox 3 on Mac OS X.

(I normally have dom.event.contextmenu.enabled set to false on my computers because some websites abuse handling of that event (such as to block saving images).  The very top edge of Google's context menu appears slightly above Firefox's context menu; clicking on that little bit that's exposed will dismiss the Firefox menu while leaving the Google menu up for you to select an item.)

Comment 4

9 years ago
Let me clarify how this works for me. Ctrl + clicking on the map works correctly. Tapping with 2 fingers on the trackpad (which should be a right click) does not work. Holding 2 fingers on the trackpad and clicking the button also doesn't work.

All three of these methods work perfectly when using Safari.

Comment 5

9 years ago
I just noticed that I didn't specify that I am using Mac OS X.
The underlaying problem that the context menu doesn't come up when using the touchpad is covered by bug 426643. The other issue mentioned in comment 0 is just a setting inside the preferences and can be fixed by yourself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: General → Menus
OS: Mac OS X → All
QA Contact: general → menus
Hardware: PowerPC → All
Resolution: --- → DUPLICATE
Version: unspecified → 3.0 Branch
Duplicate of bug: 426643
You need to log in before you can comment on or make changes to this bug.