If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Consistent Crash in nsHTMLReflowState::GetNearestContainingBlock when visiting site

VERIFIED FIXED

Status

()

Core
Layout
--
major
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: marcia, Assigned: roc)

Tracking

({crash})

Trunk
crash
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [RC2+] Patch in Bug 398332 will fix this, URL)

(Reporter)

Description

10 years ago
Seen while testing Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0.

STR:
1. Visit the site using any OS.
2. Crash

Breakpad: http://crash-stats.mozilla.com/report/index/409dadee-2757-11dd-8fe2-001321b13766?p=1
Probably related to bug 398332 and bug 410198, I guess.

But now we have a real site that is actually crashing with this stacktrace, which is bad.
Depends on: 398332
OS: Mac OS X → All
(Reporter)

Comment 2

10 years ago
I don't see the crash using IE or Safari.
Does the pathc in bug 398332 help?
(Reporter)

Comment 4

10 years ago
I would need a tryserver build with that patch to test unless someone else in QA can build with that patch.
Yes, the WIP patch in bug 398332 seems to fix the crash.
Is that WIP patch safe to go into the tree?
Flags: blocking1.9?

Updated

10 years ago
Duplicate of this bug: 435258
Flags: blocking1.9.0.1+
Whiteboard: [RC2?]

Updated

10 years ago
Whiteboard: [RC2?] → [RC2?][RC2+]

Comment 8

10 years ago
(In reply to comment #6)
> Is that WIP patch safe to go into the tree?
> 

Well it's WIP and non reviewed.  So not yet.  If you can roc can work up a safe and reviewed fix we'd probably take it.
I put a patch in bug 398332 that fixes this.
Assignee: nobody → roc

Updated

10 years ago
Whiteboard: [RC2?][RC2+] → [RC2?][RC2+] Patch in Bug 398332 will fix this
Hardware: PC → All
Flags: wanted1.9.0.x+
Flags: wanted1.9.0.x+
Flags: blocking1.9?
Flags: blocking1.9.0.1+
Flags: blocking1.9+
Whiteboard: [RC2?][RC2+] Patch in Bug 398332 will fix this → [RC2+] Patch in Bug 398332 will fix this
That patch was checked in.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008052816 Minefield/3.0pre and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008052817 Firefox/3.0pre (Debug Builds with this Patch included).

No Crash on the Motortrend.com site --> Verified fixed
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.