If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RSS feeds load REALLY slowly in Firefox 3

RESOLVED DUPLICATE of bug 329534

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 329534
10 years ago
8 years ago

People

(Reporter: btflmalegod@gmail.com, Unassigned)

Tracking

({perf, testcase})

Trunk
x86
Windows XP
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008052006 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008052006 Minefield/3.0pre

When opening Firefox 3, it doesn't normally load up like it's supposed to. Live Bookmarks (AKA "RSS feeds"), for some reason, are taking FOREVER to load up, causing one to have to wait 3 to 4 minutes for the browser to load up, and the browser just works in slow motion.

Reproducible: Always

Steps to Reproduce:
Click on the shortcut to open Firefox 3
Actual Results:  
It takes 3 to 4 minutes for the browser to load up, and the browser just works in slow motion.

Expected Results:  
Firefox 3 should just load up like it's supposed to.

This problem is present in the release candidate of Firefox 3 (FF 3.0rc1) and the latest Minefield nightlies. The problem also disappears when you delete every single Live Bookmark (AKA "RSS feed") from the bookmarks section.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
How much feed links do you have? Can you test this problem in Safe Mode or in a new blank profile?

Comment 2

10 years ago
can you provide the link to the slow RSS?
(Reporter)

Comment 3

10 years ago
Let's put it this way: I created a new profile, and the only thing in there was my bookmarks, which included the Live Bookmarks (AKA "RSS feeds"). The same exact thing happened. The same stuff is in Firefox 2, and I've never had a problem at all.

(In reply to comment #1)
> How much feed links do you have? Can you test this problem in Safe Mode or in a
> new blank profile?
> 

Can you post your feed links?

Anyway, try moving your bookmark file away from profile dir and importing it.
(Reporter)

Comment 5

9 years ago
I imported it from a separate location, so the latter doesn't apply to me. As to the former, I made sure to update or get rid of Livemark links that were dead, and I'm still having a problem. It's like all the RSS feeds want to load up at the same time. Weird.

BTW: This problem pops up, I've now found, in FF 3.0rc2.

(In reply to comment #4)
> Can you post your feed links?
> 
> Anyway, try moving your bookmark file away from profile dir and importing it.
> 

Ok, but feeds work for me, and if you don't provide us your feed urls (or at least some of them) we can not try to reproduce your bug.
(Reporter)

Comment 7

9 years ago
Okay, here you go:

http://blog.myspace.com/justalice
http://news.bbc.co.uk/go/rss/-/2/hi/default.stm
Broadcasting & Cable
http://www.broadcastingcable.com/
http://www.broadcastingcable.com/blog/1380000138.html?nid=3349
http://www.broadcastingcable.com/blog/1640000164.html?nid=3350
http://www.broadcastingcable.com/community/Programming/47168.html?nid=3341
http://www.broadcastingcable.com/community/Local+TV/47169.html?nid=3342
http://www.broadcastingcable.com/community/Washington/47170.html?nid=3343
http://www.broadcastingcable.com/community/Business+and+Deals/47171.html?nid=3344
http://www.broadcastingcable.com/community/Advertising/47172.html?nid=3345
http://www.broadcastingcable.com/community/Syndication+%26+Distribution/47173.html?nid=3346
http://www.broadcastingcable.com/community/Technology/47174.html?nid=3347
http://www.broadcastingcable.com/community/Fates+%26+Fortunes/47181.html?nid=3348
http://www.broadcastingcable.com/blog/50000405.html?nid=3795
http://www.broadcastingcable.com/blog/60000406.html?nid=3796
http://www.news.com/
CNN.com
http://www.cnn.com/?eref=rss_topstories
http://www.cnn.com/WORLD/?eref=rss_world
http://www.cnn.com/US/?eref=rss_us
http://www.cnn.com/POLITICS/?eref=rss_politics
http://www.cnn.com/LAW/?eref=rss_law
http://www.cnn.com/TECH/?eref=rss_tech
http://www.cnn.com/TECH/space/?eref=rss_space
http://www.cnn.com/HEALTH/?eref=rss_health
http://www.cnn.com/SHOWBIZ/?eref=rss_showbiz
http://www.cnn.com/TRAVEL/?eref=rss_travel
http://topics.cnn.com/topics/feeds/rss/Education
http://www.cnn.com/offbeat/?eref=rss_offbeat
http://www.cnn.com/mostpopular/?eref=rss_mostpopular
http://www.cnn.com/?eref=rss_latest
CNN Money
http://money.cnn.com/rssclick/?section=money_latest
http://money.cnn.com/rssclick/?section=money_topstories
http://money.cnn.com/rssclick/markets/?section=money_markets
http://money.cnn.com/rssclick/news/economy/?section=money_news_economy
http://money.cnn.com/rssclick/news/international/?section=money_news_international
http://money.cnn.com/rssclick/pf/?section=money_pf
http://money.cnn.com/rssclick/technology/?section=money_technology
http://money.cnn.com/rssclick/commentary/?section=money_commentary
http://money.cnn.com/rssclick/mostpopular/?section=money_mostpopular
http://theblunttruthaboutcnn.blogspot.com/
http://whatshappeningatcnn.blogspot.com/
http://blog.myspace.com/davebarnes
http://drdot.blog-city.com/
E! Online
News
http://www.eonline.com/
http://www.eonline.com/
http://www.eonline.com/
http://www.eonline.com/
http://www.eonline.com/
http://www.eonline.com/
http://www.eonline.com/redcarpet/
Gossip
http://www.eonline.com/gossip/awful/
http://www.eonline.com/gossip/kristin/
http://www.eonline.com/hwood_party_girl/index.html
http://www.eonline.com/ask_the_answer_bitch/index.html
http://www.eonline.com/marc_malkin/index.html
http://www.eonline.com/celebrities/
http://www.eonline.com/
Movies
http://www.eonline.com/lyons_den/index.html
http://www.eonline.com/movies/
http://blog.myspace.com/breakfastwithchopin
http://blog.myspace.com/evanandjaron
http://blog.myspace.com/eve6
http://extratv.warnerbros.com/
http://forums.mozillazine.org/viewforum.php?f=23
http://www.fhmonline.com/
http://www.mediabistro.com/fishbowlDC/?c=rss
http://www.mediabistro.com/fishbowlLA/?c=rss
http://www.mediabistro.com/fishbowlny/?c=rss
http://blog.myspace.com/gracepotterandthenocturnals
http://googleblog.blogspot.com/
http://news.google.com/news?ned=:ePkh8BM9gxtfDrcjFW5RrhADigUAdFgGGw
Huffington Post
http://www.huffingtonpost.com/raw_feed_index.rdf
http://www.huffingtonpost.com/thenewswire/
http://www.huffingtonpost.com/theblog/
http://www.huffingtonpost.com/theblog/
http://www.indie911.com/podcasts
Jennifer Paige
http://launch.groups.yahoo.com/group/theultimatejenniferpaigefan/
http://blog.myspace.com/jenniferpaigemusic
http://blog.myspace.com/karikimmel
L.A. Times
News
http://www.latimes.com/news/?track=rss
http://www.latimes.com/news/local/?track=rss
http://www.latimes.com/news/local/politics/cal/?track=rss
http://www.latimes.com/news/local/los_angeles_metro/?track=rss
http://www.latimes.com/news/local/inland/?track=rss
http://www.latimes.com/news/local/orange/?track=rss
http://www.latimes.com/news/local/valley/?track=rss
http://www.latimes.com/news/local/ventura/?track=rss
http://latimesblogs.latimes.com/politicalmuscle/
http://latimesblogs.latimes.com/homicidereport/
http://latimesblogs.latimes.com/thehomeroom/
http://www.latimes.com/news/nationworld/nation/?track=rss
http://www.latimes.com/news/nationworld/politics/?track=rss
http://www.latimes.com/news/politics/?track=rss
http://www.latimes.com/business/investing/?track=rss
http://www.latimes.com/business/?track=rss
http://www.latimes.com/news/education/?track=rss
http://www.latimes.com/news/science/environment/?track=rss
http://www.latimes.com/news/science/?track=rss
http://www.latimes.com/technology/?track=rss
http://www.latimes.com/news/nationworld/world/?track=rss
http://www.latimes.com/news/nationworld/world/africa/?track=rss
http://www.latimes.com/news/nationworld/world/asia/?track=rss
http://www.latimes.com/news/nationworld/world/europe/?track=rss
http://www.latimes.com/news/nationworld/world/latinamerica/?track=rss
http://www.latimes.com/news/nationworld/world/middleeast/?track=rss
http://www.latimes.com/classified/automotive/highway1/?track=rss
Opinions & Columns
http://www.latimes.com/news/columnists/la-columnist-gskelton,0,1141051.columnist?track=rss
http://www.latimes.com/news/opinion/?track=rss
http://www.latimes.com/news/opinion/commentary/?track=rss
http://www.latimes.com/news/local/orange/la-columnist-dparsons,0,5817103.columnist?track=rss
http://www.latimes.com/news/local/la-columnist-sharvey,0,3065491.columnist?track=rss
http://www.latimes.com/news/local/la-columnist-slopez,0,4715349.columnist?track=rss
http://www.latimes.com/news/local/la-columnist-bsipchen,0,3971510.columnist?track=rss
http://www.latimes.com/news/columnists/la-columnist-jgoldberg,0,6021760.columnist?track=rss
http://www.latimes.com/news/columnists/la-columnist-mdaum,0,523508.columnist?track=rss
http://www.latimes.com/news/columnists/la-columnist-rbrooks,0,5243347.columnist?track=rss
http://opinion.latimes.com/opinionla/
http://www.latimes.com/classified/automotive/highway1/la-hy-neil-sg,0,5627290.storygallery?track=rss
http://www.latimes.com/business/la-columnist-tpetruno,0,1374224.columnist?track=rss
http://www.latimes.com/news/local/la-goldstein-sg,0,1668345.storygallery?track=rss
http://www.latimes.com/sports/columnists/la-columnist-bplaschke,0,5883852.columnist?track=rss
Entertainment
http://www.calendarlive.com/movies/reviews/?track=rss
http://www.latimes.com/entertainment/news/movies/?track=rss
http://www.calendarlive.com/music/?track=rss
http://www.latimes.com/entertainment/news/music/?track=rss
http://www.calendarlive.com/tv/?track=rss
http://www.latimes.com/entertainment/news/tv/?track=rss
http://www.latimes.com/entertainment/news/arts/?track=rss
http://latimesblogs.latimes.com/showtracker/
http://www.latimes.com/entertainment/news/arts/?track=rss
http://www.calendarlive.com/books/?track=rss
http://theenvelope.latimes.com/news/?track=rss
http://goldderby.latimes.com/awards_goldderby/
http://www.latimes.com/entertainment/news/?track=rss
http://www.calendarlive.com/printedition/calendar/qtakes/sns-celebrity,0,1658506.storygallery?track=rss
Lifestyle
http://www.latimes.com/features/books/?track=rss
http://www.latimes.com/features/food/?track=rss
http://www.latimes.com/features/health/?track=rss
http://www.latimes.com/features/home/?track=rss
http://www.latimes.com/features/lifestyle/?track=rss
http://www.latimes.com/travel/printedition/?track=rss
http://www.latimes.com/features/magazine/?track=rss
http://vegasblog.latimes.com/vegas/
http://www.latimes.com/classified/realestate/news/?track=rss
http://www.maxim.com/
http://mediamatters.org/
http://michellemalkin.com/
http://www.mozillazine.org/
http://www.mozilla.org/news.html
http://planet.mozilla.org/
http://developer.mozilla.org/devnews
http://weblogs.mozillazine.org/calendar/
http://quality.mozilla.org/
New York Times
News
http://www.nytimes.com/pages/business/index.html?partner=rssnyt
http://www.nytimes.com/pages/business/media/index.html?partner=rssnyt
http://www.nytimes.com/pages/business/worldbusiness/index.html?partner=rssnyt
http://www.nytimes.com/pages/business/yourmoney/index.html?partner=rssnyt
http://dealbook.blogs.nytimes.com/
http://www.nytimes.com/pages/education/index.html?partner=rssnyt
Health
http://www.nytimes.com/pages/health/research/index.html?partner=rssnyt
http://www.nytimes.com/pages/health/nutrition/index.html?partner=rssnyt
http://www.nytimes.com/pages/health/policy/index.html?partner=rssnyt
World
http://www.nytimes.com/pages/world/africa/index.html?partner=rssnyt
http://www.nytimes.com/pages/world/americas/index.html?partner=rssnyt
http://www.nytimes.com/pages/world/asia/index.html?partner=rssnyt
http://www.nytimes.com/pages/world/europe/index.html?partner=rssnyt
http://www.nytimes.com/pages/world/middleeast/index.html?partner=rssnyt
http://www.nytimes.com/pages/national/index.html?partner=rssnyt
New York / Region
http://www.nytimes.com/pages/nyregion/thecity/index.html?partner=rssnyt
http://www.nytimes.com/pages/nyregion/metrocampaigns/index.html?partner=rssnyt
Science
http://www.nytimes.com/pages/science/earth/index.html?partner=rssnyt
http://www.nytimes.com/pages/health/nutrition/index.html?partner=rssnyt
http://www.nytimes.com/pages/science/space/index.html?partner=rssnyt
Technology
http://pogue.blogs.nytimes.com/
http://www.nytimes.com/pages/washington/index.html?partner=rssnyt
Arts
http://www.nytimes.com/pages/arts/design/index.html?partner=rssnyt
http://www.nytimes.com/pages/arts/music/index.html?partner=rssnyt
http://www.nytimes.com/pages/arts/television/index.html?partner=rssnyt
http://www.nytimes.com/pages/automobiles/index.html?partner=rssnyt
Books
http://www.nytimes.com/pages/books/review/index.html?partner=rssnyt
http://www.nytimes.com/pages/dining/index.html?partner=rssnyt
Fashion & Style
http://www.nytimes.com/pages/fashion/thursdaystyles/index.html?partner=rssnyt
http://www.nytimes.com/pages/fashion/weddings/index.html?partner=rssnyt
http://www.nytimes.com/pages/garden/index.html?partner=rssnyt
http://www.nytimes.com/pages/magazine/index.html?partner=rssnyt
http://www.nytimes.com/pages/movies/index.html?partner=rssnyt
http://movies.nytimes.com/pages/movies/index.html?partner=rssnyt
http://www.nytimes.com/pages/realestate/index.html?partner=rssnyt
http://theater.nytimes.com/pages/theater/index.html?partner=rssnyt
Travel
http://www.nytimes.com/pages/travel/escapes/index.html?partner=rssnyt
http://www.nytimes.com/pages/weekinreview/index.html?partner=rssnyt
http://www.playboy.com/blog/
http://blog.myspace.com/samanthamusic
http://blog.myspace.com/sugitap
http://forums.mozillazine.org/viewforum.php?f=29
http://www.tmz.com/
TV Guide
http://community.tvguide.com/blog/TVGuide-News-Blog/Todays-News/700000044?rssDate=12345678
http://www.tvguide.com/News-Views/Interviews-Features/Article/
http://www.tvguide.com/News-Views/Columnists/The-Biz/
http://community.tvguide.com/blogs/Tv-Guide-Editors/700000006?rssDate=12345678
http://www.mediabistro.com/tvnewser/?c=rss
http://tv.yahoo.com/
Wired
http://www.wired.com/rss/index.xml
http://www.wired.com/rss/index.xml
http://www.wired.com/rss/culture.xml
http://www.wired.com/rss/techbiz.xml
http://www.wired.com/rss/politics.xml
http://updates.zdnet.com/index.php?t=7
this appear to me like a dupe of the problem with loading a lot of rss feeds, we don't manage well a big number of feeds since we do update in a for cycle.

So the problem is not a single feed that read slowly but the whole of feeds takes a long time to update. Is this correct?
@Bonardo: no, I think it is a WFM. Anyway I noticed a random error at myspace feeds. Read further.

@btflmalegod:
Well, we asked you feed links, not site links.... :-P
Anyway, with a little of patience, much free time and great madness, I loaded site-by-site in a new blank profile of the latest Fx3 trunk, and I saved all RSS links I found at the root of Bookmark Menu. I can't find some, but I virtually saved all of them.

Restarting Fx3, I've noticed only a short slow down, but nothing so problematic. Anyway your issue could be caused by feed links I've not added. So you must provide us _feed_ links. You can send them exporting your bookmarks in HTML file and attaching it to this bug (see "Attachment" bug section). Be sure you don't send us bookmarks you don't want to be public.

Anyway, I noticed a random error on myspace pages. When I clicked on "rss" links, sometimes "Add live bookmarks" dialogue was not shown. On the contrary it was shown the XML file. I must go back and re-click on the link (sometimes very much times!) to do it working. I think I'll post a bug about this.
(Reporter)

Comment 10

9 years ago
Created attachment 323920 [details]
RSS feed links
(Reporter)

Comment 11

9 years ago
HTML file has been submitted.

(In reply to comment #10)
> Created an attachment (id=323920) [details]
> RSS feed links
> 

Nothing, it works for me very well. Are you sure that:

1) you have the latest trunk (my current identifier is 2008060607)
2) you created a completely new and blank profile, without importing cookies, prefs, extensions etc
3) you imported the bookmark files manually from a path _different_ by the path of the new profile (for example, from the desktop)
4) the problem is caused by Live bookmarks

?
(Reporter)

Comment 13

9 years ago
I can create a new profile with nothing but my bookmarks in it, and the same exact problem will occur every single time.

(In reply to comment #12)
> Nothing, it works for me very well. Are you sure that:
> 
> 1) you have the latest trunk (my current identifier is 2008060607)
> 2) you created a completely new and blank profile, without importing cookies,
> prefs, extensions etc
> 3) you imported the bookmark files manually from a path _different_ by the path
> of the new profile (for example, from the desktop)
> 4) the problem is caused by Live bookmarks
> 
> ?
> 

(In reply to comment #13)
> I can create a new profile with nothing but my bookmarks in it, and the same
> exact problem will occur every single time.

All your bookmarks or only your Live bookmarks?

If there are only Live bookmarks in your blank profile, I don't know why this happens. I have your Live bookmark, I use WinXP as you, but I can't reproduce this bug. It could be caused by some other programs, OS settings or OS updates, but IMO it's very unlikely.

I can only suggest you to update WinXP to SP3 and try to recreate a blank profile and reimport your Live bookmarks, but with WinXP in Safe mode.
(Reporter)

Comment 15

9 years ago
Upgraded to WinXp SP3, created a new profile and cleaned up more Livemarks. Now, when I open Minefield, it takes about a minute to load up. But when it does, it just does what it's supposed to. I don't think, though it should take that long.

In any case, maybe somebody can look at this config info and try to figure out if an extension might be responsible. I tried myslef, but I couldn't get anything.

BTW: My copy of Minefield isn't recognizing the Java Plugin.

****** 

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008060703 Minefield/3.1a1pre
Build ID: 2008060703

Enabled Extensions: [29]
- Aardvark 2.9 - aardvark@rob.brown: http://karmatics.com/aardvark/
- About:Config 1.0 - aboutconfig@pitux.fr: http://pitux.free.fr/
- Adblock Plus 0.7.5.4 - {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}: http://adblockplus.org/
- All-in-One Sidebar 0.7.5 - {097d3191-e6fa-4728-9826-b533d755359d}: http://firefox.exxile.net/aios/
- Autohide 1.2 - {DD43485F-44CC-4452-A6C6-69356A7E33DA}: http://www.krickelkrackel.de/autohide/
- Bookmark Backup 0.4.9 - {3474c305-9dad-11d8-9207-00055d74c2e4}: http://www.pikey.me.uk/mozilla/
- BugMeNot 1.8 - {987311C6-B504-4aa2-90BF-60CC49808D42}: http://erichamiter.com
- Console┬▓ 0.3.9.2 - {1280606b-2510-4fe0-97ef-9b5a22eafe80}: http://console2.mozdev.org/index.html
- DictionarySearch 3.0.0 - {a0faa0a4-f1a7-4098-9a74-21efc3a92372}: http://dictionarysearch.mozdev.org/
- DOM Inspector 2.0.0 - inspector@mozilla.org: http://www.mozilla.org/projects/inspector/
- Firefox Showcase 0.9.4.8 - {89506680-e3f4-484c-a2c0-ed711d481eda}: http://showcase.uworks.net/
- Forecastfox 0.9.7.6 - {0538E3E3-7E9B-4d49-8831-A227C80A7AD3}: http://forecastfox.mozdev.org/
- Full Screen 0.7 - {06CC82D4-29FB-4082-81AA-A445F8A13F0A}: http://www.splintered.co.uk/
- Get Mail Plus 3.0 - getmail@webdesigns.ms11.net: http://webdesigns.ms11.net/getmail.html
- Gmail Manager 0.5.5 - {582195F5-92E7-40a0-A127-DB71295901D7}: http://www.longfocus.com/firefox/gmanager/
- IE Tab 1.5.20080310 - {77b819fa-95ad-4f2c-ac7c-486b356188a9}: https://addons.mozilla.org/firefox/addon/1419/
- IE View 1.3.7 - {6e84150a-d526-41f1-a480-a67d3fed910d}: http://www.google.com/search?q=Minefield%20IE%20View
- Image Zoom 0.3.1 - {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}: http://imagezoom.yellowgorilla.net/
- keyconfig 20060828.1 - keyconfig@dorando: http://mozilla.dorando.at/
- MinimizeToTray 0.0.1.2006102615+ - {31513E58-F253-47ad-86DB-D5F21E905429}: http://minimizetotray.mozdev.org/
- Mozilla QA Companion 0.1.14 - {667e9f3d-0096-4d2b-b171-9a96afbabe20}: http://quality.mozilla.org/
- MR Tech Link Wrapper 2.2 - {AE7FD9A4-892A-4DE0-B635-4C58D0B0E09F}: http://www.mrtech.com/extensions/#linkwrapper
- MR Tech Toolkit 6.0a29 - {9669CC8F-B388-42FE-86F4-CB5E7F5A8BDC}: http://www.mrtech.com/extensions/local_install/
- PDF Download 1.0.1.1 - {37E4D8EA-8BDA-4831-8EA1-89053939A250}: http://www.pdfdownload.org
- Print/Print Preview 0.6 - {19EB90DC-A456-458b-8AAC-616D91AAFCE1}: http://www.splintered.co.uk/
- Tab Mix Plus 0.3.6.1.080416 - {dc572301-7619-498c-a57d-39143191b318}: http://tmp.garyr.net
- Update Channel Selector 1.0.3 - updatechannel@blueprintit.co.uk: http://www.oxymoronical.com/web/firefox/updatechannel
- Update Notifier 0.1.5.4 - {95f24680-9e31-11da-a746-0800200c9a66}: http://www.longfocus.com/firefox/updatenotifier
- User Agent Switcher 0.6.11 - {e968fc70-8f95-4ab9-9e79-304de2a71ee1}: http://chrispederick.com/work/user-agent-switcher/

Installed Themes: [1]
- Default - {972ce4c6-7e08-4474-a285-3208198ce6fd}: http://www.mozilla.org/

Installed Plugins: (12)
- Adobe Acrobat
- IE Tab Plug-in
- iTunes Application Detector
- Microsoft® DRM
- Mozilla Default Plug-in
- QuickTime Plug-in 7.4.5
- RealJukebox NS Plugin
- RealNetworks Rhapsody Player Engine
- RealPlayer Version Plugin
- RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit) 
- Shockwave Flash
- Windows Media Player Plug-in Dynamic Link Library

Since you have this problem also with a blank profile without extensions and additional plugins, extensions and plugins can't be the problem.

For Java, are you sure do you have Java installed?

PS: only few suggests: have you ever tried Google Reader ( http://www.google.com/reader/ )? Furthermore for what I see in your plugin list, you could also try VLC ( http://www.videolan.org/vlc/ ) and Media Player Classic ( http://sourceforge.net/projects/guliverkli/ ).
(Reporter)

Comment 17

9 years ago
Actually, I'm starting to think that the problem's more basic: Firefox 3 just SUCKS at handling RSS feeds! Seriously, when I have nothing but bookmarks in a profile, and everything elswe is disabled, it can't be anything I'm doing.
Well, finally I reproduced the bug. Today (after 3 days) I reopened the profile where I imported the Live Bookmarks of Btfl. Fx started, but it was unresponsive for ~5 minutes. In the meanwhile I heard a high HD activity.

I think the problem is that the update of Live Bookmarks is not asynchronous, and when a Live Bookmark is updated it is immediately written to HD.
Ah, I forget. Btfl, can you add 'perf, testcase' to Keywords? Thanks.
(Reporter)

Updated

9 years ago
Keywords: perf, testcase
(Reporter)

Comment 20

9 years ago
Keywords have been added.

(In reply to comment #18)
> Well, finally I reproduced the bug. Today (after 3 days) I reopened the profile
> where I imported the Live Bookmarks of Btfl. Fx started, but it was
> unresponsive for ~5 minutes. In the meanwhile I heard a high HD activity.
> 
> I think the problem is that the update of Live Bookmarks is not asynchronous,
> and when a Live Bookmark is updated it is immediately written to HD.
> 

5 minutes? That's even longer than what I experienced. Glad somebody was able to reproduce the bug.
(Reporter)

Comment 21

9 years ago
BTW: Would there be something a user could add to about:config to make the update of Live Bookmarks asynchronous?

Comment 22

9 years ago
Someone pointed out this looks like Bug 329534:

https://bugzilla.mozilla.org/show_bug.cgi?id=329534
Yes, it is clearly a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 329534
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.