Closed Bug 435096 Opened 12 years ago Closed 9 years ago

Minimonth: month/year button text not readable with high contrast theme

Categories

(Calendar :: Calendar Views, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 671119

People

(Reporter: ssitter, Unassigned)

References

Details

(Keywords: access)

Attachments

(2 files, 2 obsolete files)

Attached image screenshot
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15pre) Gecko/2008052110 Calendar/0.9pre

When using a different Windows theme (in this case a high contrast white on black theme) the text of the month/year buttons in the minimonth control is not readable. See screenshot for explanation.

The minimonth should use the system colors if possible. If it's not possible it should specify both background and text color to keep the text readable.
Attached image screenshot using system colors (obsolete) —
First approach using system colors. This fixes the issue and matches the display of the dropdown month/year menus.
Attachment #343387 - Flags: ui-review?(christian.jansen)
Attached patch using system colors (obsolete) — Splinter Review
Comment on attachment 343387 [details]
screenshot using system colors

The screenshot shows the current minimonth (left) and with patch applied (right) comparison for XP Luna, Classic, Contrast Black and Contrast White theme.
This is surly an improvement, but I'm not happy with the removal of the grey backgrond of the navigation box. Maybe it should be replaced by "ThreeDFace" instead of removing it completely.
Another possibility would be to define the text color in addition to the background color too. This way the minimonth would always look the same. Drawback: Ignoring the users theme settings.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #343387 - Attachment is obsolete: true
Attachment #343387 - Flags: ui-review?(christian.jansen)
Attachment #343388 - Attachment is obsolete: true
Assignee: ssitter → nobody
Status: ASSIGNED → NEW
Thunderbird and Firefox allow the user to set text and background colours. Why not add these config options to Calendar? (as well as addressing the background colour issue which by the way doesn't occur in Thunderbird or Firefox GUIs).
OH yes. I don't think you have the option to set to system colours in Lightning.
Duplicate of this bug: 524094
Now that I'm back in work with access to my PC running Thunderbird and Lightning I realise we have 2 issues here:

1) The bug as described where the top left hand pane and drop-down list below it has invisible text when using the Windows High Contrast (black in my case) colour scheme. The text in the bigger calander view on the right is visible so why not set the colours of the smaller left side panes to work the same way?

2) Lightning does not obey the Thunderbird colour settings either. I have set the Thunderbird colours to be white text on a black background. Since the Lightning add-on has no options for setting colours should it not obey the Thunderbird settings?
Just discovered that the Events pane within Lightning's Task view has the same problem. Will try to attach a .bmp screenshot.
This issue is now addressed in bug 671119 for the global UI.
I think it could be marked as duplicate.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671119
You need to log in before you can comment on or make changes to this bug.