Closed Bug 435179 Opened 12 years ago Closed 4 years ago

[Linux] Checking and unchecking tags does not work via the keyboard

Categories

(Firefox :: Keyboard Navigation, defect)

All
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: MarcoZ, Unassigned)

References

Details

(Keywords: access, regression)

STR:
1. Bookmark any page via CTRL+D.
2. Add one tag for this bookmark.
3. Visit a different page and add this as another bookmark via CTRL+D.
4. Tab to the "Show all Tags" button and activate it with SPACE.
5. Tab to the list of pre-defined tags, and try to activate/deactivate entries with SPACE.

Result: State is not toggled.
Expected. Like on Windows, state should be toggled.
Flags: blocking1.9.0.1?
State is toggle to checked but then reverts immediately, yo see it flash.
So I guess an extra event is being used to toggle it.
Also WFM with latest nightly on OS X 10.5. Seems to be a Linux only issue.

Is this a regression? Are other checkboxes also affected?
(In reply to comment #2)
> Is this a regression? Are other checkboxes also affected?

Also happens in beta 5. Other checkboxes, for example in the Preferences dialog, are not affected.
Regression range (nightlies): 2007081604…2007081704. That’s when the “starring, bookmarking and tagging UI” has been enabled with at least two check-ins from bug 385266.
Thanks Alex for getting the regression window. It's interesting why that only happens on Linux.
Keywords: regression
Summary: Checking and unchecking tags does not work via the keyboard (works on Windows). → [Linux] Checking and unchecking tags does not work via the keyboard
A Litmus testcase covering this can be found here:
https://litmus.mozilla.org/show_test.cgi?id=5391
Flags: in-litmus+
Keywords: relnote
Don't think that this is needed in the release notes, removing keyword.
Keywords: relnote
Flags: wanted1.9.0.x+
Flags: blocking1.9.0.1?
Flags: blocking1.9.0.1-
Flags: blocking-firefox3.1?
Mano: any idea what could have caused this regression on Linux?
Not a regression, no progress, can't block the release on this.
Flags: blocking-firefox3.1? → blocking-firefox3.1-
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID 	20160503030421

This works for me on the current release (Firefox 46.0.1) and latest Nightly (49.0a1) using Ubuntu 15.04. I will close the bug. If anyone can still reproduce the issue on a current build, fell free to reopen it.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.