yellowpages.superpages.com - map won't load in non-Firefox Gecko browsers

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: smithpd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

www.whitepages.com shows maps for businesses found.  Using Seamonkey, if you click on a map to get different scale or detail, it goes into a permanent "loading" state and never finishes loading.  An example URL that contains such a map is:

http://yellowpages.superpages.com/listings.jsp?SRC=comwp&C=botwin&T=santa+fe&S=NM&STYPE=S&L=Santa+Fe+NM&R=N&MC=1&OO=1&F=1&CP=Health+%26+Medicine%5EEye+Care%5EOptometry%5EOptometrists%5E

Click on the map itself, and it will not open using Seamonkey 1.1.9.  It will open successfully using Firefox 2.0 or Windows Explorer 7.0

Reproducible: Always

Steps to Reproduce:
1.  Go to URL listed above in Details, or find any location in www.whitepages.com
2.  Click on map graphic
3.  Observe that map will not open.
4.  Try same on Firefox and observe that it works
Actual Results:  
Map did not load

Expected Results:  
Map loads and displays

Same problem exists on various computers using XP and 2000

Comment 1

11 years ago
Hmm, it looks like maps at whitepages.com works, but maps at http://yellowpages.superpages.com doesn't. Am I correct?
Clicking "Enlarge Map Results" for "Business Search" gives me "forever loading" in both of the
following (on Linux):

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008052201
SeaMonkey/2.0a1pre

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15pre) Gecko/20080522
BonEcho/2.0.0.15pre
 - Build ID: 2008052205

Adding to the Sm about:config a string pref with the name
general.useragent.extra.firesomething and the value "NOT Firefox/3.0" makes no
difference.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Whiteboard: [trunk and 1.8 Branch]
Version: unspecified → Trunk

Comment 3

11 years ago
(In reply to comment #2)
> Clicking "Enlarge Map Results" for "Business Search" gives me "forever loading"
> in both of the
> following (on Linux):
> 
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008052201
> SeaMonkey/2.0a1pre
> 
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15pre) Gecko/20080522
> BonEcho/2.0.0.15pre
>  - Build ID: 2008052205
> 
> Adding to the Sm about:config a string pref with the name
> general.useragent.extra.firesomething and the value "NOT Firefox/3.0" makes no
> difference.
>

They might sniff for "Firefox/2.0". Note that they use yellowpages.superpages.com for their business search
 

I'm moving this to tech evang - very likely that they exclude/serve bad code to non-Firefox Gecko browsers. Someone needs to confirm it, though
Assignee: general → english-us
Component: General → English US
Product: Mozilla Application Suite → Tech Evangelism
QA Contact: general → english-us
Summary: Whitepages map will not load using Seamonkey, but Firefox works → yellowpages.superpages.com - map won't load in non-Firefox Gecko browsers
Version: Trunk → unspecified

Comment 4

11 years ago
Actually, the map works if I replace "SeaMonkey/1.1.9" in the ua string with "Firefox/2.0" or "Firefox/3.0".
Blocks: 334967
In reply to comment #3:
Here I can load the map "the first time" in both BonEcho and Suiterunner; trying to enlarge the map "loads forever"; however you may be right: altering the BonEcho useragent to

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15pre) Gecko/20080522 Firefox/2.0.0.15pre

makes the enlarged map load in a finite time.
Whiteboard: [trunk and 1.8 Branch]
tested right now with a Camino UA string, and it seemed to work fine.
Problem not found
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.19) Gecko/2011032020 Camino/2.0.7 (like Firefox/3.0.19)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 7

5 years ago
(In reply to Hallvord R. M. Steen from comment #6)
> Problem not found Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.19) Gecko/2011032020 Camino/2.0.7 (like Firefox/3.0.19)

Of course it wouldn't be found with a string that includes Firefox. Using Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 SeaMonkey/2.19; Build ID: 20130628213754  no map(s) load. Correct sniffing, if sniffing for any browser "name" could ever be justified, would be for the rendering engine Gecko, not for Gecko's Firefox or Camino or SeaMonkey or etc. UI wrapper. Proper sniffing, if and when needed or desired, is for browser features, not names.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Ah, thanks for pointing out that I was testing with a "Camino" string that includes "Firefox". 
I'm now re-testing with the UA string from your comment me on the link above (in a private window to try to avoid cookies/session data invalidating the test), and the map still works fine. (It looks like a grey square at first, but zoom out a little and you'll see it's just because it's zoomed in to a place where there aren't any features).

Does it still fail for you?
Status: REOPENED → NEW

Comment 9

5 years ago
(In reply to Hallvord R. M. Steen from comment #8)
> Does it still fail for you?

just a gray rectangle where a map should be
Do you get map controls? Did you try zooming out?

Comment 11

5 years ago
In FF map loads without having to do anything. In SM clicking various buttons makes page changes without loading any maps. SM zoom does nothing. Page map area has no zoom controls in Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 SeaMonkey/2.20; Build ID: 20130721212621
I tried with a SeaMonkey UA and I didn't have any issues. 
Is it still wrong? if yes, Which UA string?
Assignee: english-us → nobody
Component: English US → Desktop
WFM too with the last user-agent string given by Felix Miata

Comment 14

4 years ago
WFM too Mozilla/5.0 (X11; Linux i686; rv:32.0) Gecko/20100101 SeaMonkey/2.29; Build ID: 20140822025554 
Must have been fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.