Closed Bug 435299 Opened 11 years ago Closed 11 years ago

support SVG in imglib

Categories

(Core :: ImageLib, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 276431

People

(Reporter: joe, Assigned: joe)

References

Details

imglib should support SVG images. This requires quite some work on the SVG/Layout side, which ideally will be shared with SVG filters on CSS and SVG fonts (which is where bzbarsky comes in AIUI).
Is this different to bug 272288?
I'm going to say that this is the bug for the imglib work required for that bug.
Depends on: 272288
OS: Mac OS X → All
Hardware: PC → All
Depends on: 231179
Depends on: 276431
Flags: wanted1.9.0.x?
Flags: wanted1.9.0.x? → wanted1.9.1?
P1.
Priority: -- → P1
Flags: wanted1.9.1? → wanted1.9.1+
Vlad, would you really hold 1.9.1 for this?
Flags: blocking1.9.1? → blocking1.9.1-
Priority: P1 → P2
I think we decided there is no imagelib work required for this bug, we'll do it in layout instead.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
the image can not be loaded. it only shows the alt tag
Retitling this so it doesn't confuse people when it shows up in searches.  Olé: please see bug 276431 and bug 272288 -- we're going to make it work, just not the way we thought we might when this bug was filed.
Summary: implement <img src="foo.svg"> → support SVG in imglib
Changing resolution to "duplicate of bug 276431", for clarity's sake.

(That bug added support for SVG in imagelib (at least, parts of it live in imagelib - VectorImage / SVGDocumentWrapper))  The work described in comment 2 basically ended up happening as part of bug 276431.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 276431
You need to log in before you can comment on or make changes to this bug.