Last Comment Bug 435340 - sidebar and bookmarks library behave differently when adding separators
: sidebar and bookmarks library behave differently when adding separators
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: 3.0 Branch
: PowerPC Mac OS X
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Marco Bonardo [::mak]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-22 17:47 PDT by juan becerra [:juanb]
Modified: 2013-02-18 08:58 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description juan becerra [:juanb] 2008-05-22 17:47:56 PDT
Fx3rc1, 10.4.11, litmus test case 4121. Sidebar and bookmarks library behave differently when adding separators.

Sidebar, Steps:
1. Take for example the default Mozilla Firefox folder in the Bookmarks Menu.
2. Right-click on the Mozilla Firefox folder and select New Separator. 

Behavior, sidebar: A separator is added inside the Mozilla Firefox folder

Bookmarks Library, Steps:
1. Navigate to the Bookmarks Menu in the left pane
2. Right-click on the Mozilla Firefox folder and select New Separator

Behavior, library: A separator is added above the Mozilla Firefox folder

The behavior is inconsistent, and it can be a little frustrating if the user expects to be able to add a separator between two folders while in the sidebar, because they won't be able to. Unless they then drag the separator out of the folder, for example.
Comment 1 Paul J. Weiss 2008-08-23 21:08:34 PDT
I agree.
Comment 2 Gervase Markham [:gerv] 2009-11-26 06:54:32 PST
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Comment 3 Marco Bonardo [::mak] 2013-02-18 08:58:30 PST
they are now consistent afaict

Note You need to log in before you can comment on or make changes to this bug.