"overflow:auto" and "overflow:hidden" don't work in table elements with Firefox3 RC1.

RESOLVED DUPLICATE of bug 409736

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 409736
10 years ago
10 years ago

People

(Reporter: uta, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

"overflow:auto" and "overflow:hidden" don't work in table elements with Firefox3 RC1.


Reproducible: Always

Steps to Reproduce:
1. Access Demo URL (http://rubricks.org/test.html)
2. Click all test cases
Actual Results:  
All contents is shown.

Expected Results:  
The overflowed contents is scrolled out or hidden.

Comment 1

10 years ago
At first I looked at overflow and what it specifies that it applies to:
11.1.1 Overflow: the 'overflow' property
Applies to:  non-replaced block-level elements, table cells, and inline-block elements 

I wonder if a table would be considered a non-replaced block-level element.  But because table cell is explicitly listed I suppose a table does not count as a non-replaced block-level element.  

But then there's this:
9.2.1 Block-level elements and block boxes
Block-level elements are those elements of the source document that are formatted visually as blocks (e.g., paragraphs). Several values of the 'display' property make an element block-level: 'block', 'list-item', and 'run-in' (part of the time; see run-in boxes), and 'table'. 
http://www.w3.org/TR/CSS21/visuren.html#block-level

The rendering of the tests is the same in Safari 3.1 as I see with FF3.
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables

Comment 2

10 years ago
I mixed up what has the overflow style.  The div has the overflow style, not the table.  The question should be over the width of the table.  

Comment 3

10 years ago
The width of the table is covered by:
If the 'table' or 'inline-table' element's 'width' property has a computed value (W) other than 'auto', the property's value as used for layout is the greater of W and the minimum width required by all the columns plus cell spacing or borders (MIN). If W is greater than MIN, the extra width should be distributed over the columns. 

Under 17.5.2.2 Automatic table layout
http://www.w3.org/TR/CSS21/tables.html#auto-table-layout

So the width of the table will be set to MIN which is what is needed to contain the div.  So no overflow happens.

Safari 3.1 does the same thing with the tests.  

-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

10 years ago
I see.

I confirm that overflow does work with fixed table layout, thank you.
  => http://rubricks.org/test_table_overflow_5.html

If I use automatic table layout and there is very very long text in it,
The side-scroll-bar of browser is shown. You mean it is correct, right?
  => http://rubricks.org/test_table_overflow_6.html
Resolution: INVALID → DUPLICATE
Duplicate of bug: 409736
You need to log in before you can comment on or make changes to this bug.