New Location bar autocompletion : bad ordering when displaying the list of matching urls

RESOLVED DUPLICATE of bug 409895

Status

()

Firefox
Address Bar
--
major
RESOLVED DUPLICATE of bug 409895
10 years ago
10 years ago

People

(Reporter: Adrian M, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008051202 Firefox/3.0

(Firefox 3.0)

When I want to go to "www.freshmeat.net"  and therefore I start typing in the location bar.   After pressing "F", the following list appears  : 

1.  http://login.foxmarks.com
2.  http://ubuntuforums.org/
3.  http://freshmeat.net/
4.  https://addons.mozilla.org/en-US/firefox
5.  http://feedback.mozilla.org/

The search/ordering is wrong : "ubuntuforums.org" and "addons.mozilla.org/en-US/firefox"  should NOT be there at all,  or at least they should be displayed last in the results list. 

When I type "f" i expect to see the list of the urls that start with "f", not all the urls that contain "f".  

The behaviour of this new location bar is extremely intrusive as it's 
negatively affecting the well-established habit of getting to a given
frequent website by entering the first few characters.













Reproducible: Always

Comment 1

10 years ago
There is code already to prioritize the start elements after bug 393678, bug  	404261. I suspect foxmarks is your top entry because despite the login portion, the f in foxmarks is a start element. The ubuntuforums entry is odd, but due to frecency it would show up if you visit more often than ubuntu forums. It is worth noting however that it will adapt and learn, if you type f and choose freshmeat a few times then freshmeat will make it to the top of the list (quickly in my experience)

This might be a dupe of bug 409023

Comment 2

10 years ago
(In reply to comment #1)
>The ubuntuforums entry is odd, but due to frecency it would show up if 
>you visit more often than ubuntu forums.

s/ubuntu forums/freshmeat sorry
Also, you might be interested in bug 409895

(Reporter)

Comment 3

10 years ago
I can certainly add a "r"   and "fr" goes to "freshmeat" - this is ok.

What bothers me is not that "freshmeat" is not the first choice, 
but the fact that in that list there are some urls that shouldn't be there in my opinion.  

It's not a good idea to enforce this completely new behaviour: without the ability to fully customize it, the awesome seems more like a drawback than a "feature" to me.   

Are there any intentions to make the new awesome configurable (and hopefully settable to the old look and behaviour) ? 

Regarding bugs 409895 and 422610 : it looks like i'm in the crowd of thos epeople who dislike the new addition and would llike a feature like "Add an option to restore the URL autocompletion in FF3" .
 

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409895
You need to log in before you can comment on or make changes to this bug.