Closed Bug 435447 Opened 15 years ago Closed 15 years ago

Today pane events don't change color when calendar color is changed

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: benjamin.lerner, Assigned: Fallen)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051906 Minefield/3.0pre
Build Identifier: TB 20080421, Lightning nightly (2008052219)

I don't know whether this is an artifact of the same underlying problem as bug 435083 (or bug 433937), as there seems to be a more general problem with coloring events at the moment.  I'll try again, with whichever nightly picks up the fixes for those bugs, and see if this problem goes away...

Reproducible: Always

Steps to Reproduce:
1. Have some timed events and some all-day events on a calendar.
2. Note the color of the events in the Today pane -- it matches the calendar color.
3. Change the color of the calendar.  Note the color of the all-day events (which match the new color) and the timed events (which no longer match).
4. Switch the Today pane to yesterday, and back.  Note the color of the events (which now all match the new color).
Actual Results:  
The all-day events change color to match.  The timed events do not.  You can force a refresh by changing the date in the today pane (e.g. switch to yesterday, and back), and the colors will update.

Expected Results:  
All events, of whatever type, should reflect the changed color.
Updated to add: still seeing this bug with the latest nightly build.  But it doesn't affect local calendars -- I'm seeing it with my GData calendars.
I can't confirm this for webdav either so this is a gdata-problem? 
Moving to Provider: GData component according comment #1 and comment #2.
Component: Lightning Only → Provider: GData
QA Contact: lightning → gdata-provider
I'm surprised this should be gdata-only, but in any case, this fixes the issue.
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #333328 - Flags: review?(daniel.boelzle)
I don't have any non-local and non-GData calendars to test with, sorry :)  So I don't know whether it may affect other network calendars or not...  When this fix lands, I'll be sure to test again to confirm the fix works for me
Assignee: philipp → nobody
Status: ASSIGNED → NEW
Component: Provider: GData → General
OS: Windows XP → All
QA Contact: gdata-provider → general
Hardware: PC → All
Bug is not only gdata.
Assignee: nobody → philipp
Comment on attachment 333328 [details] [diff] [review]
Fix agenda-listbox

>-            var calcolor = "";
>-            try {
>-                var calcolor = this.mOccurrence.calendar.getProperty("color");
>-            } catch (e) {
>-            }
>-            if (!calcolor) {
>-                calcolor = "#a8c2e1";
>-            }
>+            this.refreshColor();
>+        ]]></body>
>+      </method>
>+      <method name="refreshColor">
>+        <body><![CDATA[
>+            ASSERT(this.mOccurrence, "Need Occurrence for setting color", true);

Are you sure we don't run into the ASSERTION throwing? The removed code has a fallback to show the default color in case !this.mOccurrence.

>-            imagebox.setAttribute("style","background-color: "  + calcolor + ";");
>+            imagebox.setAttribute("style", "background-color: "  + calcolor + ";");
remove                                                           ^

r=dbo
Attachment #333328 - Flags: review?(daniel.boelzle) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
The checkin broke the display of events that are stored in a calendar without color assigned. Previously the Agenda entries used the default blue color too. This doesn't work anymore and the Agenda just shows an half empty box.
Status: RESOLVED → REOPENED
Flags: blocking-calendar0.9+
Resolution: FIXED → ---
Attached patch Fix v1Splinter Review
Attachment #334852 - Flags: review?(daniel.boelzle)
Whiteboard: [needs patch]
Attachment #334852 - Flags: review?(daniel.boelzle) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Whiteboard: [needs patch]
Checked in lightning 2008082118 -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.