Closed Bug 435459 Opened 12 years ago Closed 11 years ago

Page not (entirely) redrawn when navigating to some new pages in Flickr

Categories

(Firefox :: General, defect, major)

3.0 Branch
x86
Windows Vista
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 474886

People

(Reporter: bugzilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

When I follow some links on Flickr, the new page is not drawn correctly. Instead, only parts of it (the images for instance) are drawn over the still-visible page I came from. Links are usually not shown until the mouse happens to pass over them. The new page does appear to work as far as clicking on links goes (if you can see them), but it looks terrible, a hodge-podge of the old and the new page.

I hope the problem will be reproducible, because on my system it doesn't appear to happen all the time. The steps to reproduce below pretty consistently result in this problem on my system though.

Reproducible: Sometimes

Steps to Reproduce:
1. Make sure you're logged in to Flickr
2. Navigate to http://www.flickr.com/
3. Click on any of the photos
4. Click on one of the tags under "Tags"
5. If the problem does not manifest itself, click on "public content tagged with ..."
6. If it still does not manifest itself, go back and try a different tag or a different photo
Actual Results:  
In step 4 or 5, sometimes after a few tries, the new page is not drawn entirely or at all. Only when mousing over links do they show, and the contents of the old page still show through.

Expected Results:  
The new page should be drawn in its entirety, replacing the old page.

There's a bunch of errors on the Error Console, but they seem to appear whether or not this problem manifests itself. If necessary I will reproduce them here.
Some more info on OS and hardware:

Microsoft Vista Home Premium 64-bit SP1
Intel Core Duo Extreme quad-core 3 GHz
4 GB RAM
I used CamStudio to capture the problem manifesting itself. The movie is quite large (about 30 MB) but it shows the problem very clearly. Let me know if I should upload it.
Version: unspecified → 3.0 Branch
Severity: normal → major
I just installed Firefox 3.0 RC2 (which appears to be identifying itself as plain 3.0, the user agent string is: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0), and this is still happening!

Could someone look in to this? It seems like a pretty major bug to me.
The screen capture movie I made illustrating this problem is too big to attach, but I've made it available at http://www.chaos.demon.nl/tmp/bug.avi.

Can someone take a look at it please? I think this is a pretty major bug, Flickr is currently *broken* on my system.
Flickr is still broken in version 3.0 of Firefox! I can't be the only person seeing this (although perhaps it has to do with my hardware (3 GHz Intel quad-core, 4 GB RAM, 2 x NVidia GeForce 8800 GTX) or software (Windows Vista Home Premium 64-bit SP1).
I tried it on my Dell laptop with Windows XP SP2, and it seems to work fine there. It still happens consistently on my desktop though. So it must have to do with Vista, or with a 64-bit OS, or a very fast computer (quad core 3GHz), or the NVidia drivers. But I can't be the only one who has one of those and is seeing this problem!
I'm experiencing the exact same issue in Flickr when using Firefox 3 on Vista Ultimate 64.  Like the original poster, I'm also using an nvidia video card (in my case, though, it's a quadro fx 1600).

On this system, the described behavior in flickr is evident on a fresh Firefox 3 install with no addons.  This isn't an issue when viewing the same Flickr pages with Firefox 2 or IE7 on the exact same system.

There are at least three of us experiencing this.  I found another blog reference to this issue here:

http://wp.dembowski.net/2008/07/19/flickr-firefox-3-problem/
The AVI link above shows the behavior exactly.  I have the same problem.
I'm also experiencing this issue - Flickr is the only site where I've noticed this happening.

Windows Vista x64 Home Premium Edition
NVidia 8800GTS 512Mb
Firefox 3.0.1
I have the same problem.

Firefox 3.0.1
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Running on:
OS Name	Microsoft® Windows Vista™ Business
Version	6.0.6001 Service Pack 1 Build 6001
Processor	Intel(R) Core(TM)2 Duo CPU     T7700  @ 2.40GHz, 2401 Mhz, 2 Core(s), 2 Logical Processor(s)

Display: NVIDIA Quadro FX 570M

Installed Physical Memory (RAM)	4,00 GB
Same problem here on Vista Business 64-Bit and NVIDIA 8800 card, too. Even with Firefox 3.1b1. Very annoying in my opinion.

Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1
I can confirm the bug in Firefox 3.1 beta 2 on my 64-bit Vista Ultimate machine with a nVidia Geforce 8800 GT. I think I remember having this bug back when I ran Windows XP Pro 64-bit edition as well.

This is definitely shaping up to be a 64-bit nVidia thing.
Noah, have you changed anything in the nvidia control panel? I am running the newest stable nvidia drivers 180.48 WHQL on Vista 64-Bit Business and the bug is still there. Also with Firefox 3.1b2, which I have tested yesterday.

But if this should be a driver problem, why Opera or IE on the same installation do not have this problem? Because of the browsers rendering engine in conjunction with the nvidia drivers?
I have this bug on two computers, and only one has an NVidia graphics adapter.

The first is a homebuilt desktop with Intel DG45ID motherboard with G45 chipset and integrated Intel X4500HD graphics.  This machine has never had NVidia drivers installed.

The second is a Lenovo SL500 laptop with a NVidia 9300M GS graphics adapter.

The machines run Vista Ultimate SP1 and Business SP1 respectively, and have Firefox set to update itself automatically, and have exhibited this problem since they were installed over two months ago.
Further regarding the comment that "This is definitely shaping up to be a 64-bit nVidia thing," the laptop I mention in my last comment runs 32-bit Vista.  The desktop (non-NVidia) runs 64-bit Vista.  It seems clear to me that neither a 64-bit OS nor an NVidia graphics adapter are necessary to manifest this bug.
OK, I stand corrected. It's just a Firefox 3.x + Flickr thing, then?

@Thomas: I've never even opened the NVIDIA control panel, so no I haven't changed anything there.
This happens to me too, for what it's worth. Firefox 3.0.5, Vista Ultimate 64-bit, nVidia hardware.

Here's a screen snapshot example: http://flickr.com/photos/tlcub4bear/3241552834/
Todd's screenshot is very similar to what I see (on both 64- and 32-bit Vista, and not limited to NVidia graphics).
This will be solved by the patch on bug 474886.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474886
You need to log in before you can comment on or make changes to this bug.