RFE: Open a new window via selection option on the Firefox Dock Icon when right clicking on said icon

RESOLVED DUPLICATE of bug 415463

Status

()

Firefox
Shell Integration
--
enhancement
RESOLVED DUPLICATE of bug 415463
10 years ago
10 years ago

People

(Reporter: 11superstrings@gmail.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008052504 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008052504 Minefield/3.0pre

Feature request.  It would be a wonderful feature to be able to right click on the Dock icon for Firefox and have an option to open a new window.  This is a feature with Safari that I have found very useful and would love to have it included in Firefox.  Thank you for your time and thank you for such a great product!!

Reproducible: Always

Steps to Reproduce:
1. Right Click on Dock Icon for Firefox
2. 
3.
Actual Results:  
No option for "New Window"

Expected Results:  
Would be nice to have this option.

Build platform
target
i386-apple-darwin8.8.4

Build tools
Compiler 	Version 	Compiler flags
gcc-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -Wno-long-long -g -gfull -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fpascal-strings -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon
g++-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long -g -gfull -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon

Configure arguments
--target=i386-apple-darwin8.8.4 --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk --enable-application=browser --enable-update-channel=nightly --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-codesighs
(Reporter)

Comment 1

10 years ago
Created attachment 322453 [details]
Safari's "New Window" option as an example

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415463
You need to log in before you can comment on or make changes to this bug.