Live bookmarks of rss is not rendering ASCII characters properly.

RESOLVED DUPLICATE of bug 252147

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 252147
10 years ago
8 years ago

People

(Reporter: Robert, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0

Place holders such as & or ' in rss code are not being converted to & or ' respectively. The place holders are rendering as & or ' in the live bookmarks dropdown menus.

View a screenshot of the bug at: www.cat-bob.com/bugs/rssBug.bmp

Download the rss code bookmarked to produce the error at: www.cat-bob.com/bugs/googleNewsAustralia-26-May-08.rss

Subscribe to: http://news.google.com.au/?output=rss



Reproducible: Always

Steps to Reproduce:
1. Open this page www.cat-bob.com/bugs/googleNewsAustralia-26-May-08.rss
2. When firefox asks what to do, select bookmarks toolbar in the 'create in:' selection
3. Click on the new button in the bookmarks toolbar
Actual Results:  
Place holders such as & or ' in rss code are not being converted to & or ' respectively.

Expected Results:  
Place holders such as & or ' in rss should be converted to & or ' respectively.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
RSS does not allow HTML in title element.
so use the ATOM feed instead: http://news.google.com.au/news?ned=au&output=atom
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: Bookmarks & History → Places
QA Contact: bookmarks → places
Resolution: --- → DUPLICATE
Duplicate of bug: 252147
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.