Custom Message filter for "Status" header is overridden by Thunderbird's own "Status"

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: mozillabug, Unassigned)

Tracking

Trunk
Thunderbird 7.0
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 20080421

When a message is read with Pine it sets the "Status" header to "R". When Thunderbird imports this message later it considered it unread (new). I'd like for Thunderbird to mark it as read when the status contains "R". However, the built-in Status filter only allows for "is" and "isn't" and it must be one of Thunderbird's known status values (ie. "Read" not "R").

If I create a custom header, "Status" and apply "contains R" and filter the messages it works perfectly, however, if I close Thunderbird and re-open it, the filter reverts to "Status is Read" (ie. overriding my customer Status and using the original built-in Status). Is there anyway to use the Pine Status with Thunderbird's filters?


Reproducible: Always

Steps to Reproduce:
1. Create Custom message filter "Status: contains R" 
2. Save
3. Run filter -- works
4. Exit Thunderbird
5. Run Thunderbird
6. Edit this filter, notice it's now "Status: is Read"
"Status:" version of Bug 388449 on "Date:".

(1) Create custom header of "Status"
(2) Create filer rule of "Status contains R" (custom header, Status at bottom) 
    Content of msgFilterRules.dat
      condition="OR (\"Status\",contains,R)"  (Tb 2.0.0.14)
      condition="OR (\"status\",contains,R)"  (Tb trunk 2008/5/22 build)
(3) Terminate Thunderbird    
    Content of msgFilterRules.dat
      condition="OR (\"Status\",contains,R)"  (Tb 2.0.0.14)
      condition="OR (\"status\",contains,R)"  (Tb trunk 2008/5/22 build)
(4) Restart Thunderbird, Tools/Message Filter, then close message filter panel
    (no need to edit message filter rules)
    Content of msgFilterRules.dat
      condition="OR (status,contains,)"       (Tb 2.0.0.14)
      condition="OR (status,is,replied)"      (Tb trunk 2008/5/22 build)

Since \"Status\"(custom header) is changed to status(standard one) at msgFilterRules.dat processing, chosen "Status" becomes upper one(standard Status) when edit of the message filter rule is executed after restart.

Problem is re-produced with both Tb 2.0.0.14 and Tb trunk 2008/5/22 build.
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Version: unspecified → Trunk
Bug for customized Date: header was Bug 378449. Sorry for mistype and spam.
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Checked with Tb 7(bug 525022 comment #13), and Tb 8.0 again.
condition="AND (\"Status\",contains,pqr)" was always kept, and it worked as expected.
=> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → Thunderbird 7.0
You need to log in before you can comment on or make changes to this bug.