Java 6.0 update 10 b24 starts when opening Chatzilla

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
minor
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Assigned: James Ross)

Tracking

Trunk
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.83])

Attachments

(1 attachment, 2 obsolete attachments)

Using the latest test version of Java 6.0U10b24 on trunk build 3.0pre the java console will start up and remain in the systray, and will increase memory use of Firefox loading a base runtime of java I assume.  No idea why starting Chatzilla will launch the java console, but its unnecessary.  

This version of java also introduces the Java Quick Starter Extension 1.0 that will be required it seems going forward with Firefox 3.1a1pre and Moz2. 

Running Vista HP SP1 and build:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008052606 Minefield/3.0pre Firefox/3.0 ID:2008052606
Chatzilla version 0.9.82.1
(Assignee)

Comment 1

10 years ago
This is probably from line 117 in http://mxr.mozilla.org/seamonkey/source/extensions/irc/js/lib/utils.js#112:

  jsenv.HAS_JAVA = (typeof java == "object");

The IRC library must make this check, however, and it never used to cause the Java plugin to start - but that was when Java was special-cased. Perhaps we could shortcut the check if HAS_XPCOM is true?
Severity: normal → minor

Comment 2

10 years ago
I can't reproduce this on XP, for what it's worth. Also, how would I even check which version of Java I have, or how do I tell it to update without downloading and installing a completely new SDK?
Look in about:plugins - should tell you what version of Java you have, or open the Control Panel, click the Java Icon and look at the version there. 

I don't know of anyway to get an update since Upadate 10 b24 (build) is still in Beta short of downloading and installing jre. 

Also note, that having more than one version on your system 'can' cause problems, as I myself, always uninstall the old version before installing a new version.. but that's just me.
Looks like Sun may have pulled b24, as they now have b23 posted: 
http://java.sun.com/javase/downloads/ea.jsp

I had b14 before that, so I don't the version change is going to fix the problem of java starting w/chatzilla.

Comment 5

10 years ago
Created attachment 323135 [details] [diff] [review]
Patching something we don't fully understand

Blah. I don't like doing this, but if we have to because java sucks, then we can. Jim, could you test this patch? Thanks.
Assignee: rginda → gijskruitbosch+bugs
Status: NEW → ASSIGNED

Comment 6

10 years ago
Created attachment 323137 [details] [diff] [review]
Almost equally sucky, but still slightly better patch

Oops. I misunderstood Silver's comment, I think. This is a slightly better patch. Doh.
Attachment #323135 - Attachment is obsolete: true
(Assignee)

Comment 7

10 years ago
Created attachment 323141 [details] [diff] [review]
Remove HAS_JAVA (unused) and block HAS_RHINO if we HAS_XPCOM

I also updated the XPCOM interface checks to work when there's no XPCOM, and commented the code (!).
Assignee: gijskruitbosch+bugs → silver
Attachment #323137 - Attachment is obsolete: true
Attachment #323141 - Flags: review?(gijskruitbosch+bugs)

Comment 8

10 years ago
Comment on attachment 323141 [details] [diff] [review]
Remove HAS_JAVA (unused) and block HAS_RHINO if we HAS_XPCOM

r=me

(PS: comments! win!)
Attachment #323141 - Flags: review?(gijskruitbosch+bugs) → review+
Is this patch rolled into a dev build of Chatzilla - I'm not versed well enough to even try to apply the patch - sorry but I'm more than willing to test any build you have - 

(Assignee)

Comment 10

10 years ago
I've put an XPI with the latest ChatZilla code plus this patch here:

  http://twpol.dyndns.org/temp/chatzilla-0.9.82.1-bug435772.xpi
Thanks, I'm at work now, will test tomorrow afternoon, and I work till 10pm tonight, then back to work 8 hrs later - 

Working great, no problems noted and the java issue is no longer present.
Thanks for the quick fix. 

Will mark fixed.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008053106 Minefield/3.0pre Firefox/3.0 ID:2008053106
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

10 years ago
The bug shouldn't be marked FIXED until the patch has been checked in, normally. Thanks for testing this though, and it has now been checked in. All done here!
Whiteboard: [cz-0.9.83]
You need to log in before you can comment on or make changes to this bug.