nsBasicEncoder held past XPCOM shutdown in static nsCOMPtr

VERIFIED FIXED in M18

Status

P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: dbaron, Assigned: pavlov)

Tracking

(Blocks: 1 bug, {memory-leak, topembed+})

Trunk
x86
Linux
memory-leak, topembed+
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tind-mlk][nsbeta3+])

Attachments

(1 attachment)

nsWindow::SetTitle (in GTK widget code) holds "static 
nsCOMPtr<nsIUnicodeEncoder> encoder" defined at
http://lxr.mozilla.org/seamonkey/source/widget/src/gtk/nsWindow.cpp#1992
past XPCOM shutdown.
Keywords: mlk
Whiteboard: [tind-mlk]
(Assignee)

Comment 1

18 years ago
I have a fix for this sitting in my tree waiting to get checked in
Status: NEW → ASSIGNED
Keywords: nsbeta3

Comment 2

18 years ago
nsbeta3+
Whiteboard: [tind-mlk] → [tind-mlk][nsbeta3+]
Target Milestone: --- → M18
(Assignee)

Comment 3

18 years ago
check fixed in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
*** Bug 33856 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 38671
(Assignee)

Comment 5

18 years ago
Created attachment 12575 [details] [diff] [review]
oops, missed a place

Comment 6

18 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Keywords: topembed+
Product: Core → Core Graveyard
Blocks: 60697
You need to log in before you can comment on or make changes to this bug.