Closed Bug 435810 Opened 12 years ago Closed 12 hours ago

when switching between tabs and typing something into the find toolbar firefox freezes for a long time

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: trwals, Unassigned)

References

()

Details

(Keywords: perf)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

When I have multiple tabs in the Facebook application Warbook: Rise of the Infernals I will switch between a tab showing user information to the tab showing the log of all attacks/messages since I started the game and search for the username in the find toolbar which is kept open.  Often the first letter of what I type will appear and firefox will freeze for up to 30 sec with 100% cpu usage, then will work as normal and highlight what I was searching for (if present).  I can delete what is there and type something else, or type random letters, and it has no problems jumping around the page to highlight what I am searching for.  It just seems to be that 70% of the time I switch from another tab and then start searching that it freezes up.  Often I open multiple tabs at once, then click one, find a piece of information, and click back to search for that information on messages tab.

Reproducible: Sometimes

Steps to Reproduce:
1. Click the messages button in the Warbook: ROTI game, then click all.
2. Open another (or several) tab(s), for instance right clicking a user in the log and opening that page.
3. Open find toolbar if not already open.
4. Click back to messages tab and start typing in find toolbar.
Actual Results:  
Took several tries to get it to work.  First couple times with a few tabs open didn't work.  Open a few more, click a form submission button (I guess, its called Attack in this game) and the page reloaded.  After it finished I clicked back and searched for another term and it froze for about 15 sec.

Expected Results:  
Not frozen up.
Product: Firefox → Toolkit
Freezing of the main thread is - most probably - not caused by the findbar in this case, but because the game tabs are eating up all the CPU time and memory.
Component: Find Toolbar → General
Product: Toolkit → Firefox
Keywords: perf

Since the facebook game is no longer available, can this bug be closed?

Flags: needinfo?(mdeboer)
Status: UNCONFIRMED → RESOLVED
Closed: 12 hours ago
Flags: needinfo?(mdeboer)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.