If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozilla hangs (problem with java script?)

VERIFIED DUPLICATE of bug 37463

Status

()

Core
Networking
P3
critical
VERIFIED DUPLICATE of bug 37463
18 years ago
17 years ago

People

(Reporter: pg, Assigned: Scott MacGregor)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m16) Gecko/20000613
BuildID:    20000613211



Reproducible: Always
Steps to Reproduce:
1.select URL
2.(any currency will do)
3.hit go

Actual Results:  mozilla will hang

Comment 1

18 years ago
Confirmed on PC/Linux, build 2000062220.
The stack traces are the same as in bug 37463.
I'd like to mark this dup, but I can't find any location change on that page.
Reassigning to the owner of that bug.
Please mark dup if this testcase works fine with that bug's patch.
Assignee: rogerl → mscott
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 3.1 → All

Comment 2

18 years ago
Confirmed on Mac OS 8.6/2000061411.  Changin Platform to ALL.  Adding CRASH 
keyword.
Keywords: crash
Hardware: PC → All

Comment 3

18 years ago
Note the link under the "Go" button at the above website is a JavaScript URL:

                      javascript:doconvert();


There is a general problem with JavaScript URLs not working.
Resolving this as duplicate of bug 41707 -

*** This bug has been marked as a duplicate of 41707 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Component: Javascript Engine → Networking
Resolution: --- → DUPLICATE

Comment 4

18 years ago
I've had a look at bug 41707, but I could not find any mention of a hang, freeze
or crash there. Thus I don't buy the current duplicate resolution. Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

18 years ago
Also compare bug 37463 (lockup/freeze upon javascript: Window.Location = etc.)
(Assignee)

Comment 6

18 years ago
this is a dup of 37463

*** This bug has been marked as a duplicate of 37463 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
The bug this was duped against has been fixed, and I'm not seeing this behavior
anymore with Linux build 2000110621. Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.