Extensions check during startup opens empty proxy credential window for each extension

RESOLVED FIXED

Status

()

Toolkit
Add-ons Manager
--
minor
RESOLVED FIXED
10 years ago
5 years ago

People

(Reporter: Premysl Krcmar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.9) Gecko/2008051202 Firefox/3.0

On first run or after version switch or after some period during firefox startup it checked for new extensions and pop up empty proxy login window for each extension even I previously fill the proxy credentials and checked the box to remember it. 


Reproducible: Always

Steps to Reproduce:
1. everytime on first run
2. everytime when you switch versions of firefox
3. sometimes after expired time for extensions new version check
Actual Results:  
Pop-up many empty proxy login windows.

Expected Results:  
1) It would be nice if it pops up only one window
2) Even nicer if it takes saved proxy credentials
3) and the best if it does not pop up anything unles proxy credentials are invalid and proxy denied it.
Component: Build Config → Extension/Theme Manager
QA Contact: build.config → extension.manager
Whiteboard: DUPEME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Updated

10 years ago
Blocks: 449216
This will be essentially the same issue as bug 356930
Blocks: 356930
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Depends on: 348997
Depends on: 475053
No longer depends on: 348997
No longer blocks: 356930
Should have been fixed by bug 339804
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.