[ForumUX] Spaces in URLs are converted to plusses

VERIFIED FIXED in 1.4

Status

support.mozilla.org
Forum
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: Jason Barnabe (np), Assigned: jsocol)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: forumux_only sumo_triage, URL)

Attachments

(1 attachment)

Updated

10 years ago
Target Milestone: --- → Future
Created attachment 390050 [details] [diff] [review]
SQL patch, v1

Removing the regex for turning " " (space) into "+" (plus) does the trick. I used the following test post:
---------------
((Test kb rename old|blah))

[http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0.12/win32/en-US/Firefox%20Setup%203.0.12.exe|text]
---------------
Noted that internal links still work as expected.
Assignee: nobody → paul.craciunoiu
Attachment #390050 - Flags: review?(laura)
Attachment #390050 - Flags: review?(cwwmozilla)
Also bumping the severity, since this breaks links with spaces (e.g. for links to download our releases)
Severity: minor → normal
Summary: Spaces in URLs are converted to plusses → [ForumUX] Spaces in URLs are converted to plusses
Target Milestone: Future → 1.4
Oh. For testing, make sure to clear the cachelib (regexes are cached there, see webroot/lib/smarty_tiki/outputfilter.urlt.php)

Updated

9 years ago
Attachment #390050 - Flags: review?(cwwmozilla) → review+

Comment 4

9 years ago
Comment on attachment 390050 [details] [diff] [review]
SQL patch, v1

tested on sumotools and it wfm.

Comment 5

9 years ago
Did you test for regressions?  That is, is this bit of regex used by any other bits of code where it might actually be correct?
I tested a bit, URLs with spaces seem to be handled alright in articles. Does it work for you Laura? Try removing the ! before $cachelib on line 95 of outputfilter.urlt.php to test.

Comment 7

9 years ago
Comment on attachment 390050 [details] [diff] [review]
SQL patch, v1

Let's get it into QA.
Attachment #390050 - Flags: review?(laura) → review+
(In reply to comment #7)
Laura: should I file an IT bug for running the SQL and clearing the cache on ForumUX?

Comment 9

9 years ago
On the staging server?  Yep.
Depends on: 511993
Cheng, Chris: want to verify this on our forumux branch?
http://sumo-forumux.stage.mozilla.com/en-US/kb/

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: forumux_only
(In reply to comment #8)
> (In reply to comment #7)
> Laura: should I file an IT bug for running the SQL and clearing the cache on
> ForumUX?

Not sure if this was filed before, but looks like we need it now, given that the URL in my test post in https://support-stage.mozilla.org/tiki-view_forum_thread.php?comments_parentId=446729&forumId=4 still gets a "+" added where %20 (space char) was.
(Assignee)

Updated

9 years ago
Assignee: paulc → james
Reopening; SQL's been run in bug 511993, and my test post in comment 11's URL still has + characters as delimiters.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

9 years ago
Depends on: 517975
The SQL was run on forumux, not on support-stage.  Filed  bug 517975 to get it run there.
(Assignee)

Comment 14

9 years ago
Closing since bug 517975 closed. Stephen?
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(In reply to comment #14)
> Closing since bug 517975 closed. Stephen?

Yup, w00t; verified FIXED on https://support-stage.mozilla.org/tiki-view_forum_thread.php?comments_parentId=446729&forumId=4.
Status: RESOLVED → VERIFIED
Not sure if this needs upstreaming?
Whiteboard: forumux_only → forumux_only sumo_triage
You need to log in before you can comment on or make changes to this bug.