Letters i and ў in Belarusian text look different than other letters

RESOLVED WORKSFORME

Status

()

Core
Internationalization
--
major
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Yuri, Assigned: smontagu)

Tracking

1.9.0 Branch
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.9a2) Gecko/20080322 Firefox/3.0a2
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.9a2) Gecko/20080322 Firefox/3.0a2

These 2 letters belong in Belarussian alphabet but not Cyrillic one where all other letters came from. And their style is totally different. This makes the whole text look ugly.

Opera doesn;t have this problem.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

9 years ago
Assignee: nobody → mozilla_by
Component: General → be / Belarusian
Product: Firefox → Mozilla Localizations
QA Contact: general → belarusian.be

Comment 1

9 years ago
Created attachment 368784 [details]
The page snapshot on Mandriva 2008.1

Probably, it is problem of FreeBSD fonts. I don't see any problem on Linux.

Unfortunately, I don't have FreeBSD installed.
Could you tell, what version of FreeBSD is used? Could you attach a  snapshot pf the page?

Updated

9 years ago
Summary: Letters i and ў in Belarussian text look different than other letters → Letters i and ў in Belarusian text look different than other letters
(Reporter)

Comment 2

9 years ago
Created attachment 368804 [details]
One section of one article of Belarus language wikipedia

FreeBSD doesn't have it's own fonts, it uses fonts coming with X-Server and/or installed separately as packages.

I use FreeBSD 7.1-STABLE.

See how Belarussian і and ў always stand up in text.

I believe this is a defect in one/few fonts. But how can I know which font is used for a particular text?
(Reporter)

Comment 3

9 years ago
Actually Opera shows the same text beautifully on the same system.
(Reporter)

Comment 4

9 years ago
Using Font Finder add-on I found that the font used in wiki page is "sans-serif" size 12.7px. Looks like a very basic font.

On the opposite posts on this bugzilla page use font "monospace" 12px and і and ў are shown ok.

Comment 5

9 years ago
Created attachment 369835 [details]
The same page on Mandriva Linux 2008.1

I found the page you had shot. It is the same page on linux.

The used font is "sans" 12.7px

It seems it is font problem.
(Reporter)

Comment 6

9 years ago
It's very strange that on your Linux selected font for the same page is 'sans' and on my FreeBSD it's 'sans-serif'.

I have windows version of firefox running under wine on FreeBSD and Gentoo Linux. On both it says that font is 'sans-serif', size 12.7. But it looks very well on both.

I agree, looks like this is a font problem. But I do not understand why 'sans-serif' font looks different on different machines/systems. Maybe firefox substitutes fonts differently.

URL that we look at is: http://be.wikipedia.org/wiki/Кінамастацтва

Comment 7

9 years ago
Let's try to investigate further in the intl component.

Could you try to create a minimal test case (single small html file possibly) and attach it to the bug, and verify that the rendering problem still exists in current 3.5 nightly builds? Or 3.6pre nightlies, even?

3.0.x problems would be sad, but I doubt we'd try to still fix those.
Assignee: mozilla_by → smontagu
Component: be / Belarusian → Internationalization
Product: Mozilla Localizations → Core
QA Contact: belarusian.be → i18n
Version: unspecified → 1.9.0 Branch
(Reporter)

Comment 8

9 years ago
I couldn't find source tarball for 3.5 or 3.6pre.
So you know where I can grab it?
Since the problem is related to FreeBSD I need to build FF from source.

Comment 9

9 years ago
I guess the Beta 3 source tarball should be good enough, http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.1b3/source/.

The current trunk and branch trees can be gotten via Mercurial, https://developer.mozilla.org/en/Mozilla_Source_Code_(Mercurial). If you go the hg server, it's exporting snapshots, too. http://hg.mozilla.org/mozilla-central/ offers the 3.6pre sources, for example.
(Reporter)

Comment 10

9 years ago
I am not sure if there is an easy way to make a minimal testcase.

After I download wikipedia page from the URL above text is displayed differently with different fonts.

I downloaded firefox-3.1b3-source.tar.bz2. But I am getting compile errors during compile:
In file included from oggplay.c:40:
oggplay_private.h:105: error: expected specifier-qualifier-list before 'semaphore'
oggplay.c: In function 'oggplay_prepare_for_close':
oggplay.c:619: warning: implicit declaration of function 'SEM_SIGNAL'
oggplay.c:619: error: 'OggPlayBuffer' has no member named 'frame_sem'
oggplay.c: In function 'oggplay_get_available':
oggplay.c:633: warning: implicit declaration of function 'oggz_tell'
gmake[5]: *** [oggplay.o] Error 1

It might be quite difficult to build on FreeBSD because it's not clear how many potential issues like that will follow. And FreeBSD firefox-development (close to head) port isn't up-to-date any more.

So I think that it's a better strategy to find which fonts are in use for these texts and to make sure that all fonts installed support Belarus characters.

'Font Finder' plugin shows only names like 'serif' and 'sans-serif'. I am not sure why it doesn't display more detailed information on which font is used.
Which font file it comes from?
Do you know how to get this information?
Is it possible to enhance 'Font Finder' to show this information?
Yuri, some info about your problem that is already abvious :

On the systems that work, the first font found by Firefox is a Belarussian font that includes all the characters you need.
On your BSD system, the first font found by Firefox is a Cyrillic font, and Firefox only goes looking for a Belarussian font when some characters are missing.

The Font Finder add-on is more confusing than anything else, because it does not tell you what font on your system Firefox is using, *only* the font the CSS on the site told him to use. But Firefox always has to match the CSS specification with the font that actually exist on your disk, and the result is not always the same.

It is possible to find out what font is physically used by activating some logs, there's a description here about it for Windows and Mac OS :
http://groups.google.com/group/mozilla.dev.tech.gfx/msg/8c1c7ae9cb1b9ec8

Once you find out which font Firefox uses, and which font it should use, the correction would be to change some prefs to configure the belarussian font as preferred over the cyrillic one.

Comment 12

9 years ago
It isn't Firefox's problem. I think it some problem with X Server confugure.

On my Firefox all looks good.
My UA: Mozilla/5.0 (X11; U; FreeBSD amd64; en-US; rv:1.9.0.8) Gecko/2009033002 Firefox/3.0.8
OS: FreeBSD 7.2-PRERELEASE

Comment 13

9 years ago
Created attachment 370046 [details]
The same page on FreeBSD 7.2-PRERELEASE
(Reporter)

Comment 14

9 years ago
My Files section in xorg.conf is:
Section "Files"
    FontPath   "/usr/local/lib/X11/fonts/misc/"
    FontPath   "/usr/local/lib/X11/fonts/TTF/"
    FontPath   "/usr/local/lib/X11/fonts/OTF"
    FontPath   "/usr/local/lib/X11/fonts/Type1/"
    FontPath   "/usr/local/lib/X11/fonts/100dpi/"
    FontPath   "/usr/local/lib/X11/fonts/75dpi/"
    FontPath   "/usr/local/lib/X11/fonts/local/"
    FontPath   "/usr/local/lib/X11/fonts/TrueType/"
    FontPath   "/usr/local/lib/X11/fonts/cyrillic/"
EndSection

Cyrillic fonts are there.
Anything wrong with it?

Comment 15

9 years ago
It's just folder and maybe empty.

Maybe need install some TrueType fonts:
/usr/ports/x11-fonts/freefont-ttf
/usr/ports/x11-fonts/dejavu
(Reporter)

Comment 16

6 years ago
9.X version now looks good, also with suggestions above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.