Last Comment Bug 436210 - I can't click on links in Flash in Zillow.com
: I can't click on links in Flash in Zillow.com
Status: RESOLVED WORKSFORME
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.zillow.com/search/RealEsta...
Depends on:
Blocks: 310174
  Show dependency treegraph
 
Reported: 2008-05-28 16:17 PDT by John
Modified: 2013-09-22 10:33 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description John 2008-05-28 16:17:29 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

I can't click on links in Flash in Zillow.com

Reproducible: Always

Steps to Reproduce:
1. Go to any house... like http://www.zillow.com/search/RealEstateSearch.htm?addrstrthood=584+kenridge+circle&citystatezip=30084
2. Try to click "See Home Info" or "See Comparable Homes"

Actual Results:  
Nothing

Expected Results:  
Go to a different page

This works on FF 2. I have no addons. Using Flash 9 r124
Comment 1 Corey Farwell 2008-05-28 23:37:54 PDT
Both of those links seem to work for me.
Firefox 3 RC1 / Linux / Flash 9.0 r124
Even though you have no addons anyways, try running Firefox in safe-mode and see if it makes a difference.
Comment 2 Marcia Knous [:marcia - use ni] 2008-05-29 11:22:37 PDT
Confirmed - I see the same thing using  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008052904 Minefield/3.1a1pre. I am using r124 version as well.
Comment 3 John 2008-05-29 11:26:34 PDT
Happens in safemode too.
Comment 4 Corey Farwell 2008-05-29 13:18:04 PDT
Is this the same issue? https://bugzilla.mozilla.org/show_bug.cgi?id=436301
Comment 5 Corey Farwell 2008-05-29 13:24:27 PDT
I upgraded my Firefox 2.x with Flash r124 to Firefox RC1 (all on Windows XP), and flash seemed to transfer over fine.  I went to Zillow and the links don't seem to work, so this does seem to be a bug.
Comment 6 Luke Bellandi 2008-05-29 13:36:02 PDT
Possibly the same issue. What rect of the Zillow Flash app canvas isn't responding to events, and what is the app's total rect?
Comment 8 Marcia Knous [:marcia - use ni] 2008-05-29 15:48:59 PDT
Just wanted to note that I see this running on Windows Vista as well -  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008052904 Minefield/3.1a1pre using r124. This site works fine on Mac using the RC2 candidate build.
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2008-06-02 10:45:19 PDT
Marking this as a dupe of 434914 which it probably was :)

Marcia: we recently did another cvs->hg merge, so this should now be fixed on 3.1a1pre. If not, please re-open.

*** This bug has been marked as a duplicate of bug 434914 ***
Comment 10 Steven Michaud [:smichaud] (Retired) 2008-06-02 11:21:48 PDT
Mike, this is very unlikely to be a dup of bug 434914 -- it appears to be a mouse bug, not a keyboard bug.

Marcia and others, please see if this is still reproducible in the latest Firefox 3 nightly.  If it is, then this isn't a dup of bug 434914.

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.9.0/firefox-3.0pre.en-US.mac.dmg
Comment 11 Luke Bellandi 2008-06-02 11:28:21 PDT
Strange. I still see the bug in 6/2/2008 RC2-nightly with Flash Player 10 Beta, but it behaves correctly with Flash Player 9r124.
Comment 12 Luke Bellandi 2008-06-02 11:29:15 PDT
(scratch that last comment -- meant for another bug.)
Comment 13 Steven Michaud [:smichaud] (Retired) 2008-06-02 11:57:53 PDT
(Following up comment #10)

Now that I've read this bug more carefully, I see it's cross-platform
... and therefore can't have anything to do with bug 434914.
Comment 14 Steven Michaud [:smichaud] (Retired) 2008-06-02 11:59:08 PDT
> it's cross-platform

Or, um, Windows-specific.
Comment 15 Marcia Knous [:marcia - use ni] 2008-06-02 12:19:29 PDT
I still am having trouble with zillow navigation using  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008060204 Minefield/3.1a1pre. Specifically, the following things don't work on Windows:

1. Can't use the various zoom levels on the map navigational controls on the left hand side (Street, City, State, USA)
2. When I enter a zip code (94043) and click on a cluster of homes returned in the map, it doesn't give me the popup to navigate to the more detailed view of the groups of homes.

Using the latest nightly on Mac Leopard, Items #1 and #2 work.
Comment 16 nightisfalling 2008-06-08 20:56:27 PDT
It didn't work for me either but now it does.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Comment 17 John 2008-06-08 22:15:15 PDT
It's working here too.
Comment 18 Ria Klaassen (not reading all bugmail) 2008-06-09 01:41:10 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008060807 Minefield/3.1a1pre

The site has apparently corrected its code. Since there's no testcase attached, I think it is not useful to keep this bug open.
Comment 19 Brian Fitzgerald 2013-09-20 14:18:30 PDT
I can not get it to work and the same problem on other sites like;

<a href=”http://www.northtexashomesforsale.com/Search-Homes” >Click Here to Search Homes for Sale in North Texas</a>
Comment 20 Brian Fitzgerald 2013-09-20 14:19:06 PDT
<a href="http://www.northtexashomesforsale.com/Search-Homes" >Click Here to Search Homes for Sale in North Texas</a>
Comment 21 Brian Fitzgerald 2013-09-20 14:20:07 PDT
<a href="http://www.northtexashomesforsale.com/" >North Texas Homes For Sale</a> 

http://www.northtexashomesforsale.com/"
Comment 22 Georg Fritzsche [:gfritzsche] 2013-09-22 10:33:46 PDT
Brian, this apparently was not an issue anymore in 2008. Can you please file a new bug on this with more specific steps on how to reproduce your problem?

Note You need to log in before you can comment on or make changes to this bug.