Closed Bug 436244 Opened 12 years ago Closed 12 years ago

Tsushima needs to be included in Japan

Categories

(Webtools Graveyard :: Download Day, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: negoro, Unassigned)

Details

(Keywords: jp-critical)

Attachments

(1 file)

I am sorry to come up with it, but we got a contact from a user that Tsushima needs to be in Japan. 
http://en.wikipedia.org/wiki/Image:Tsushima-sat.jpg

I appreciate your time to modify it.
Actually, we got several comments at our staff blogs. We need your help to resolve this issue become too big...
http://blogs.mozilla-japan.org/inside/entry/1986/#comments
Attached image screenshot
Getting harder.. Please help me...
Please address this ASAP.
Severity: normal → major
Hardware: PC → All
Probably this is an original map.
http://www.ammap.com/download/
(In reply to comment #5)
> Probably this is an original map.
> http://www.ammap.com/download/

looks like the border data is in the swf file directly...
Many Japanese angry the Tsushima issue in Japanese major BBS site too.
and Minami-chishima has problem too.
http://en.wikipedia.org/wiki/Kuril_Islands
Japan insists on the dominium of the Minami-chishima.
I and almost all Japanese know that Russia insist on the dominium of the Minami-chishima too.

I and all Japanese cannot approve a current map as a Japanese.
I think that Minami-chishima will be deleted from this map.

Regardless of the conclusion of the Chishima Islands problem, Tsushima needs to be in Japan.
I think that we should remove the map, because we may not be able to control the borders. And the map painted the many undefined borders as 'actual' borders in the world. So, many people may be discomforted by the map.

# Google Maps changes the borders and the name of places on each localized versions. This is too delicate issue.
Hi all:  Just catching up here.  All of us were getting some well-deserved
sleep.  So the issue is that we need to include Tsushima?  I will have Ryan
look into this as soon as I reach him.  We used that ammap map so we might need
to reach the developer to have him update it.  He has been really helpful so
far and I am confident he would work on this.

I am not sure I understand Masayuki's comment - are you suggesting we remove
the pledge map all together?

(In reply to comment #9)
> Hi all:  Just catching up here.  All of us were getting some well-deserved
> sleep.  So the issue is that we need to include Tsushima?

I'm not sure, some Japanese people think that Chishima should be included in Japan, but most Russian people don't think so, probably. The country border problems are too complex...

> I am not sure I understand Masayuki's comment - are you suggesting we remove
> the pledge map all together?

Yes. The map paints the borders very clearly, but they should not be so in some places on some countries/areas. Mozilla should not stimulate such problems.
(In reply to comment #10)
> (In reply to comment #9)
> > Hi all:  Just catching up here.  All of us were getting some well-deserved
> > sleep.  So the issue is that we need to include Tsushima?
> 
> I'm not sure, some Japanese people think that Chishima should be included in
> Japan, but most Russian people don't think so, probably. The country border
> problems are too complex...

Tushima should be included in Japan. That is a mistake of the original author of the map. But we have other border problems now... MJ blog has such comments. The Tushima bug called the other complex problems... I meant that I'm not sure that we should *only* fix the Tushima problem.
Ok -- We'll definitely ask the developer to include Tushima.  Please let me explicitly what other changes you want made.

Thanks!
(In reply to comment #12)
> Ok -- We'll definitely ask the developer to include Tushima.

Thank you.

> Please let me explicitly what other changes you want made.

Other claims in MJ blog are issues on the diplomacy between two or more countries. We can/should not chose any comments. So, we should not use any maps which have the borders in our marketing.
It will solve problem temporally.
There is many regions in the world that have border problems. This can happen about any of them and can destroy crossborder community relationships.
And there is another opinion "Why we have to compete between Firefox users? we should take hands togather and charange world record."

Solutions that Masayuki proposed and others are these:
* Use deformed map. landscape is deformed and borders are unclearified.
* Other way of grouping. Continent, localized binaries, etc...
* Googlemap or something mashup apis... We get no abuse. 
* Use NO map. If you need visual effects 
* No grouping, no competition.

We have another risk reveiled by this issue brings big minus to promote, one of comments on MJ blog said: "Mozilla make us their enemy. instead we promote other browsers from now on!"

We must discuss until next time.
It is not the best choice, but wants you to blank Minami-chishima. not include Russia.
Some kinds of people are really susceptible for issues related on territorial carve-ups. Even google or some other portal sites are considering about them. (like google maps for toponomastic problems)
I think it's true that this is worth for 'jp-critical', but it's not only for jp. In the map 'Taiwan' is separated to Chinese, or the same for Falkland Iss., middle-easts, etc.

If we miss to taking actions on this problem, it could affect to the "share" of FF, i think.
Mozilla shouldn't join political problems, we must solve this mistakes as soon as we can.
I think it's good that we map each continent, not each nation.
But the best is not to use map (mapping the world lightly is very difficult and dangerous...) if we can bear no visual effects.

In MJblog, radical comments are also seen. The later we solve this problem, the worse some people's image for Mozilla is...
I've emailed the developer of the map, should hopefully have an updated map by end of day today.
Status: NEW → ASSIGNED
Thanks for the update Ryan.  As soon as the map is updated, we'll notify our community.  We look forward to the news.
Appreciate the end of day happened. The quick reaction would help us get back the trust!
OS: Windows XP → All
Looks like it is fixed. Thank you for the quick response.
-> FIXED

Thank you!
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified FIXED on staging: http://img524.imageshack.us/my.php?image=picture4pz4.png; will be fixed when we next svn up...
Status: RESOLVED → VERIFIED
Though "Tsushima" was fixed, map is not still perfect.
(correct map is http://www.abysse.co.jp/japan/japanmap/japanmap05.html, for instance.)
I think Oki Islands (http://en.wikipedia.org/wiki/Oki_Islands) and Izu Islands (http://en.wikipedia.org/wiki/Izu_Islands) are not mapped, for example (I think this map may have more problems...)
And all Kuril Islands (see http://en.wikipedia.org/wiki/Kuril_Islands_dispute) is mapped as Russian territory...
Hello everyone:  I want to apologize for the discrepancies in the map.  Finding a complete map and country list was nearly impossible, but we're taking all this feedback seriously and working with the map developer to resolve things. We're definitely not trying to make any political statements here so I really appreciate your help on isolating these problems.

We'll get these newest ones resolved as soon as possible.

The goal with the map was to inspire participants and show the truly global passion for Firefox :)

Thanks again! 
(In reply to comment #24)
> Though "Tsushima" was fixed, map is not still perfect.
> (correct map is http://www.abysse.co.jp/japan/japanmap/japanmap05.html, for
> instance.)
> I think Oki Islands (http://en.wikipedia.org/wiki/Oki_Islands) and Izu Islands
> (http://en.wikipedia.org/wiki/Izu_Islands) are not mapped, for example (I think
> this map may have more problems...)

Hey, the map is not a detailed map, these islands are too small. Are you want to add the *all* islands of the world??
> Are you want to add the *all* islands of the world??
No, I don't want to. (especially, Oki...)  There is no need that too small islands are mapped...
More islands shown, more bombs we have. To do is clean all risks at once or fix each bug reported.
(Islands that have problem about marine borders are mostly small. "200mile economic zone" around is more important than island itself.)
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.