"Enter name of file to save to ..." dialog is not focused

RESOLVED DUPLICATE of bug 431544

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 431544
10 years ago
9 years ago

People

(Reporter: Takanori MATSUURA, Unassigned)

Tracking

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ja; rv:1.9pre) Gecko/2008052715 Fedora/3.0-0.65.pre.cvs2008052623.fc9 Minefield/3.0pre
Build Identifier: 

When downloading files, "Enter name of file to save to ..." dialog is opened but not focused.

The dialog is focused but the focus is immediately returned to the browser window.

Reproducible: Always

Steps to Reproduce:
1. Click the link for foo.dmg etc.
2. Select "Save File" in "Opening foo.dmg" dialog
3. Click "OK" button
Actual Results:  
"Enter name of file to save to ..." is shown and focus is return to the browser window.

Expected Results:  
"Enter name of file to save to ..." dialog is shown and focus is kept to the "Enter name of file to save to ..." dialog.
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?
Needs to be confirmed before it can block, adding tchung, but this will likely be one of the usual smoketests that QA does.
Flags: blocking-firefox3?
Keywords: qawanted

Comment 2

10 years ago
Confirmed (Mac OS 10.5.2 and 10.5.3 Leopard). Happens strictly all the time in multiple sites and with RC1 as well as RC2. Gee, can't imagine this one is not yet confirmed / assigned ! Please fix before release !!!

Comment 3

10 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9) Gecko/2008052903 Firefox/3.0

Reproducing this bug gets different results:

Cant get foo.dmg to work - it is for PCs not macs ...


STEPS TO REPRODUCE:
1 Need a .dmg file - so  i went to:

http://www.videolan.org/mirror.php?
mirror=http://mirror.services.wisc.edu/mirrors/videolan/&file=vlc/0.8.6h/macosx/vlc-0.8.6h.dmg

2 this results in Opening vlc-0.8.6h.dmg dialog box - also the desktop gets a random name like 
wOTxAyG8.exe.part file appearing on the desktop

3 select save file button
4 click OK button
RESULT
the icon on the desktop changes and it's name is now vlc-0.8.6h.dmg
the previous dialog closes and a new dialog Downloads opens

The Save As dialog box does not open as described.

FF2 and Safari both open the download box - safari opens the dmg to a disk image on the desktop and FF3 requires you to double click the icon


Comment 4

10 years ago
> Bob : Nope, this is not what we are talking about. The bug occurs only of you check (in preferences) "Always ask where to save downloaded files" (sorry for the appriximative translation, I'm using the french version). 

So, if you need a step-by-step guide to reproducing the bug, here it is. 

1. 
Set preferences to "Always ask where to save downloaded files"

2. 
Click this link : http://www.panic.com/coda/ and click on "Download" 
OR
Type this URL directly in FF3's address bar : http://www.panic.com/coda/d/Coda%201.1.zip

(actually, ANY URL pointing to a file that FF can't handle internally would do the trick). 


3. Watch the FIRST dialog box appear, saying "you opened file (blah blah) now what do you want to do, open it with (blah) or save it ?". 

4. Check "Save it to disk" and click OK

5. Now watch the SECOND dialog box appear (classic "save as..." dialog). And guess what... this second dialog DOES NOT have the focus. The browser window has it. 

ADDED : this is EXTREMELY annoying, notably because in a classic "save as..." dialog on the Mac, you are allowed to type "command-D" to instantly go to the desktop. Very convenient, unless you type command-D when it is the browser window that is focused, because then you just create a bookmark (rats, not only will I have to re-focus, go to desktop and save, but I'll also have to remember getting rid of that bookmark). 

Got it now ? ;-)

Thanks again for putting this on top of the pile. It's probably nothing, but it's EXTREMELY frustrating for Mac users... 

Comment 5

10 years ago
confirm this. was able to reproduce on rc3 on Mac OS X 10.5.3 and Windows XP SP3
Confirming, I see this using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

10 years ago
Is this still QAWanted?
Keywords: qawanted

Comment 8

9 years ago
Confirmed and voted. This **** is still going on in FF3.1 betas.

Comment 9

9 years ago
This bug is probably a duplicate of Bug 431544
Yes, it is. Thanks for pointing that out.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 3.0 Branch
Duplicate of bug: 431544
You need to log in before you can comment on or make changes to this bug.