Build error with Forte 6.0 on Solaris 2.8 INTEL

VERIFIED WORKSFORME

Status

SeaMonkey
Build Config
P3
blocker
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Markus Doehr, Assigned: cls)

Tracking

Trunk
Future
x86
Solaris

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
I'm trying to build the tip of the tree with Forte 6.0 while getting this error:

CC -library=iostream -o nsFtpConnectionThread.o -c -DOSTYPE=\"SunOS5\" -DOJI  -I
../../../../dist/include -I../../../../include        -KPIC  -mt -O  -DNDEBUG -D
TRIMMED -DMOZILLA_CLIENT -DBROKEN_QSORT=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_
INO=d_ino -DMOZ_WIDGET_GTK=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DSTDC_HEADERS=1 -DHA
VE_ST_BLKSIZE=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1
 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 -D
HAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_FILIO_H=1 -DHAVE_SYS_IPC_H=1 -DHAVE
_SYS_SHM_H=1 -DHAVE_X11_EXTENSIONS_XSHM_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_ST
ATFS_H=1 -DHAVE_SYS_VFS_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1 -D
HAVE_LIBRESOLV=1 -DHAVE_LIBSOCKET=1 -DHAVE_LIBNSL=1 -DHAVE_LIBELF=1 -DHAVE_LIBIN
TL=1 -DHAVE_LIBPOSIX4=1 -DHAVE_LIBW=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_QSOR
T=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_L
OCALTIME_R=1 -DHAVE_STATVFS=1 -DHAVE_MEMMOVE=1 -DHAVE_USLEEP=1 -DHAVE_GETTIMEOFD
AY=1 -DGETTIMEOFDAY_TWO_ARGS=1 -DHAVE_DEV_ZERO=1 -DHAVE_IOS_BINARY=1 -DHAVE_OSTR
EAM=1 -DHAVE_CPP_EXPLICIT=1 -DHAVE_CPP_SPECIALIZATION=1 -DHAVE_CPP_MODERN_SPECIA
LIZE_TEMPLATE_SYNTAX=1 -DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS_CHA
NGING_USING=1 -DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_NAMESPACE_STD=1
-DHAVE_CPP_UNAMBIGUOUS_STD_NOTEQUAL=1 -DHAVE_CPP_NEW_CASTS=1 -DHAVE_CPP_DYNAMIC_
CAST_TO_VOID_PTR=1 -DNEED_CPP_UNUSED_IMPLEMENTATIONS=1 -DHAVE_I18N_LC_MESSAGES=1
 -DMOZ_MAIL_NEWS=1 -DMOZ_ENDER_LITE=1 -DNS_MT_SUPPORTED=1 -DMOZ_USER_DIR=\".mozi
lla\" -DMOZ_MATHML=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DJ
S_THREADSAFE=1 -DLAYERS=1  nsFtpConnectionThread.cpp
"nsFtpConnectionThread.cpp", line 1060: Warning: String literal converted to cha
r* in assignment.
"nsFtpConnectionThread.cpp", line 1062: Warning: String literal converted to cha
r* in assignment.
"nsFtpConnectionThread.cpp", line 1198: Warning: String literal converted to cha
r* in assignment.
"nsFtpConnectionThread.cpp", line 1200: Warning: String literal converted to cha
r* in assignment.
"", line 189: Error: String/char constants may not include line separator.
** Assertion ** : 0 (/set/taz/builds/fcs0406/intel-S2/lang/cafe/resources/cdr/sr
c/c_dataparse.cc: 967)
gmake[5]: *** [nsFtpConnectionThread.o] Error 199
gmake[5]: Leaving directory `/home/doehrm/mozilla/netwerk/protocol/ftp/src'
gmake[4]: *** [install] Error 2
gmake[4]: Leaving directory `/home/doehrm/mozilla/netwerk/protocol/ftp'
gmake[3]: *** [install] Error 2
gmake[3]: Leaving directory `/home/doehrm/mozilla/netwerk/protocol'
gmake[2]: *** [install] Error 2
gmake[2]: Leaving directory `/home/doehrm/mozilla/netwerk'
gmake[1]: *** [install] Error 2
gmake[1]: Leaving directory `/home/doehrm/mozilla'

[doehrm@sun8 ~/mozilla]$ cat ~/.mozconfig
mk_add_options MOZ_CVS_FLAGS=-q
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --enable-mathml

I built with 

[doehrm@sun8 ~/mozilla]$ CC=cc CXX=CC gmake -f client.mk build_all


Today I saw on access1.sun.com that there's a patch for Forte 6.0 but currently 
available only for sparc (109481-01).

Comment 1

18 years ago
Markus, could you please create a .i output for this file? In other words,
try doing the following in the .../mozilla/netwerk/protocol/ftp/src directory:

CC -library=iostream -o nsFtpConnectionThread.i -E -DOSTYPE=\"SunOS5\" -DOJI  -I
../../../../dist/include -I../../../../include        -KPIC  -mt -O  -DNDEBUG -D
TRIMMED -DMOZILLA_CLIENT -DBROKEN_QSORT=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_
INO=d_ino -DMOZ_WIDGET_GTK=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DSTDC_HEADERS=1 -DHA
VE_ST_BLKSIZE=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1
 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 -D
HAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_FILIO_H=1 -DHAVE_SYS_IPC_H=1 -DHAVE
_SYS_SHM_H=1 -DHAVE_X11_EXTENSIONS_XSHM_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_ST
ATFS_H=1 -DHAVE_SYS_VFS_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1 -D
HAVE_LIBRESOLV=1 -DHAVE_LIBSOCKET=1 -DHAVE_LIBNSL=1 -DHAVE_LIBELF=1 -DHAVE_LIBIN
TL=1 -DHAVE_LIBPOSIX4=1 -DHAVE_LIBW=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_QSOR
T=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_L
OCALTIME_R=1 -DHAVE_STATVFS=1 -DHAVE_MEMMOVE=1 -DHAVE_USLEEP=1 -DHAVE_GETTIMEOFD
AY=1 -DGETTIMEOFDAY_TWO_ARGS=1 -DHAVE_DEV_ZERO=1 -DHAVE_IOS_BINARY=1 -DHAVE_OSTR
EAM=1 -DHAVE_CPP_EXPLICIT=1 -DHAVE_CPP_SPECIALIZATION=1 -DHAVE_CPP_MODERN_SPECIA
LIZE_TEMPLATE_SYNTAX=1 -DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS_CHA
NGING_USING=1 -DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_NAMESPACE_STD=1
-DHAVE_CPP_UNAMBIGUOUS_STD_NOTEQUAL=1 -DHAVE_CPP_NEW_CASTS=1 -DHAVE_CPP_DYNAMIC_
CAST_TO_VOID_PTR=1 -DNEED_CPP_UNUSED_IMPLEMENTATIONS=1 -DHAVE_I18N_LC_MESSAGES=1
 -DMOZ_MAIL_NEWS=1 -DMOZ_ENDER_LITE=1 -DNS_MT_SUPPORTED=1 -DMOZ_USER_DIR=\".mozi
lla\" -DMOZ_MATHML=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DJ
S_THREADSAFE=1 -DLAYERS=1  nsFtpConnectionThread.cpp >nsFtpConnectionThread.i

Then please attach the .i output to this bug. I'll then submit a P1/S1 bug
against the Sun compiler for it. Thanks!
(Reporter)

Comment 2

18 years ago
Created attachment 10648 [details]
preprocessed output

Comment 3

18 years ago
Thanks. I've submitted Sun bug #4348105 (priority 1 / severity 1) against
this problem. I will keep this bug report updated with their replies.

Comment 4

18 years ago
I've received the following back from one of the compiler folks:
"The attached code is incomplete and cannot be compiled. For example,
the second line uses type nsIChannel, which hasn't been declared.
Please provide a compileable example."

doehrm, could you please provide a complete .i file for the compiler folks.
The output will typically be 10-20 thousands lines of preprocessed code.
Thanks.
(Reporter)

Comment 5

18 years ago
Created attachment 10651 [details] [diff] [review]
Preprocessed output 2nd try
(Reporter)

Comment 6

18 years ago
Mea culpa... There were some include errors I didn't see.
Sorry again

(Reporter)

Comment 7

18 years ago
Restarting the build I'm getting now

CC -library=iostream -o nsToken.o -c -DOSTYPE=\"SunOS5\" -DOJI -D_IMPL_NS_HTMLPA
RS -DXML_DTD  -I../../dist/include -I../../include        -KPIC  -mt -O  -DNDEBU
G -DTRIMMED -DMOZILLA_CLIENT -DBROKEN_QSORT=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1
-DD_INO=d_ino -DMOZ_WIDGET_GTK=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DSTDC_HEADERS=1
-DHAVE_ST_BLKSIZE=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UI
NT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=
1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_FILIO_H=1 -DHAVE_SYS_IPC_H=1 -D
HAVE_SYS_SHM_H=1 -DHAVE_X11_EXTENSIONS_XSHM_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SY
S_STATFS_H=1 -DHAVE_SYS_VFS_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=
1 -DHAVE_LIBRESOLV=1 -DHAVE_LIBSOCKET=1 -DHAVE_LIBNSL=1 -DHAVE_LIBELF=1 -DHAVE_L
IBINTL=1 -DHAVE_LIBPOSIX4=1 -DHAVE_LIBW=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_
QSORT=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHA
VE_LOCALTIME_R=1 -DHAVE_STATVFS=1 -DHAVE_MEMMOVE=1 -DHAVE_USLEEP=1 -DHAVE_GETTIM
EOFDAY=1 -DGETTIMEOFDAY_TWO_ARGS=1 -DHAVE_DEV_ZERO=1 -DHAVE_IOS_BINARY=1 -DHAVE_
OSTREAM=1 -DHAVE_CPP_EXPLICIT=1 -DHAVE_CPP_SPECIALIZATION=1 -DHAVE_CPP_MODERN_SP
ECIALIZE_TEMPLATE_SYNTAX=1 -DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS
_CHANGING_USING=1 -DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_NAMESPACE_ST
D=1 -DHAVE_CPP_UNAMBIGUOUS_STD_NOTEQUAL=1 -DHAVE_CPP_NEW_CASTS=1 -DHAVE_CPP_DYNA
MIC_CAST_TO_VOID_PTR=1 -DNEED_CPP_UNUSED_IMPLEMENTATIONS=1 -DHAVE_I18N_LC_MESSAG
ES=1 -DMOZ_MAIL_NEWS=1 -DMOZ_ENDER_LITE=1 -DNS_MT_SUPPORTED=1 -DMOZ_USER_DIR=\".
mozilla\" -DMOZ_MATHML=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1
 -DJS_THREADSAFE=1 -DLAYERS=1  nsToken.cpp
Assertion failed: deptab[ code ] == dep.index(), file /set/taz/builds/fcs0406/in
tel-S2/lang/cafe/resources/cdr/inc/c_compress.h, line 170
 >> Signal 6:
    while processing nsToken.cpp at line 0.
gmake[3]: *** [nsToken.o] Error 1
gmake[3]: Leaving directory `/home/doehrm/mozilla/htmlparser/src'
gmake[2]: *** [install] Error 2
gmake[2]: Leaving directory `/home/doehrm/mozilla/htmlparser'
gmake[1]: *** [install] Error 2
gmake[1]: Leaving directory `/home/doehrm/mozilla'

Should I recreate an .i file for this?

(Reporter)

Comment 8

18 years ago
Created attachment 10767 [details]
nsToken.i - Signal 6 error

Comment 9

18 years ago
Last night I decided to build Mozilla on Solaris Intel myself with
Workshop 6 to see if I could reproduce what doehrm was seeing.

I can. I get the same assertion failure. This is with a completely 
clean mozilla source tree (ie no existing .o's compiled before with
SC5.0).

I added these comments, and a pointer to my build location and the
location of the build ttanscript to Sun compiler bug 4348105. The
following evaluation comment was then added to that bug report by
one of the engineers in the compiler group:

"Looking at the build results (see Comments), it appears that
multiple parallel compiles are not properly locking the
template cache state file, and one process overwrites it
while another is reading it."

I'll forward more information on this when it's available.
(Assignee)

Comment 10

18 years ago
The entire build process should be serial unless gmake -jn is used.  Recent
versions of gmake are known to be buggy though.  Which version of gmake is being
used?  The current recommended version is 3.76.1 on Solaris.

(Reporter)

Comment 11

18 years ago
[doehrm@imohep ~]$ gmake -v
GNU Make version 3.78.1, by Richard Stallman and Roland McGrath.

I know about a bug in 3.79[.1] but not in 3.78

Comment 12

18 years ago
The Sun compiler engineer has further evaluated Sun bug #4348105. Here is
his comments:

"CC driver has a buffer over-run generating -ptk data caused by the following
code:

        /* setup buffer for -ptk option */
	for (j = 0, size = 0; j < argc; j++)
          size = size + strlen( argv[j]);
	ptk_buffer = malloc(size+argc+1+50); /* extra 50 for quoting args of
					-Dxx='xxx yy' and for -xildoff */
        ptk_buffer[0] = '\0';

There are 69 -Dxx=yyy options in the failing case which would require
138 extra bytes not 50.  (Some space is available due to options
omitted from ptk string, but not enough.)"

Comment 13

18 years ago
Just to let you know that the compiler folks created a special version of
CC for me with a fix for this in. Using the previous "nightly" that I had
(from June 28), it successfully compiled the source files that it had 
problems with before, then after about 59 minutes, it failed with:

...
CC -library=iostream -o nsStyleContext.o -c -DOSTYPE=\"SunOS5\" -DOJI
-D_IMPL_NS_LAYOUT  -I../../../dist/include -I../../../include    
-I./../../html/base/src -I./../../html/style/src -I./../../xul/base/src
-I/usr/openwin/include   -KPIC  -mt -O  -DNDEBUG -DTRIMMED -DMOZILLA_CLIENT
-DBROKEN_QSORT=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino
-DMOZ_WIDGET_GTK=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DSTDC_HEADERS=1
-DHAVE_ST_BLKSIZE=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1
-DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1
-DHAVE_SYS_BYTEORDER_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1
-DHAVE_SYS_FILIO_H=1 -DHAVE_SYS_IPC_H=1 -DHAVE_SYS_SHM_H=1
-DHAVE_X11_EXTENSIONS_XSHM_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1
-DHAVE_SYS_VFS_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1
-DHAVE_LIBRESOLV=1 -DHAVE_LIBSOCKET=1 -DHAVE_LIBNSL=1 -DHAVE_LIBELF=1
-DHAVE_LIBINTL=1 -DHAVE_LIBPOSIX4=1 -DHAVE_LIBW=1 -D_REENTRANT=1 -DHAVE_RANDOM=1
-DHAVE_QSORT=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1
-DHAVE_SNPRINTF=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STATVFS=1 -DHAVE_MEMMOVE=1
-DHAVE_USLEEP=1 -DHAVE_GETTIMEOFDAY=1 -DGETTIMEOFDAY_TWO_ARGS=1
-DHAVE_DEV_ZERO=1 -DHAVE_IOS_BINARY=1 -DHAVE_OSTREAM=1 -DHAVE_CPP_EXPLICIT=1
-DHAVE_CPP_SPECIALIZATION=1 -DHAVE_CPP_MODERN_SPECIALIZE_TEMPLATE_SYNTAX=1
-DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS_CHANGING_USING=1
-DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_NAMESPACE_STD=1
-DHAVE_CPP_UNAMBIGUOUS_STD_NOTEQUAL=1 -DHAVE_CPP_NEW_CASTS=1
-DHAVE_CPP_DYNAMIC_CAST_TO_VOID_PTR=1
-DNEED_CPP_UNUSED_IMPLEMENTATIONS=1 -DHAVE_I18N_LC_MESSAGES=1 -DMOZ_MAIL_NEWS=1
-DMOZ_ENDER_LITE=1 -DNS_MT_SUPPORTED=1 -DMOZ_USER_DIR=\".mozilla\"
-DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1
-DLAYERS=1  nsStyleContext.cpp
"nsStyleContext.cpp", line 2035: Error: "nsStyleContextData::AddRef()" has
already been called and cannot be defined inline.

I've just grabbed last night's snapshot .tar.gz, unpacked it, configured
it, and after about 15 minutes it fails with:

...
CC -library=iostream -o nsString.o -c -DOSTYPE=\"SunOS5\" -DOJI -D_IMPL_NS_COM
-D_IMPL_NS_BASE  -I../../dist/include -I../../include    
-I/usr/openwin/include   -KPIC  -mt -O  -DNDEBUG -DTRIMMED -DMOZILLA_CLIENT
-DBROKEN_QSORT=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino
-DMOZ_WIDGET_GTK=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DSTDC_HEADERS=1
-DHAVE_ST_BLKSIZE=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1
-DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1
-DHAVE_SYS_BYTEORDER_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1
-DHAVE_SYS_FILIO_H=1 -DHAVE_SYS_IPC_H=1 -DHAVE_SYS_SHM_H=1
-DHAVE_X11_EXTENSIONS_XSHM_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1
-DHAVE_SYS_VFS_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1
-DHAVE_LIBRESOLV=1 -DHAVE_LIBSOCKET=1 -DHAVE_LIBNSL=1 -DHAVE_LIBELF=1
-DHAVE_LIBINTL=1 -DHAVE_LIBPOSIX4=1 -DHAVE_LIBW=1 -D_REENTRANT=1 -DHAVE_RANDOM=1
-DHAVE_QSORT=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1
-DHAVE_SNPRINTF=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STATVFS=1 -DHAVE_MEMMOVE=1
-DHAVE_USLEEP=1 -DHAVE_GETTIMEOFDAY=1 -DGETTIMEOFDAY_TWO_ARGS=1
-DHAVE_DEV_ZERO=1 -DHAVE_IOS_BINARY=1 -DHAVE_OSTREAM=1 -DHAVE_CPP_EXPLICIT=1
-DHAVE_CPP_SPECIALIZATION=1 -DHAVE_CPP_MODERN_SPECIALIZE_TEMPLATE_SYNTAX=1
-DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS_CHANGING_USING=1
-DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_NAMESPACE_STD=1
-DHAVE_CPP_UNAMBIGUOUS_STD_NOTEQUAL=1 -DHAVE_CPP_NEW_CASTS=1
-DHAVE_CPP_DYNAMIC_CAST_TO_VOID_PTR=1 -DNEED_CPP_UNUSED_IMPLEMENTATIONS=1
-DHAVE_I18N_LC_MESSAGES=1 -DMOZ_MAIL_NEWS=1 -DMOZ_ENDER_LITE=1
-DNS_MT_SUPPORTED=1 -DMOZ_USER_DIR=\".mozilla\" -DMOZ_DLL_SUFFIX=\".so\"
-DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1 -DLAYERS=1  nsString.cpp
"nsAlgorithm.h", line 72: Error: Formal argument iter of type char**& in call to
static nsCharSinkTraits<char*>::write(char**&, char*const*, unsigned) is being
passed char*.
"nsAWritableString.h", line 537:     Where: While instantiating
"copy_string<nsReadingIterator<char>, char*>(nsReadingIterator<char>,
nsReadingIterator<char>, char*)".
"nsAWritableString.h", line 537:     Where: Instantiated from
basic_nsAWritableString<char>::AppendFromPromise(const
basic_nsAReadableString<char>&).
"nsAWritableString.h", line 522:     Where: Instantiated from
basic_nsAWritableString<char>::AppendFromReadable(const
basic_nsAReadableString<char>&).
"nsAWritableString.h", line 306:     Where: Instantiated from non-template code.
"nsAlgorithm.h", line 72: Error: Formal argument s of type char*const* in call
to
static nsCharSinkTraits<char*>::write(char**&, char*const*, unsigned) is being
passed const char*.
"nsAWritableString.h", line 537:     Where: While instantiating
"copy_string<nsReadingIterator<char>, char*>(nsReadingIterator<char>,
nsReadingIterator<char>, char*)".
"nsAWritableString.h", line 537:     Where: Instantiated from
basic_nsAWritableString<char>::AppendFromPromise(const
basic_nsAReadableString<char>&).
"nsAWritableString.h", line 522:     Where: Instantiated from
basic_nsAWritableString<char>::AppendFromReadable(const
basic_nsAReadableString<char>&).
"nsAWritableString.h", line 306:     Where: Instantiated from non-template
code.^M2 Error(s) detected.

Sigh.

Comment 14

18 years ago
see bug 43826
http://bugzilla.mozilla.org/show_bug.cgi?id=43826

Comment 15

18 years ago
setting bug satus to New
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 16

17 years ago
Created attachment 18386 [details] [diff] [review]
jsinterp.i from mozilla/js/src
(Reporter)

Comment 17

17 years ago
I'm still on this bug :-)

I donwloaded the latest version of Forte Update-1 for Intel and started to 
compile (again).

[doehrm@imohep ~/mozilla/js/src]$ CC -V
CC: Sun WorkShop 6 update 1 C++ 5.2 2000/09/12

[doehrm@imohep ~/mozilla/js/src]$ cc -V
cc: Sun WorkShop 6 update 1 C 5.2 2000/09/12

[doehrm@imohep ~/mozilla/js/src]$ uname -a
SunOS imohep 5.7 Generic_106542-12 i86pc i386 i86pc

but now in mozilla/js/src I'm getting


cc -o jsinterp.o -c -DOSTYPE=\"SunOS5\" -DOJI -DEXPORT_JS_API  -DJS_USE_SAFE_ARE
NA  -I../../dist/include     -I.    -KPIC -mt -O  -DNDEBUG -DTRIMMED -DBROKEN_QS
ORT=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino -DMOZ_WIDGET_GTK=1 -DMOZ_D
EFAULT_TOOLKIT=\"gtk\" -DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_INT16_T=1 -DH
AVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UINT16_T=1 -
DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -D
HAVE_SYS_FILIO_H=1 -DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_SYS_VFS_H
=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1 -DHAVE_LIBRESOLV=1 -DHAVE_L
IBSOCKET=1 -DHAVE_LIBNSL=1 -DHAVE_LIBELF=1 -DHAVE_LIBINTL=1 -DHAVE_LIBPOSIX4=1 -
DHAVE_LIBW=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_QSORT=1 -DHAVE_STRERROR=1 -DH
AVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STATV
FS=1 -DHAVE_MEMMOVE=1 -DHAVE_USLEEP=1 -DHAVE_RINT=1 -DHAVE_GETTIMEOFDAY=1 -DGETT
IMEOFDAY_TWO_ARGS=1 -DHAVE_DEV_ZERO=1 -DHAVE_IOS_BINARY=1 -DHAVE_OSTREAM=1 -DHAV
E_CPP_EXPLICIT=1 -DHAVE_CPP_SPECIALIZATION=1 -DHAVE_CPP_MODERN_SPECIALIZE_TEMPLA
TE_SYNTAX=1 -DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS_CHANGING_USING
=1 -DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_NAMESPACE_STD=1 -DHAVE_CPP_
UNAMBIGUOUS_STD_NOTEQUAL=1 -DHAVE_CPP_NEW_CASTS=1 -DHAVE_CPP_DYNAMIC_CAST_TO_VOI
D_PTR=1 -DNEED_CPP_UNUSED_IMPLEMENTATIONS=1 -DHAVE_I18N_LC_MESSAGES=1 -DMOZ_MAIL
_NEWS=1 -DMOZ_ENDER_LITE=1 -DNS_MT_SUPPORTED=1 -DMOZ_USER_DIR=\".mozilla\" -DMOZ
_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DHAVE_MOVEMAIL=1 -DJS_THREAD
SAFE=1 -DLAYERS=1  -DMOZILLA_CLIENT jsinterp.c
"jsinterp.c": [js_Interpret]: internal: SIGNAL: Segmentation Fault
cc: mcs failed for jsinterp.c
gmake: *** [jsinterp.o] Error 2

I attached the preprocessed .i file in case someone is interested.

Comment 18

17 years ago
Just some input here, I reran my Mozilla build from CVS on 12/11 and ran with
options --disable-debug and disable-tests and I got through this js bug. I have
reason to beleive it is the --enable-optimize flag that is blowing up Forte.
Although I just ran into another problem with nsAtomTable.cpp in xpcom that I
have to try to figure out. Thats my report for tonight.
(Assignee)

Comment 19

17 years ago
Setting milestones to Future.
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 20

17 years ago
cls, I think this bug can be closed off. I'm successfully building
tip-of-the-trunk Mozilla with the Forte 6 Update 1 compilers. It
needs a special (new) patch. The patch is:

109508-01 - SPARC
109509-01 - Intel

doerhm, can you verify that this combo indeed fixes the problem please?
(Reporter)

Comment 21

17 years ago
access1 doesn't show me this patch... is it released?

Comment 22

17 years ago
I don't know. It's certainly made it to the internal sunpatch machine, and
now has an official status (ie. no preceding T=testing nomclature). If it's
not there now, then I don't think it'll be long before it turns up.
Okay, let's keep this bug open until you have a chance to verify that the
patch works.
(Reporter)

Comment 23

17 years ago
I applied the patch that's now available on access1. The build runs fine until

js/src/jsinterp.c

Here the compiler still segfaults. I changed the compile while deleting the -O 
flag and it continued.

$ cat ~/.mozconfig
mk_add_options  MOZ_CVS_FLAGS=-q

ac_add_options  --disable-debug
ac_add_options  --enable-optimize
ac_add_options  --disable-tests
ac_add_options  --enable-mathml

When this build is finished I'll retry building without the --enable-optimize 
flag. 

Comment 24

17 years ago
We are seeing exactly the same thing in our builds, and have got around
it by adjusting the build of that single file, so that it's not built
with optimize turned on. We've filled a Bugtraq bug against the Sun compiler 
on this. When I've found out from the submitter what the bug number was, I'll
update this bug report too.

Comment 25

17 years ago
The Sun Bugtraq we entered against the compiler for this problem
was marked as a duplicated of #4395783. This has been fixed,
but not in patch 109508-01/109509-01. When I know a patch number
I'll add it to this bug report.
(Reporter)

Comment 26

17 years ago
Just for information: It compiles fine with 

CC: Sun WorkShop 6 update 2 C++ 5.3 2001/01/06

The autoconf 'bug' (-DHAVE_CPP_PARTIAL_SPECIALIZATION) is fixed in 6U2.
(Reporter)

Comment 27

17 years ago
Status update: Mozilla compiles fine but SIGSEGV at start:

[doehrm@sun9 ~/mozilla/dist/bin]$ ./mozilla
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  
LD_LIBRARY_PATH=.::/opt/sfw/lib:/opt/sfw/mysql/lib:/opt/sfw/lib/qt:/opt/sfw/kde/
lib
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Registering plugin 0 for: "*","All types",".*"
Segmentierungsfehler - Speicherabbild 'core' geschrieben

<snip>

(dbx) where
=>[1] nsXULTreeOuterGroupFrame::EndBatch(0x83875d8, 0xdd044b48, 0x8043178), at 
0xdce9bc42
  [2] nsContainerBox::CreateBoxList(0x8387528, 0x8043220, 0x83875d8, 0x8387538, 
0x838753c), at 0xdcec1ed8
  [3] nsContainerBox::InitChildren(0x8387528, 0x8043220, 0x8387580), at 
0xdcec2bf8
  [4] nsBoxFrame::SetInitialChildList(0x83874f4, 0x82b1bd8, 0x0, 0x8387580), at 
0xdced8eaa
  [5] nsCSSFrameConstructor::ConstructXULFrame(0x82d07a0, 0x82ea568, 0x82b1bd8, 
0x8044cd8, 0x830cb18, 0x8387468, 0x81ca750, 0x6, 0x83927a0, 0x8043c2c, 0x0, 
0x80435f8), at 0xdce1abed
  [6] nsCSSFrameConstructor::ConstructFrameInternal(0x82d07a0, 0x82ea568, 
0x82b1bd8, 0x8044cd8, 0x830cb18, 0x8387468, 0x81ca750, 0x6, 0x83927a0, 
0x8043c2c, 0x0), at 0xdce1fba9
  [7] nsCSSFrameConstructor::ConstructFrame(0x82d07a0, 0x82ea568, 0x82b1bd8, 
0x8044cd8, 0x830cb18, 0x8387468, 0x8043c2c), at 0xdce1f0b0
  [8] nsCSSFrameConstructor::ProcessChildren(0x82d07a0, 0x82ea568, 0x82b1bd8, 
0x8044cd8, 0x8329da0, 0x8387468, 0x0, 0x8043c2c, 0x0, 0x0), at 0xdce32dc3
  [9] nsCSSFrameConstructor::ConstructXULFrame(0x82d07a0, 0x82ea568, 0x82b1bd8, 
0x8044cd8, 0x8329da0, 0x83873dc, 0x81ca750, 0x6, 0x8392760, 0x80444d4, 0x0, 
0x8043ef4), at 0xdce1ab94
  [10] nsCSSFrameConstructor::ConstructFrameInternal(0x82d07a0, 0x82ea568, 
0x82b1bd8, 0x8044cd8, 0x8329da0, 0x83873dc, 0x81ca750, 0x6, 0x8392760, 
0x80444d4, 0x0), at 0xdce1fba9
  [11] nsCSSFrameConstructor::ConstructFrame(0x82d07a0, 0x82ea568, 0x82b1bd8, 
0x8044cd8, 0x8329da0, 0x83873dc, 0x80444d4), at 0xdce1f0b0
  [12] nsCSSFrameConstructor::ProcessChildren(0x82d07a0, 0x82ea568, 0x82b1bd8, 
0x8044cd8, 0x8307138, 0x83873dc, 0x1, 0x80444d4, 0x0, 0x0), at 0xdce32dc3
  [13] nsCSSFrameConstructor::ConstructDocElementFrame(0x82d07a0, 0x82ea568, 
0x82b1bd8, 0x8044cd8, 0x8307138, 0x8387350, 0x837d3e0, 0x8044da0), at 0xdce131c6
  [14] nsCSSFrameConstructor::ContentInserted(0x82d07a0, 0x82b1bd8, 0x0, 
0x8307138, 0x0, 0x0), at 0xdce26557
  [15] StyleSetImpl::ContentInserted(0x82d0650, 0x82b1bd8, 0x0, 0x8307138, 
0x0), at 0xdd9c38d8
  [16] PresShell::InitialReflow(0x82ea568, 0xf, 0xf), at 0xdcd4cdcb
  [17] nsXULDocument::StartLayout(0x8284a80), at 0xdd80fe14
  [18] nsXULDocument::ResumeWalk(0x8284a80), at 0xdd817c79
  [19] nsXULDocument::EndLoad(0x8284a80), at 0xdd802fa9
  [20] XULContentSinkImpl::DidBuildModel(0x8345f78, 0x1), at 0xdd7efe95
  [21] CWellFormedDTD::DidBuildModel(0x8334ad0, 0x0, 0x1, 0x830cfe8, 
0x8345f78), at 0xddd35314
  [22] nsParser::DidBuildModel(0x830cfe8, 0x0), at 0xddd24857
  [23] nsParser::ResumeParse(0x830cfe8, 0x1, 0x1), at 0xddd25f72
  [24] nsParser::OnStopRequest(0x830cfe8, 0x83347b0, 0x0, 0x0), at 0xddd270c7
  [25] nsJARChannel::OnStopRequest(0x83347b0, 0x82637d4, 0x0, 0x0), at 
0xde175e12
  [26] nsOnStopRequestEvent::HandleEvent(0x834e488), at 0xde0d2c12
  [27] nsARequestObserverEvent::HandlePLEvent(0x834e48c), at 0xde0d1517
  [28] PL_HandleEvent(0x834e48c), at 0xdfaa5358
  [29] PL_ProcessPendingEvents(0x8149870), at 0xdfaa5179
  [30] nsEventQueueImpl::ProcessPendingEvents(0x815e5f0), at 0xdfaa74e4
  [31] event_processor_callback(0x815e5f0, 0x5, 0x1), at 0xde8400fe
  [32] our_gdk_io_invoke(0x825b1d8, 0x1, 0x823e658), at 0xde83fb33
  [33] g_io_unix_dispatch(), at 0xde5737e8
  [34] 0x0(), at 0xffffffff
  [35] 0x815e5f0(), at 0x815e5ef
(dbx) 

it was compiled with

[doehrm@sun9 ~]$ cat .mozconfig 
mk_add_options  MOZ_CVS_FLAGS=-q
#mk_add_options BUILD_MODULES=psm

ac_add_options  --disable-debug
ac_add_options  --disable-tests
ac_add_options  --enable-mathml
ac_add_options  --enable-svg

I installed the most current patches available. Even 6U2 is not working any 
more. 

[doehrm@sun9 ~]$ CC -V
CC: Sun WorkShop 6 update 1 C++ 5.2 Patch 109509-02 2001/03/04
[doehrm@sun9 ~]$ cc -V
cc: Sun WorkShop 6 update 1 C 5.2 Patch 109514-03 2001/03/12
usage: cc [ options] files.  Use 'cc -flags' for details

(Reporter)

Comment 28

17 years ago
It willl build - indeed.

After having patched the compiler and a few attempts, I got the build finished, 
though without having '--disable-debug' in the .mozconfig the resulting binary 
will not run:

[doehrm@sun9 ~/mozilla/dist/bin]$ ./mozilla
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  
LD_LIBRARY_PATH=.:./plugins::/opt/sfw/lib:/opt/sfw/mysql/lib:/opt/sfw/lib/qt:/op
t/sfw/kde/lib
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Segmentierungsfehler - Speicherabbild 'core' geschrieben



Comment 29

17 years ago
Reporter: I know this is your bug, but could we please limit it to one area 
(building/faulting in Forte compilation)?  Unless a g++ or Forte5 build does 
not have this problem ... Otherwise these bugs become impossible to close...

Because you're currently building, i'd suggest we resolve this bug as fixed, 
and you file a new bug for the current crash (or finding a current bug).

Bug 66583 is about nsXULTreeOuterGroupFrame::EndBatch although it probably 
isn't related.  Tree crashes belong to hyatt, whereas these build issues belong 
to cls/richb. ... Actually, I don't see why richb doesn't own this bug since he 
has been acting as the contact.
(Reporter)

Comment 30

17 years ago
I set the bug to WORKSFORME and I'll file a new one for the running issue, ok?
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 31

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.