Last Comment Bug 436276 - SVG SMIL: Add support for animating non-length SVG attributes
: SVG SMIL: Add support for animating non-length SVG attributes
Status: RESOLVED FIXED
[parity-Opera][parity-webkit]
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal with 12 votes (vote)
: mozilla9
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 216462 515116 522267 522306 522308 534028 540478 540479 540588 541882 541884 545042 589436 589439 602759 617623
Blocks: svg11tests enablesmil 690486
  Show dependency treegraph
 
Reported: 2008-05-29 05:28 PDT by Jeff Schiller
Modified: 2011-09-29 12:44 PDT (History)
18 users (show)
jwatt: wanted‑next+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case to illustrate the problem. (445 bytes, image/svg+xml)
2008-05-29 05:28 PDT, Jeff Schiller
no flags Details
Another test-case (3.69 KB, image/svg+xml)
2009-05-04 05:56 PDT, Rafał Miłecki
no flags Details
One more test-case for text elements. (3.87 KB, image/svg+xml)
2009-05-05 03:09 PDT, Rafał Miłecki
no flags Details

Description Jeff Schiller 2008-05-29 05:28:45 PDT
Created attachment 322926 [details]
Test case to illustrate the problem.

Simple test to animate font-size CSS property, which does not yet work in the hg repository for SMIL at http://hg.mozilla.org/users/dholbert_mozilla.com/smil-patches/

See Bug 216462, Comment #58 for more details.
Comment 1 Robert Longson 2008-05-29 09:06:09 PDT
As far as I know the bug 216462 only implements animation of attributes which are lengths.
Comment 2 Jeff Schiller 2008-05-29 09:18:45 PDT
Thanks, that's good to know.  My understanding from discussion with Daniel was that I could create bugs to cover missing functionality.
Comment 3 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2008-05-29 09:21:16 PDT
(In reply to comment #2)
> My understanding from discussion with Daniel was
> that I could create bugs to cover missing functionality.

Yes, please do.  (thanks for making this one)
Comment 4 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2008-05-29 17:01:04 PDT
Rather than overloading the "URL" field to point to the hg repository, I'm trying out a whiteboard syntax suggested by timeless, for dealing with hg branches: "[hgurl:c0]", which means "this is a bug on a specific hg repo, whose url is in comment 0".

(alternately, we could just put the whole hg URL in the whiteboard, but hg urls are probably too long for that)
Comment 5 Rafał Miłecki 2009-05-04 05:56:51 PDT
Created attachment 375599 [details]
Another test-case

This test-case animates:
y and rx for rect
r for circle
rx for ellipse
points for polyline
points for polygon
Comment 6 Lars Gunther 2009-05-04 13:36:13 PDT
Since that last testcase works perfectly in Opera shouldn't this bug be labeled parity-opera? (It almost works in Safari 4 beta as well.)
Comment 7 Rafał Miłecki 2009-05-04 13:47:53 PDT
(In reply to comment #6)
> Since that last testcase works perfectly in Opera shouldn't this bug be labeled
> parity-opera? (It almost works in Safari 4 beta as well.)

I am not sure, do you suggest there is something in my test case that doesn't follow SVG standard?

Yes, it works in Opera - just like the first test case. However it wasn't written to match Opera's SVG implementation. It's as simply as the fact that Opera just supports SVG really well.
Comment 8 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2009-05-04 14:16:46 PDT
Lars: Yes, it should -- thanks.

Rafał: I think you misunderstood Lars' meaning from comment 6 -- he's simply saying that this bug is for a feature that Opera (and WebKit) already supports, and we should label it as such.  (also -- thanks for the great testcase!)
Comment 9 Robert Longson 2009-05-05 01:48:06 PDT
*** Bug 491268 has been marked as a duplicate of this bug. ***
Comment 10 Rafał Miłecki 2009-05-05 03:07:35 PDT
Ouch, I didn't understand Lars. Thanks for explaining.

I reported bug #491268 which is duplicate of this one as I didn't know x and y attributes of text are lists. I'll attach test-case for testing textx elements with single values in x/dx/y/dy.
Comment 11 Rafał Miłecki 2009-05-05 03:09:12 PDT
Created attachment 375790 [details]
One more test-case for text elements.

Nothing special, just animating x/dx/y/dy attributes.
Comment 12 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2010-08-02 14:19:22 PDT
FWIW, all of this bug's testcases now work in mozilla-central nightly builds, except for the last two lines of the attachment 375599 [details]
(for 'points'), which is being tracked in bug 522308.
Comment 13 Silvia Pfeiffer 2010-08-11 17:39:51 PDT
What about supporting begin="click" or begin="mouseover" in animations? As far as I know, they don't work yet. At least the following example didn't work, while it works in Webkit-based browsers and in Opera.


<circle id="circle" cx="240" cy="135" r="135" fill="black" pointer-events="all">
  <set attributeName="r" attributeType="XML" to="240" begin="mouseover" dur="6s"/>
</circle>
Comment 14 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2010-08-11 18:26:31 PDT
That's bug 485157, whose patches are currently undergoing review.
Comment 15 Silvia Pfeiffer 2010-08-12 05:37:16 PDT
awesome - sorry my search didn't find it
Comment 16 Robert Longson 2011-09-26 07:59:08 PDT
Closing as there are no more types left.
Comment 17 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-09-26 15:36:42 PDT
Can we get rid of nsISVGValue/nsSVGValue and all related code now?
Comment 18 Robert Longson 2011-09-26 21:18:27 PDT
There's nsSVGStringProxyValue left which creates proxy objects for XUL I think for when we have attributes that won't parse e.g. x="?" which is then replaced. I imagine that could be rewritten though and nsISVGValue could go as part of that.
Comment 19 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-09-26 21:46:45 PDT
Is that actually still used? It looks to me like it wraps attributes which are themselves represented as nsISVGValues, and we've removed all those.

Note You need to log in before you can comment on or make changes to this bug.