Extra separator in the History menu when there are no history items

RESOLVED DUPLICATE of bug 589521

Status

--
trivial
RESOLVED DUPLICATE of bug 589521
11 years ago
8 years ago

People

(Reporter: alqahira, Unassigned)

Tracking

({polish})

Details

When we have less than 12 items in the History menu, we show an extra separator where the folders would be, i.e. we have two separators between individual items at the top and "Clear History…" at the bottom.

We should remove one of them until there are folders to be shown.

Also, in the no-history case, we still have 2 between "Show History" and "Clear History…"; in a complete menu, there are 3 there, so we're making some progress.

Stuart thought he'd fixed both of these at one point, so this might even be a regression.
On the trunk, we just have the "no history" bug, i.e. 

Show History
--------------
--------------
Clear History…
Summary: When < 12 history items, there is an extra separator in the History menu → Extra separator in the History menu when there are no history items

Updated

10 years ago
Duplicate of this bug: 467031

Comment 3

10 years ago
I cant view my history at all. when i look there is nothing there. can anyone help me?

Comment 4

10 years ago
(In reply to comment #3)
> I cant view my history at all. when i look there is nothing there. can anyone
> help me?

Bugzilla is not a technical support forum; you should use our tech support forums for this:

http://forums.mozillazine.org/viewforum.php?f=12

cl
Duping forward, because bug 589521 has a patch.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589521
You need to log in before you can comment on or make changes to this bug.