Post update restart UI is broken

RESOLVED FIXED in mozilla1.9.1b2

Status

()

RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: mossop, Assigned: rstrong)

Tracking

Trunk
mozilla1.9.1b2
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
When app.update.showInstalledUI is true after an update has been applied and the application started the update window is meant to appear notifying the user that the update was successful. The update window does appear however it says that a new update has been found. The problem is that the patch status is not getting retrieved correctly, its status is "null" rather than "succeeded"
Product: Firefox → Toolkit
Duplicate of this bug: 459894
I checked the latest 1.8.0 branch and it is broken there as well.

This is due to cleanupActiveUpdate being called after the call to showUpdateInstalled. Basically, the update param for the showUpdateInstalled call is being nulled out and it needs to be to cleanup after the update. It would likely be best to make showUpdateInstalled not take an update param and use a different method for determining the last update.
fixed by the checkin of bug 324121.
Assignee: nobody → robert.bugzilla
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b2
You need to log in before you can comment on or make changes to this bug.