Closed Bug 436770 Opened 13 years ago Closed 11 years ago

title or alt tooltips are not visible for disabled textbox

Categories

(Firefox :: General, defect)

3.6 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 274626

People

(Reporter: scheder, Unassigned)

Details

(Keywords: ue, uiwanted)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

a disabled textbox (i.e., <input type='text' alt='abc' title='abc' disabled='disabled'>) does not show its title attribute as a tooltip. It works fine for enabled textboxes but not for disabled ones. This would be especially useful for disabled textboxes because the user cannot scroll to the right to see any text that is cut-off. The same functionality works just fine in IE 7.

Reproducible: Always

Steps to Reproduce:
1. create page with <input type='text' alt='abc' title='abc' disabled='disabled'>
2. hover over textbox
3. notice that tooltip does NOT show-up
Actual Results:  
no tooltip shows up

Expected Results:  
tooltip should show up
Version: unspecified → 2.0 Branch
Keywords: ue, uiwanted
this happens in both Firefox 2 and 3 branches.
This bug is existent also for checkbox and radio button elements and not yet fixed. A great pity!
This is a duplicate of #274626
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Issue is still present with the current Firefox 3.6.3
Version: 2.0 Branch → 3.6 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 274626
Was just testing a button and it seems like this is still an issue in FF 7.0.1 (Mac).
You need to log in before you can comment on or make changes to this bug.