Closed Bug 436873 Opened 14 years ago Closed 13 years ago

Forwarded bug: Iceweasel jumps focus over viewports when opening a page using extenal call

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 263553

People

(Reporter: azatoth, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080404 Iceweasel/2.0.0.14 (Debian-2.0.0.14-2)
Build Identifier: 

Package: iceweasel
Version: 3.0~b5-3
Severity: normal

When I'm opening a page from an extenal application (Xchat here), the
main iceweasel window is moved to the current viewport (using xfce4),
and is stealing focus.

I feel this is a bug (I want to try have some order of my windows), but
perhaps it's an "feature", I don't know, but I report is as an bug.


-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-1-686 (SMP w/1 CPU core)
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages iceweasel depends on:
ii  debianutils            2.28.4            Miscellaneous utilities specific t
ii  fontconfig             2.5.0-2           generic font configuration library
ii  libatk1.0-0            1.22.0-1          The ATK accessibility toolkit
ii  libc6                  2.7-10            GNU C Library: Shared libraries
ii  libcairo2              1.6.4-1           The Cairo 2D vector graphics libra
ii  libdbus-1-3            1.2.1-1           simple interprocess messaging syst
ii  libdbus-glib-1-2       0.74-2            simple interprocess messaging syst
ii  libfontconfig1         2.5.0-2           generic font configuration library
ii  libfreetype6           2.3.5-1+b1        FreeType 2 font engine, shared lib
ii  libgcc1                1:4.3.0-3         GCC support library
ii  libglib2.0-0           2.16.3-2          The GLib library of C routines
ii  libgtk2.0-0            2.12.9-3          The GTK+ graphical user interface 
ii  libjpeg62              6b-14             The Independent JPEG Group's JPEG 
ii  libpango1.0-0          1.20.2-2          Layout and rendering of internatio
ii  libstdc++6             4.3.0-3           The GNU Standard C++ Library v3
ii  libx11-6               2:1.0.3-7         X11 client-side library
ii  libxrender1            1:0.9.4-1         X Rendering Extension client libra
ii  libxt6                 1:1.0.5-3         X11 toolkit intrinsics library
ii  procps                 1:3.2.7-8         /proc file system utilities
ii  psmisc                 22.6-1            Utilities that use the proc filesy
ii  zlib1g                 1:1.2.3.3.dfsg-12 compression library - runtime

iceweasel recommends no packages.

-- no debconf information




Reproducible: Always
Same thing here under KDE, FWIW.
Still a problem in FF 3.0rc2.

UA: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008062113 Iceweasel/3.0 (Debian-3.0~rc2-2)
about:config to set browser.tabs.loadDivertedInBackground to true

If that behavior is not what you want then this is a dupe of bug 263553.
(In reply to comment #3)
> about:config to set browser.tabs.loadDivertedInBackground to true

I want it to be false, i.e. the new tab should become the current tab.

> If that behavior is not what you want then this is a dupe of bug 263553.

Probably. BTW, shouldn't it block the tracking bug 88810?
Possibly, though I don't really like long lived tracking bugs. They have a tendency to go off topic or get out of scope.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263553
You need to log in before you can comment on or make changes to this bug.