Series are not removed after deletion of component

RESOLVED DUPLICATE of bug 247936

Status

()

task
RESOLVED DUPLICATE of bug 247936
11 years ago
11 years ago

People

(Reporter: mozilla_by, Unassigned)

Tracking

3.1.4
x86
Linux

Details

Series are not removed after deletion of component.

Steps to reproduce:
-------------------

1) Create a component
2) Delete the created component
3) Create a component with the name of previously deleted component

Bugzilla returns:
-----------------

Software error:

DBD::mysql::db do failed: Duplicate entry '1-7-37-All Open' for key 2 [for Statement "INSERT INTO series (creator, category, subcategory, name, frequency, query, is_public) VALUES (?, ?, ?, ?, ?, ?, ?)"] at Bugzilla/Series.pm line 199
	Bugzilla::Series::writeToDatabase('Bugzilla::Series=HASH(0x8d4e1b8)') called at Bugzilla/Component.pm line 305
	Bugzilla::Component::_create_series('Bugzilla::Component=HASH(0x8482a98)') called at Bugzilla/Component.pm line 124
	Bugzilla::Component::create('Bugzilla::Component', 'HASH(0x8c16490)') called at /var/www/hosts/bugzilla-3-1/editcomponents.cgi line 138
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 247936
You need to log in before you can comment on or make changes to this bug.