Status

Directory
PerLDAP
P2
major
RESOLVED FIXED
19 years ago
19 years ago

People

(Reporter: Leif Hedstrom, Assigned: Leif Hedstrom)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
For some reason it core dumps when used in a CGI script (I have the examples).
The same scripts works great on Solaris, but crashes on Linux with this stack:

(gdb) bt
#0  0x400911ad in chunk_alloc (ar_ptr=0x400e6420, nb=24) at malloc.c:2616
#1  0x400910c5 in __libc_malloc (bytes=19) at malloc.c:2561
#2  0x808cdde in Perl_safemalloc (size=19) at util.c:89
#3  0x809687f in save_hek (str=0xbffff95c "_<(eval 9)", len=10, hash=812736109)
    at hv.c:72
#4  0x8098f47 in Perl_share_hek (str=0xbffff95c "_<(eval 9)", len=10,
    hash=812736109) at hv.c:1209
#5  0x8096f89 in Perl_hv_store (hv=0x80fd36c, key=0xbffff95c "_<(eval 9)",
    klen=10, val=0x828d4a4, hash=812736109) at hv.c:328
#6  0x8096aa6 in Perl_hv_fetch (hv=0x80fd36c, key=0xbffff95c "_<(eval 9)",
    klen=10, lval=1) at hv.c:161
#7  0x805dcb6 in Perl_gv_fetchfile (name=0xbffffa86 "(eval 9)") at gv.c:69
#8  0x80d0811 in Perl_pp_entereval (thr=0x80fcf40) at pp_ctl.c:2648
#9  0x80eb330 in Perl_runops_standard () at run.c:30
#10 0x80594ff in perl_run (sv_interp=0x80fcf30) at perl.c:1088
#11 0x805670f in main (argc=3, argv=0xbffffbb4, env=0xbffffbc4)
    at perlmain.c:45
(gdb)



This has me really stumped...
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2

Updated

19 years ago
Summary: Core dump with CGI → [PP]Core dump with CGI
(Assignee)

Comment 1

19 years ago
*** Bug 11106 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
This was fixed with the API.xs.
You need to log in before you can comment on or make changes to this bug.