Print Selection only prints first page

RESOLVED DUPLICATE of bug 243842

Status

()

RESOLVED DUPLICATE of bug 243842
11 years ago
9 years ago

People

(Reporter: xanderwe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

I highlighted the complete article from Date to just before comments at the URL above and chose file > print, and selected "Print Selection" but only the first page printed (it should have been many pages).  I tested this with two different printers.

The footer reads "1 of 1".

Reproducible: Always

Steps to Reproduce:
1. Highlight from "Monday, June 2, 2008" to "Less content, more often."
2. Click File > Print
3. Select Print Range > Selection (radio button)
4. Click Print
Actual Results:  
Only one page prints, with page 1 of 1 at the bottom.

Expected Results:  
Should print many pages.

I tried printing with the same steps in IE6 and it worked.

Comment 1

11 years ago
Easily reproducible even when printing to PDF or PS, in both FF3 and FF2.  (on Linux here)  However, just for this page; some other pages let me print multi-page selections fine.

This looks like a dupe of bug 243842, but the testcase there prints fine for me.  That bug hasn't been touched since 2006, so it may just be obsolete?  For now, I'll confirm this until someone else can weigh in.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 2

9 years ago
I run into this quite often (from FF 2.x on at least) - just on some web pages.  Since I almost always print to file and print later I can lose a lot of time and work if I don't notice it right when it happens so I almost always switch out of FF into a file viewer to make sure it worked.  It's pretty annoying.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 243842
You need to log in before you can comment on or make changes to this bug.