mozilla-central builds happen too often

RESOLVED DUPLICATE of bug 472930

Status

P3
normal
RESOLVED DUPLICATE of bug 472930
11 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

With the slew of checkins into mozilla-central we are getting a ridiculous amount of builds happening. We don't want to go 6 or 8 hours without a new build, but we also shouldn't be building "periodic" (not on-change) builds when there are many checkins. Nick suggested triggering builds after 2 hours of idle time, which makes a lot of sense to me.

Open to other ideas as well.

Comment 1

11 years ago
Yes, that's what I thought it was doing... periodic should be "two hours of idle" not "every 2 hours"
Agreed; an on-landing build should reset the 2-hour clock to 0.
(Assignee)

Comment 3

11 years ago
I'm testing a patch to fix this.
Whiteboard: [testing on staging]
(Assignee)

Updated

11 years ago
Priority: -- → P2
(Assignee)

Comment 4

11 years ago
I'm still working on this. The fix is a little more complicated than I first thought.
Assignee: nobody → bhearsum
(Assignee)

Updated

11 years ago
Priority: P2 → P3
(Assignee)

Comment 5

11 years ago
I got distracted from this for awhile. I think I've got working code right now. I'm testing it on staging while I wait for one of the upstream Buildbot people to have a look.
Priority: P3 → P2
(Assignee)

Comment 6

10 years ago
Created attachment 330059 [details] [diff] [review]
idle scheduler

My latest patch is working fine on staging but won't make the cut for Buildbot 0.7.8, which is to be released next week. I plan to import 0.7.8 in short-order and then land this patch in our tree.
(Assignee)

Updated

10 years ago
Depends on: 449583
(Assignee)

Updated

10 years ago
Priority: P2 → P3
Whiteboard: [testing on staging]
(Assignee)

Comment 7

10 years ago
This got solved in a different way over in 472930
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 472930
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.