All users were logged out of Bugzilla on October 13th, 2018

Select dropdown setting CSS width style disables keyboard shortcut

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: surturgomi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

If you set the CSS "width" property of a <select> dropdown, Firefox loses the functionality associated with auto-scrolling to the item associated with a key press.  It will still select the item, but will not scroll to that location as it normally does.

Reproducible: Always

Steps to Reproduce:
1. Create a <select> dropdown with more <option> tags than will fit in the viewable area.
2. Add a style="width:___px" attribute to the <select> dropdown with a value larger than the width of the longest option.
3. Open the test page, click the dropdown arrow, and type a key that would normally scroll the list down.
Actual Results:  
It will select the item, but will not scroll.

Expected Results:  
It should select the item and scroll to its location in the dropdown (which it does without the width style tag).

Comment 1

11 years ago
Can you please provide a testcase for this issue?

Comment 2

11 years ago
Derrick, can you ascertain whether this also happens in Firefox 3?

Thanks!
(Reporter)

Comment 3

10 years ago
I tested this out on Firefox 3, and no, it does not seem to be happening.  Something along the way must've taken care of it.  That satisfies my needs, since most of my clients will be porting to version 3 relatively quickly, but if you are still looking for a reproducible test-case to fix it in legacy versions, feel free to let me know and I can provide something.

Thanks!

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.