festo.com - menu names only visible when hovered, due to color:transparent

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: Thiemo Paulus, Unassigned)

Tracking

({qawanted, regression})

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The menue of these page are not shown correct. You can see content of the menue only if your mouse goes over. This error was already in the very first version of Firefox 1.x.ß All other known browsers incl. Firefox 1.x worked right.

Reproducible: Always

Steps to Reproduce:
1.call link http://www.festo.com/INetDomino/gb/en/company_portal_gb.htm
2.
3.


Expected Results:  
works like Firefox 1.x
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
I can reproduce this on Windows. Regression range is
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1169689860&maxdate=1169695619
Caused by Bug 347912 ? 
Blocks: 347912
Component: General → Layout
Keywords: qawanted, regression
Product: Firefox → Core
QA Contact: general → layout
Version: 3.0 Branch → Trunk
This is a regression from Firefox 2.
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9.0.1?

Updated

10 years ago
Summary: Javascript mistake → Menu names on festo.com are only visible when hovered

Comment 3

10 years ago
DOM Inspector shows that the page uses "color:transparent" for the menus.  That will, of course, make the text invisible in any browser that supports the "transparent" color name.

http://www.festo.com/INetDomino/repository/menu.css
Assignee: nobody → english-us
Component: Layout → English US
Flags: blocking1.9.0.1?
OS: Windows XP → All
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Hardware: PC → All
Version: Trunk → unspecified

Comment 4

10 years ago
The same thing happens in Safari.

I wonder what the site author was thinking.  This is the second site I've seen that used color:transparent and broke as a result, but the other one is already fixed.
Summary: Menu names on festo.com are only visible when hovered → festo.com - menu names only visible when hovered, due to color:transparent

Comment 5

10 years ago
Thiemo, do you work at Festo? I noticed you have a Festo e-mail address; if you work there, please pass this along to the Web site team. Comment 3 explains how to fix the problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.