Can´t copy and paste from a google image search to CorelDraw for example or can´t Drag´drop

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: ohm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9) Gecko/2008052906 Firefox/3.0

I open Firefox and CorelDraw to do some homework to my kids. So, I search for any image in Google and then I just give right click and select "copy image", then go to CorelDraw (ver X4), and give right click and select paste, but it don´t do anything.

Reproducible: Always

Steps to Reproduce:
1. search any image in google
2. copy the image and paste it into a desktop aplication
3. nothing happens
Actual Results:  
When I give a right click + paste, nothing happens, when I go to "edit" option of the aplication, and select "paste", it puts the "link to the image"
(Reporter)

Updated

11 years ago
Severity: normal → major
(Reporter)

Updated

11 years ago
Keywords: access

Comment 1

11 years ago
this could be related to Bug: 437376

Comment 2

11 years ago
or you could be choosing "copy image location" rather than "copy image"
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> or you could be choosing "copy image location" rather than "copy image"
> 

I make more tests, but with the same results. I´m not choosing "copy image location", in this case I paste and it puts the link to the image. When I choose "copy image" it don´t do anything.

And the problem with the Drag'n Drop, it works fine with FF2, but now it doesn´t.

About the Bug: 437376 I can´t find information about it.

Thanks for your comments.

Comment 4

11 years ago
...I have stumbled upon the same problem. Since upgrading to Firefox 3, I cannot paste any images from the FF clipboard to Corel X4. Safe mode doesn't help either. In any other application (Photospho, Excel, etc.) this works fine. What is really strange - and what in my opinion makes it at least half a Firefox problem - is the fact that the copying and pasting works fine when using the IE Engine (IE Tab add-on) AND that it worked before the update to FF3. Any help will be hugely appreciated!

Comment 5

11 years ago
I can confirm the issue. The copy/paste or drag/drop works(-ed) fine in FF2 (all releases). In FF3, if you drag/drop all you get is a URL for the image. In Photo-Paint, if you right-click/copy a bitmap you can do a File | New from Clipboard and it will paste the image. However, In Draw, for some reason you cannot paste the image even though the application "sees" that there is a bitmap in the clipboard. This behavior is easily duplicated in the current version of the Draw Suite (X4) and back to at least v12 (the oldest version I have on this computer). 

Print-screens, copy/pastes from other applications work fine with the Corel apps.

Comment 6

11 years ago
Using ff3, I cannot copy images from web pages into CorelDraw, using CorelDraw X3 on Vista Home Basic.  I was able to bring the image into PhotoPaint and Photoshop, creating new images from the clipboard.  When I tried to grab the image with MS IE, it worked fine, pasting into CorelDraw (I had started to wonder in my OLE function in CorelDraw had been corrupted).

Updated

10 years ago
Duplicate of this bug: 494568

Comment 8

10 years ago
This problem seems to have been solved with the latest patch for Corel X4. Since installing it, copying images works fine again.
WFM per comment 8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Keywords: access
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.