{compat} Table border=0 ignored

VERIFIED DUPLICATE of bug 5821

Status

()

Core
Layout: Tables
P5
major
VERIFIED DUPLICATE of bug 5821
19 years ago
18 years ago

People

(Reporter: cpratt, Assigned: buster)

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
The table below should display without any border between the images in table
cells. However, white spaces are left between the images when displayed using
seamonkey. Nav 4.51 and IE 5 correctly put no white space between the images.
The images are available at http://schist/flash.

    <table border=0 cellpadding=0 cellspacing=0>
      <tr><td><a
href="http://signup.flash.net/cgi-bin/pin_webd/cgi-bin/pin_create_form.cgi.pl"><
img src="f_join2.gif" height=118 width=142 border=0></a></td></tr>
      <tr><td><img src="f_contents.gif" height=51 width=142></td></tr>
      <tr><td><a href="about/index.html"><img src="f_about.gif" height=24
width=142 border=0></a></td></tr>
      <tr><td><a href="price/index.html"><img src="f_price.gif" height=26
width=142 border=0></a></td></tr>
      <tr><td><a href="numbers/index.html"><img src="f_numbers.gif" height=21
width=142 border=0></td></tr>
      <tr><td><a href="business/index.html"><img src="f_business.gif" height=23
width=142 border=0></a></td></tr>
      <tr><td><a href="news/index.html"><img src="f_news.gif" height=20
width=142 border=0></a></td></tr>
      <tr><td><a href="http://www.flashnetopportunity.com"><img src="f_fmi.gif"
height=22 width=142 border=0></a></td></tr>
      <tr><td><a href="investor/index.html"><img src="f_invest.gif" height=32
width=142 border=0></a></td></tr>
      <tr><td><a href="/flashnet.html"><img src="f_myfn.gif" height=23 width=142
border=0></a></td></tr>
      <tr><td><a href="sitemap/index.html"><img src="f_sitemap.gif" height=19
width=142 border=0></a></td></tr>
      <tr><td><img src="money.gif"></td></tr>
      <tr><td><a href="http://www.flashnetopportunity.com/"><img
src="mkmoney1.gif" border=0></a></td></tr>
    </table>

Updated

19 years ago
Assignee: karnaze → kipp

Comment 1

19 years ago
If the <a> is removed then the space is absent. In the following simpler example
after dumping frames, it looks like the line frame inside the area frame is too
short.

<html><body>
<table border=0 cellspacing=0 cellpadding=0>
 <tr>
  <td><a href=foo><img width=30 height=30
   src="file://s:/mozilla/dist/win32_d.obj/bin/res/samples/raptor.jpg"></td></a>
 <tr>
  <td><a href=foo><img width=30 height=30
  src="filex://s:/mozilla/dist/win32_d.obj/bin/res/samples/raptor.jpg"></td></a>
</table>
</html></body>

Updated

19 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P5
Summary: Table border=0 ignored → {compat} Table border=0 ignored

Comment 2

19 years ago
The layout is correct (according to css2) but is not compatible with nav4 so
I've made it a compatability bug...

Updated

19 years ago
Target Milestone: M6
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 5821 ***

Comment 4

19 years ago
Chris Pratt - could you please verify this as duplicate if you agree. Based on
the comments made, I can't determine that it is a dup. Thanks
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
I'm afraid this is out of my area of expertise - but if kipp sez it's a dupe,
I'm assuming it is. From the other bug: "Yet another example of a conflict
between nav compatability and css2's line-height and line-layout specification."
- that seems like it's a dupe to me. Marking verified.
You need to log in before you can comment on or make changes to this bug.